T50 pptp - Wyse and Linux - Wyse Thin Clients - Dell Community

T50 pptp

This question is not answered

T50 pptp

Hello

I have a few T50 Terminals deployed on a client site.
Once which is connected to the internet directly. We need to connect the Terminal to their corporate network using PPTP (Not sure but thats all they have).
Adding VPN details onto the T50 only lead to greyed out options.

Can anyone point me in the right direction,

And maybe a good resource on updating the T50 Software?

Thanks

All Replies
  • Can't help with the first bit of your question, but as for updating Firmware I've found the site isn't that helpful - only version 1.018 is available.
    I was given 1.021 by a Wyse representative, and also 1.022 (which isn't the stable release) so may be worth speaking to your sales rep, or failing that log a ticket in the self-service?

  • Firmware Update

    Hey Acra,

    Thanks for that, 1.018 will be fine, what I do need is the instructions to do so?
    I only found on the Wyse Documentation site a extremely complicated procedure of sucking off the current firmware and then pushing changes onto the drive?

    If you compare this with the existing Wyse update procedure it cannot be that complicated?

    We have other terminals which we just upgrade from an TFTP server, T50's wont.

  • Not sure on remote deploy, we only have a few units so have been doing the flash manually using Wyse's USB Firmware Tool. I've been trying to test the WDM but have to make do with a VM as I don't want to trash a server!

    I wrote some brief notes if they are any use:


    Code:
    Installing T50 Firmware Updates
    ======
    
    - Download required update file (normally .rar or .zip)
    
    - Extract file to known location
    
    - Install Wyse USB Firmware Tool
    
    - Ensure blank memory stick is inserted
    
    - Run USB Firmware Tool ***MUST RUN AS ADMIN*** (else it will reject stick)
    
    	- Select 'Configure the USB key to Copy/Pull or to Update/Push firmware'
    	- Set OS to T50 (right at top) and operation to 'Update or Push firmware'
    	- Browse to extracted firmware file, set file type to .xml and select Commands.xml
    	- Select USB and hit next. At this point it will flash the stick, 
    	  but if you forgot to run as admin it will say the stick is invalid.
    
    - Insert flashed memory stick into T50
    
    - When T50 is off, hold power and 'P' key until screen shows password, release both.
    
    - Password is 'Fireport'
    
    - Choose USB option and wait.
    
    - Once successful, will boot latest version.
  • Talking

    Yes thanks, they will be helpful!
    Ill try them tomorrow and post progress.

    I believe if we get to the newer version we could start using the FTP solution for future upgrades, so USB will work for now.

  • No problem 

    One thing to note with 1.018 is that it doesn't seem to like creating an RDP session to a load-balanced terminal server environment - for that we had to update to 1.021.

  • Thanks for the heads-up, the environment dont have load balancing... so should be OK. If not Ill have to get in touch with Wyse as you suggested and get a later version from them.

  • Worked!

    Thanks, followed the instructions and managed to create the USB Drive with the update. 
    Have to admit it is not the cleanest upgrade process I have seen, specially with with screen flashing so much trying to warn you not to turn off the device while updating. 

    And PPTP is now configurable and works. Still wont auto connect, but thats not to serious. 

    Thanks for the help.

  • No worries, figure it's good to share tips given how few people seem to have these things out there!
    The flashing screen during 'flashing' was really off-putting the first time I ran it!