Wyse T50 clipboard problem - Wyse and Linux - Wyse Thin Clients - Dell Community

Wyse T50 clipboard problem

This question is not answered

Wyse T50 clipboard problem

Hi,

We have several types of Wyse clients logging in on a Windows 2008 R2 SP1 terminal server.
Our latest Wyse T50 client is crashing when a logged-in user is trying to copy and paste within the terminal session. The RDP session is suddenly closed and the user must restart the RDP connection to continue working again. When the user is doing CTRL+C then the session is closed again.
I have tried the wlx.ini setting "RdpClipBoard=no" but that does not change anything.

Does anybody know how to fix this issue?

Wyse enhanced unbuntu linux T50 client
Build: 20110511-0_u-1.010
Unbuntu: 10.04.1 LTS
OS Version: 2.6.32-212-hedley
Bios: W7.0_213-EC_PVT0.1

Kind regards,
Rene.

All Replies
  • Wyse has responded to me that this is a known issue for the current T50 clients.
    They are working on a solution.

    Kind regards,
    Rene.

  • Any further updates from WYSE when a fix can be expected for this issue, or a case reference that can be chased? This is a bit of a fundamental issue.

  • The current status: They are still working on a fix and there is no ETA given yet.

  • Hi,
    We have just received a T50 for testing and we can not validate this model for a future purchase before this problem with CTRL + C is resolved. Can we expect a patch or new firmware soon ?

    Kind regards,
    Sébastien.

  • Hi Sebastien,

    Wyse responded with the following (hopefully temporarily) workaround:

    In the RDP Configuration on the T50 in the tab Experience you have to activate the point "Grab ALL keyboard events when window has focus". This point is per default deactivated. After enabling this point the session does not get disconnected when using CTRL+C.

    Kind regards,
    Rene.

  • Hi Rene,

    Thank you for your quick response.
    It seems to work for office applications and all the Windows environment but I still have the problem with at least one application (Hyperion).
    I hope that a permanent patch will be available shortly.

    Kind regards,
    Sébastien

  • We are having the exact same problem, we tried switching on "Grab ALL keyboard events when window has focus" option and it doesnt seem to help, it is intermittent though. Anyone else any ideas?

  • I have opened a support case for it on 28-9-2011.
    The latest status : Waiting - Engineering
    So they are still working on a solution.
    When it is ready I will post it here.

    Kind regards,
    Rene.

  • We also have this EXACT same problem on a pilot testing project for a client (they are actually trying to use 5 of these T50's in production environment before we deploy many more.)
    We have the same environment... connecting to Windows 2008R2 SP1 Remote Desktop server.
    I logged this issue on 1st Sept 2011 with Wyse Support Case Number 2742120
    I have tried all the work arounds listed above and trying to use various RDP encryptions, and other settings on the server.
    Nothing has worked to rectify issues
    Here is our current issues with this Wyse T50
    Can you advise if the fix next month will address all of the following:
    1) Clipboard size seems limited and can often cancel remote desktop session when you copy data to clipboard
    2) Wyse RDP old version of Linux. Causing encryption issues (remote shadow/control of Wyse from Terminal services manager) and dropouts when connecting to Windows 2008R2 high encryption v7 RDP servers
    3) If remote internet connection drops momentarily (ie less than a second) the Wyse box instantly drops session and needs to reconnect. On standard RDP sessions on Windows PC’s they are less sensitive and can “retry” for up to 30 seconds before just closing the session.
    4) VNC remote control of Wyse T50 is completely open. No authentication required, anyone with VNC client on a laptop can take over any Wyse box on the network without that Wyse user knowing their screen is being viewed.

    Like above, our support indicates firmware update coming soon, but no date. Just told it will be next month. Client very frustrated and we have lost countless hours looking at the issues, not to mention the cost.
    We are now at a point of trialling other Wyse devices to see if they can provide better service as I fear if these issues are not rectified soon, the T50 model will need to be returned for Credit.

  • We have the same problem too. However, our case seems originated from language of the content.
    E.g go to www.bing.com and search key word like "Yahoo China" , "Yahoo Hong Kong" , "Yahoo Korea" , "Yahoo Japan", the purpose is to show some text in different languages.
    For copying and paste Korean and Japanese, no disconnection issue ; for Chinese simplified (China) and Chinese traditional (Hong Kong), T50 immediately disconnect the RDP session.

  • Has anyone had any success coming up with a solution to the CTRL+C / copy problem yet? One of my clients recently purchased and deployed over two dozen T50's. They are now considering returning all of the units and purchasing thin clients from another manufacturer, because of the copy problem. I am aware of another organization, nearby, in the same boat. Does anyone have any idea when Wyse plans on releasing a fix for this issue? This sort of thing cannot be good for their reputation.

  • Still nothing from Wyse on this problem, we are holding fire on buying more T50's until this is resolved, at somestage we are going to have to look at alternative products so Wyse will have lost out.

  • Same Here Stupendo.

  • We have encountered the same problem today and found a work-around: Disable remote desktop clipboard sharing.
    Run "Start -> Run -> gpedit.msc" and navigate to the "Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Terminal Services -> Client/Server data redirection -> Do not allow clipboard redirection".
    With different Windows versions, the exact name of the setting might be different, but the concept remains the same.

    Do not forget to log out and back in for the change to take effect.

    The drawback of this work-around is, that the users who use RDP from their notebooks will not be able to copy/paste files, text, ... from the client to the server or vice-versa via clipboard.
    But this is more acceptable and only influences users not working directly on the thin clients.

    I hope I could help some of you
    Lukas Cavigelli

  • Hi Lukas, thanks for that answer unfortuanlty this is not a solution for us as we have remote user's who require the ability to copy and paste from their notebooks to a terminal session.

    As these forums are ran by Wyse themselves it would be nice if someone from Wyse actually answered, or is that too much to ask for?