WSM 5 and Fast Patching - Wyse WSM - Wyse Software - Dell Community

WSM 5 and Fast Patching

  • WSM 5 and Fast Patching

    Hello,
    I just updated my WSM environment to WSM 5.
    I'm trying to update an image using the new patching procedure. Selected the OS image, clicked on "Patch" on the Patches tab, assigned it to the reference device.
    When it comes to finalize the patch I shut down the reference device and all the other devices. I click on "Finalize patch", and the process fails after 20 seconds (Patch finalization failed). It seems that WSM fails to create the delta files needed for patching.

    OsmUpdate log reports:

    8<--8<--8<--8<--8<--8<--

    Code:

    12272012 [12:20:45:208] [ 540] INFO: Cleanup()...
    12272012 [12:20:45:208] [ 540] INFO: No lock file, nothing to do
    12272012 [12:23:45:556] [4876] INFO:       *** OS Update Service invoked. ***
    
    12272012 [12:23:45:557] [4876] INFO: Computer name is SALVIX-WSM01
    12272012 [12:23:45:557] [4876] INFO: Invoked as:   OSMupdate create2 C:\Program Files (x86)\Wyse\WSM\StreamingDir\osimages\Salvix_2-11-2012 Salvix_20-12-2012 C:\Program Files (x86)\Wyse\WSM\StreamingDir\osimages\Salvix_20-12-2012.delta 2.0.0 0080649B1824 01 
    12272012 [12:23:45:557] [4876] DEBUG: CDiskFile(002AC978) - m_WCacheCount = 0
    12272012 [12:23:45:557] [4876] DEBUG: CDiskFile(002AE4B0) - m_WCacheCount = 0
    12272012 [12:23:45:557] [4876] INFO: **********************
    12272012 [12:23:45:557] [4876] INFO: Create(C:\Program Files (x86)\Wyse\WSM\StreamingDir\osimages\Salvix_2-11-2012, Salvix_20-12-2012, C:\Program Files (x86)\Wyse\WSM\StreamingDir\osimages\Salvix_20-12-2012.delta, 2.0.0, 0080649B1824, 01, bOld=1)
    12272012 [12:23:45:557] [4876] INFO: **********************
    12272012 [12:23:45:557] [4876] INFO: ----------------------
    12272012 [12:23:45:557] [4876] INFO:  Validate parameters
    12272012 [12:23:45:558] [4876] INFO: ----------------------
    12272012 [12:23:45:558] [4876] INFO: SplitMacID(0080649B1824)...
    12272012 [12:23:45:558] [4876] INFO: 	MAC converted to part 1=0x80649B and part 2=0x1824
    12272012 [12:23:45:558] [4876] INFO: Mac ids are 0080649B1824 = 0080649b1824
    12272012 [12:23:45:558] [4876] INFO: Patch Partitions are 0x3
    12272012 [12:23:45:558] [4876] INFO: New major = 2, minor = 0, build = 0
    12272012 [12:23:45:558] [4876] INFO: ----------------------
    12272012 [12:23:45:558] [4876] INFO:  Open Base image
    12272012 [12:23:45:558] [4876] INFO: ----------------------
    12272012 [12:23:45:558] [4876] DEBUG: CDiskFile::Open(C:\Program Files (x86)\Wyse\WSM\StreamingDir\osimages\Salvix_2-11-2012, 0x80000000 -  GENERIC_READ, 0x3 -  FILE_SHARE_READ FILE_SHARE_WRITE, 0x3 - OPEN_EXISTING, bIgnoreTimeStamp = 0)...
    12272012 [12:23:45:558] [4876] DEBUG: VDiskOpenFlag registry not exists or invalid - 0x2
    12272012 [12:23:45:558] [4876] ERROR: CDiskFile::Open: Failed to open file - 0x2
    12272012 [12:23:45:558] [4876] DEBUG: CDiskFile::~CDiskFile(002AE4B0 - pszDiskFile = (null))...
    12272012 [12:23:45:558] [4876] DEBUG: CDiskFile::Close(002AE4B0 - (null))...
    12272012 [12:23:45:559] [4876] DEBUG: CDiskFile::Close(002AE4B0) - m_WCacheCount = 0
    
    12272012 [12:23:45:559] [4876] DEBUG: CDiskFile::Close(002AC978 - (null))...
    12272012 [12:23:45:559] [4876] DEBUG: CDiskFile::Close(002AC978) - m_WCacheCount = 0
    
    12272012 [12:23:45:559] [4876] DEBUG: CDiskFile::~CDiskFile(002AC978 - pszDiskFile = (null))...
    12272012 [12:23:45:559] [4876] DEBUG: CDiskFile::Close(002AC978 - (null))...
    12272012 [12:23:45:559] [4876] DEBUG: CDiskFile::Close(002AC978) - m_WCacheCount = 0
    
    12272012 [12:23:45:559] [4876] INFO: Total records: 0
    12272012 [12:23:45:559] [4876] INFO: Total blocks: 0
    12272012 [12:23:45:559] [4876] INFO: Total record bytes: 0
    12272012 [12:23:45:559] [4876] INFO: Total data bytes: 0
    12272012 [12:23:45:559] [4876] INFO: Total elapsed time: 0.0 minutes  (0 seconds)
    12272012 [12:23:45:559] [4876] INFO: Total read time   : 0.0 minutes  (0 seconds)
    12272012 [12:23:45:559] [4876] INFO: Exit with code 102

    8<--8<--8<--8<--8<--8<--

    TMPUSE write cache files are present on the writecache folder; if I start again the reference device, all the changes made to the image are still present.

    If I shut down the reference device and try to cancel the patching operation, I get the error "Failed to cancel OS Image Patch. Please make sure that reference device used for patching is shutdown before canceling patch". I double-checked, and it is off - moreover, WSM overview shows that all the devices are off.
    Tried to restart all the WSM services several times, nothing changed.... 

    Anyone can help?
    Thanks in advance
    Regards,

    SS

  • I cannot reproduce this issue in my lab.
    Have set up a fresh WSM5 server and registered a 4.1.0 Win7Sp1 image and upraded it to WSM 5.0.1 using the fast patch procedure flawlessly.
    After kicking off the patch finalization, a subdirectory <OS Image>_DELTA is being created, the _tmpuse file is moved to this location and the system creates a 2kb .delta file.
    Some seconds later, may be some minutes if you are not using SSD, the OS Image is patched successfully.

    How long is the OS Images file name on the disk? Keep it short and crisp and try again please.

  • Hello mhaase, thank you for your suggestion. 
    I had to unregister the image, and then register it again.
    I started a new patch process using a short name (8 chars long, "27122012") and it worked. I will use short names in the future.   
    Thanks again 

  • This morning I patched the same image again and this time I was getting a "Patch finalization failed" error.
    Looking at the servers disk it showed that it hat deleted the <OS Image>_DELTA subdirectory from previous direct patch process but did not create a new one.
    I simply used the retry option and patch finalization succeeded immediately.

  • Hello, 
    yesterday I seen that while, creating the delta, WSM did not create any <OS Image>_DELTA subfolder, but started to create the delta file in the streamingdir. Then it created the parent image copy in the same directory (with the patch name), and last did the merge.
    HTH

    -- PS: yesterdey I tried to click reply several times, getting always the same error...

  • I have reproced it now several times and using the Retry option I have successfully finalized the direct patch process every time.
    Have informed engineering to look at it.

  • Hi Michael,

    Is there any further info on this?

    The procedure I'm following is:
    1. Clean image with Windows 7
    2. Register image in WSM v5
    3. Begin patch and assign reference device
    4. Boot ref device and install software/restarts/windows update etc
    5. Shutdown
    6. Finalise patch process fails, retry finalisation fails every time.

    Is this correct?

    Thanks
    Gavin

  • The order of steps is correct, but using the Retry option it should finalize.
    I guess the Image has been created with WSM 4?
    What is the Distribution Type and Image Header Version on the OS Image details page?

    Please be aware that OS Images created on WSM 4 will not use advantage of CDS improvements in WSM5 and will be patched using the legacy delta files. WSM 5 images will use the _tmpuse files and small delta files.

  • Thanks Michael,

    I was using a V4 image which i captured (from HDD) and then updated to V5. I have now tried a updating to V5 client before capturing the image. I can do the initial install, finalise and distribute, but if I try to patch the os it fails again.

    The new OS that I'm working on has the following details,

    Distribution Type: New 
    Image Header Version 5 
    Base Format: Legacy
    Safe Boot: No
    Image ID: 0f188ad5-47f2-4de2-a8ac-b723d29fab00 

    Is it that the base format is legacy?

  • Base format jsut describes if it is a WSM image (legacy) or a VHD file format.
    Updating the WSM Client does not update the capabilities of the OS Image itself. If the OS Image is captured with WSM 4, it will stay at 4 even if you update the content inside the OS Image. Unless all WSM Servers are upgraded to WSM 5, the OS Image should be at Version 4 and should not be updated to Version5 using VDiskImageCreation.exe because WSM4 based servers will not be able to work with images with WSM5 headers.
    Please open a case for your specific case; it looks like a generic patch issue. Provide the exact order of steps taken so far plus screenshots of all relevant pagesa and error messages.