WSM on Server 2K8 R2 anyone? - Wyse WSM - Wyse Software - Dell Community

WSM on Server 2K8 R2 anyone?

  • Question WSM on Server 2K8 R2 anyone?

    Hi

    We've deployed WSM on Server 2008 R2. In the central site I have two servers (core + edge) for load balancing. Lately we've boosted the number of streaming clients from 20 to 80, but this should work fine even on one server.

    I have a problem with what I suspect is a memory leak somewhere. After the servers have been turned on for about a week all memory is used and they start swapping. This again leads to ENORMOUS performance problems on the clients, with boot times up to 30 minutes (worst case).

    Both servers runs on vmWare ESX4 with 2 vCPU's and 4 GB RAM.

    PS! The Java version that comes with WSM is v6u7. This is more than 2 years old, and I've seen memory leaks from Java before. Is there any harm in upgrading the Java version to the newest one?

    Any clues will be greatly apreciated!

  • I have not deployed WSM on 2K8, but here is an old thread which might be of help to you:
    http://community-old.wyse.com/forums/topic.php?id=143

  • I'm considering re-installing on Server 2003, just to check if that helps. I'm still seeing a lot of random performance issues, and I'm not sure if it's server or network related (it's got to be one of them). Boot time varies from 30 seconds to 30 minutes :S

    I'm also seeing that the writecache for each client grows quite large. To me it would seem logic if the writecache is cleared when a client shuts down, since the image is streamed in volatile mode. On some occations I've deleted the writecache of a client with poor performance, and it has helped.

  • Are you referring to the cache directory on the WSM server, or C:\program files\wyse\wsm\cachedir on the clients?

    Have you tried using a scheduled task on the server to clean out the client cache directory ?

  • I'm talking about the writecache directory on the server.

    I've not yet set up a scheduled task, but I've deleted the files manually for testing.

    Re-installing server AND creating a new image as we speak. This way I'll find out if it helps to run it on Server 2k3. I'm also suspecting our routing setup to be a bit of a bottleneck, so if this doesn't improve performance I'll try putting a server in the same subnet as some of the clients.

    I'll report my results back here.

  • The writecache shouldn't keep growing, it is deleted when a client in volatile mode boots on a server that already has the writecache file on disk.
    However, if you patch the OS, a new writecache file is created.

    A client in persistent mode is another matter.

    Of course, you need enough free disk space for the OS.
    You wrote that your servers are virtual. My experience is that these are generally much slower than physical servers. We usually let core and DB be virtual, and the rest physical, as this gives much better performance.

    Stian

  • I've re-installed on 2003, and allthough the end-user performance issues are still there, the server itself behaves much better, and it seems like the writecache files aren't growing that big either. We were also seeing other issues on 2k8; services stopping unexpectedly, web interface painstakingly slow etc. This has not been the case on 2k3.

    Next step is to go physical.

  • Hello ahaberg,

    Have you been able to get better performance on physical platform?

    We also have VMware ESX 4.1 and WS2008 R2 and are experiencing similar performance problems with ~60 R00L clients.

    Monitoring storage, network and resources utilization doesn't seem to reveal any issues, but boot times are often dog slow.

    Thanks in advance,
    Sergei

  • Hi Sergei

    Very interesting - I think you're the first guy with this problem I've run into besides myself.

    I have not yet tried it on a physical box. As a temporary measure, I've just created more virtual servers and distributed the client load across them. Performance is decent as long as the client count doesn't exceed ~40.

    I've also confirmed that WSM (3.5) runs better on Server 2K3 then on 2K8R2.

    I will do more testing, including using a physical server, but I haven't had the time to do it yet. When I do, I will post my findings in this thread, and it would be great if you did the same.

  • I attempted to install WYSE Device Manager 4.8 on Windows Server 2008 SP2 and it did not install saying the OS was not supported so watch for that as well!! Now on Windows Server 2003 SP2 with no issues.

     

     


    I know I don't sound very WYSE but its new to me! 

  • Have been running WSM Server from client's Svr2003 file server but it was proving to be too much of a load, considering the other app databases running from it, so I went back to Svr2008SP2 in hypervisor. I had successfully installed this a moment ago but had just added it to the existing WSM Server, making it an Edge Server instead of a Core. I then made the changes to turn it into a Core Server, removed the original Svr2003 Server from WSM Admin and then walked away for about 30 min. When I came back, the local site was reporting the orig as the Core server again and the new Svr2008 was not even in the system. The odd thing is, the HQ server still saw the 2008 server as the Core for this site.

    I decided to just blow away the SQL db and WSM install on the VM and start with a Stand Alone install... I'm having the same problem as my previous post where the WSM Monitor service fails to start. I can't even access the WSM Admin page as it gives me an error stating Error 503, Service Unavailable...

  • 05072011 [02:02:14:378] (-05:00) [1352] ERROR: 8001 encountered -- database may be down
    this is excerpt from the monitor log file, except the database IS up. The service is started. I have restarted the database service a couple times actually...

  • SOLVED - So frustrating... so basically, you cannot rely on the Add/Remove uninstall procedure to completely remove all the files. I found that WSM files were not completely removed and there were also still SQL Server files. After blowing away THOSE folders and THEN re-installing yet again, it was a smooth process and now my WSM Server is up and running on my Server2008SP2 VM...

  • Server 2K8Stnd SP2 has been giving my fits. I am also running from within ESXi 4.1 but specifically, what I have been experiencing is that from a fresh install, the "WSM Monitor" service will not start, thus rendering the WSM Server useless. Of course, I'm running the Prereqs before the Server install. These are clean Svr2K8Stnd SP2 virtual machines with just Windows Updates. They are not running any other roles or serving any other purposes. One of them was joined to an existing domain, but that is all.

    Any thoughts on this?