Uniplat - Wyse WSM - Wyse Software - Dell Community

Uniplat

This question is not answered

Uniplat

Hi

I got different laptops that we needs to boot off same image file, ran through the uniplat prodecure -

*diskpart - made 4 partitions on hdd, laptop1,laptop2, z00d, uniplat
*hide partition laptop2, z00d
*installed win7x86sp1 on laptop1 (no 100mb boot part)
*tuned, installed wsm client, utilities
*ran uniplat, made .wup file to a usb disk
*hide laptop1, unhide+active laptop2
*install win7x86sp1, wsmclient+util
*uniplat restore from laptop1.wup from usb disk to uniplat partition
*made uniplat partition active, and tried to boot it, BCD error, cant boot

and that's there I'm stuck. any tips?

thanks on advantage!

E

All Replies
  • I read mhaase wrote that uniplat backup takes 1 round and ask about reboot after first round, but I don't get the quesition, just "close", and that's it. No reboot asked. Even that I checked for that the image is bootable, in wup properties.

  • when I look at the properties at the backed up .wup file only folliwing properties have values:

    OSM Version - 4
    Image HAL - Unknown
    Number of files - 77728
    Number of directories - 12472
    Creation date - 06/13/2013 21:14:14
    Backup directory - c:
    Delete all files - disabled


    No value set for image characteristics , image os version , and no request for reboot after first round of backup, makes me think there must be something wrong ... what could it be?

  • just got an idea, could it be that the first partition don't have BCD file but using MBR directly, and I somehow need to get BCD file generated in the first partition?

  • I generated new BCD file with either bcdboot, bcdedit and win7 setup cd in recovery mode, and got a step further - now it says windows registery are corrupted ...

    Are there something wrong with backuping with uniplat? Or maybe are the problem that the windows installation are not English? I hope someone can come with a clue... I'm pretty stuck here...

  • Hello eiris,

    make sure you have followed the instructions in document #9 in ftp://support-emea.wyse.com/public/WSM/WSM5-HowTo.zip
    This archive includes step-by-step for the most common configuration task in WSM , and Uniplat is one of them.

    Good luck!

  • Yes, at the page 6 in the refered document it says I'm supposed to get the reboot popup window, which I don't get... Just "backup complete" , I click close, and comes back to uniplat window, nothing more. Now I'm installing English windows 7sp1 and see how it goes...

  • Now, when I compare closely the document, I see, after the NIC prompt it should say "Backing up registry hives. Please wait...", here it goes straight to "Copying file. Please wait..." ...

    Maybe it's caused by that it's domain member? I'm logged on as domain administrator here... Other possible reasons? (Now I tested at english version, same result)

  • My next step would be to install windows7 without SP1 and see how it goes ... I'll post how it goes

  • Don't think the Service Pack is the culprit.
    Using the local Admin and/or not a domain joined machine sounds reasonable.
    Have a look at the Uniplat logfile (C:\Program Files\Wyse\WSM\WSM Client Utilities\Uniplat.txt) to understand where exactly the backup process fails.

  • tried a vanilla win7sp1 install with ONLY network card driver installed, nothing more + WSM client util .... samme issue !!! I'll repeat, and check the log.
    Downloaded non-sp1 install medias, will test them during today

  • The start of uniplat.log looks like this;

    (setup: win7sp1, this time is first time I test with 100mb system partition in addition to windows partition, but still no difference, vanilla install with only network+wyse util installed after fresh windows install)

    *************** Wyse Universal Platform Tool ***************
    06182013 [13:46:47:771] [2312] INFO: LogLevel = 17
    06182013 [13:46:47:771] [2312] ERROR: Failed to query registry Software\Wyse\WSM Client Utilities\UniPlat\LastWUPName - 2
    06182013 [13:46:47:771] [2312] ERROR: Failed to query registry Software\Wyse\WSM Client Utilities\UniPlat\LastDriveName - 2
    06182013 [13:46:47:771] [2312] ERROR: Failed to query registry Software\Wyse\WSM Client Utilities\UniPlat\LastSourceDrive - 2
    06182013 [13:46:47:771] [2312] ERROR: Failed to query registry Software\Wyse\WSM Client Utilities\UniPlat\LastDriveType - 2
    06182013 [13:46:47:849] [2312] INFO: opening file
    06182013 [13:47:08:894] [2312] INFO: CCapture::SetLog(17)
    06182013 [13:47:08:910] [2312] INFO: InitExcludeList(C:\Program Files\Wyse\WSM Client Utilities\UniPlat.ini)

  • Same issue with vanilla win7 without SP1, only thing installed are NIC + wyse util ... Now I'm out of ideas... The document mhaase pointed me to looked pretty simple and straight, and I can'tsee what's the problem ...

    There MUST be something silly simple thing I overlooked, but what could it be?

    After backing up Uniplat says about the image file:

    OSM Version: 4
    Image Characteristics:
    Image HAL: UNKNOWN
    Image OS Version:
    ...

    As we look here, there are something missing. Does it point towards anything I missed?

  • What WSM / Uniplat version are you using?

  • Latest, which are 5.0.1 (if there haven't come out any newer?)

  • To clarify what I've been trying:

    Used WSM Client utilites setup that came with latest WSM version 5.0.1

    Scenarios:
    Windows 7 Professional w/ SP1 - English
    Windows 7 Professional - English
    Windows 7 Professional w/ SP1 - English - without 100mb boot partition
    Windows 7 Professional - English - without 100mb boot partition
    (And all the same for Norwegian version, and tested both the user that windowssetup created, and enabled the builtin administrator, no success)

    Also I tried to uniplat-backup from a network connected WSM client, same problem.

    I'm wondering, are there different uniplat versions which I could test? What other things could influence this?