Issue when upgrading to WDM5.5.1 - Wyse Device Manager - Wyse Software - Dell Community

Issue when upgrading to WDM5.5.1

Issue when upgrading to WDM5.5.1

  • Just to start, i am completly new to this Wyse setup, and was asked by our Sys admin to see if i could get it working. Ive made some progress, but you will probably see many threads started by me as i learn my way through this.


    I am having issues sending the base image to our machines. The errors i am having are similar to what is outlined in this thread


    After research, i came to the conclusion that updating my wdm should resolve this issue. I downloaded 5.5.1 from dell and when running the install i get an error stating "WDM upgrade installer is unable to connect to Software Repository with the information read from database"

    I have searched for hours and cannot seem to find anything related to this error.

    Thanks in advance for your assistance.

  • Hello,

    During the WDM upgrade, the installer is trying to connect to each component like the Software Repository for update.

    Two things that causing the error:

    1) The local User "Rapport" password expires - from the server Computer Management, check the local user "Rapport" and reset the password

    After resetting the password, you also need to update the password in WDM console under Software Repository.

     - Launch the WDM --> expand Device Manager --> expand Configuration Manager --> select Software Repositories --> from the right hand side of the GUI, right click the Master --> select Properties

     - Update the rapport password in FTP and HTTPS protocol tab

    2) The WDM Repository "Location" could not resolve ( example FQDN)

     - Launch the WDM --> expand Device Manager --> expand Configuration Manager --> select Software Repositories --> from the right hand side of the GUI, right click the Master --> select Properties

     - Change the "Location" from FQDN to IP address of the WDM server or vice versa

  • Thank you for your reply, Just a little more info. We were having issues with this host, and ended up uninstalling WDM completely. I have just completed the re install of WDM 5.5 following the instructions on the setup guide. I have an ENT license, but chose to have everything set up on the same server. I am still getting the error from the 5.5.1 upgrade.

    I have verified the connection to the master repository, and it passes. It's location is currently set as a 169.254.x.x  IP address of the local server. Does this need to be moved to the IP address of the  NIC that is in our DHCP range? (eg: 10.2.40.12). Or should it be the FQDN?

    Thanks in advance for the assistance.

  • Update: I have tried with FQDN, and local nic IP address, and both give an error. "WDM upgrade installer unable to connect to software repository with the information read from database"

    all 3 settings pass connection test.