WDM5: Error when attempting to push our HAgent update - Wyse Device Manager - Wyse Software - Dell Community

WDM5: Error when attempting to push our HAgent update

WDM5: Error when attempting to push our HAgent update

This question has been answered by dmunangst

I'm getting an error when I try to push out a WES7HAgentUpgrade to a terminal:

Try 1:XC Failed: 1. [Error:Could not retrieve the list of all files and directory from Master Repository.] [WebDAV error:Failure to get directory tree from remote machine. HTTP Response Code: 404 Error Code: 404] Line#: 20 Cmd:XC WES7HAgentUpgrade\Temp\* C:\Temp\


Relevant System Details:

Brand new installation of WDM 5.0 on Windows Server 2008 (also new installation).

Terminal client is a C90LE7 Thin Client, version 9.03 (build 0827.4096), running WES7 version 6.01 (7601) SP1. I just recently flashed the image to the 0827 build via USB - it wouldn't connect to the WDM server until I did that. The C90LE7 unit is listed in the WDM Device Manager list.

I want to update the C90LE7 HAgent to the version 6.3.2.54 that came with WDM 5.0. The currently installed version of HAgent is 6.0.0.45.

Things I've Tried:

- I can go to localhost/.../Rapport directory and browse the directories and files there - no problem.

- I ran the Device Manager Diagnotic Report and everythign came up GREEN except for the following:
* FAIL: C:\Program Files (x86)\Wyse\WDM\Utilities\Database\DatabaseCredentialManager.exe (5.0.0.707) - File Doesn't Exist.
* FAIL: C:\Program Files (x86)\Wyse\WDM\Utilities\Database\HAConfigureUtility.exe (5.0.0.707) - File Doesn't Exist.
* FAIL: C:\Program Files (x86)\Wyse\WDM\Utilities\GUIExtractor\MgmtConsoleExtract.exe (5.0.0.707) - File Doesn't Exist.


Any ideas or suggestions? I'm lost.

Verified Answer
  • For what its worth, the error indicates SWREP connection failure.  With the device running gen1 6.0.0.45 Hagent I suspect there's a conflict with supporting HTTPS on your SWREP or use of windows authentication (new support included in new hagents).

    Sanity check in WDM GUI > Cfg Mgr > SWREP > MASTER> test connection

    If it fails - then deploying packages will fail too.  Check if the user pwd has expired (common issue).

    Swing into IIS on that same server an under the MyWDM site confirm WebDAV is enabled.  Check authentication and for testing disable everything but BASIC authentication.  We can change this back later if desired.  Disable require SSL.

    In SWREP properties > HTTP > uncheck the HTTPS/Secure checkbox

    test connection

    Retry your update.

    Also in the growing case for WAN or DMZ managed devices - make sure the IP or NAME defined for location in SWREP properties is accessible.  If the devices need to use an external name/IP to access WDM you'll want to enter it in place of the local IP it defaults to during install.

    -k

  • Thanks Karaziel. Deselecting the HTTPS checkbox caused the package to failover to FTP which allowed for a successful remote update.

All Replies
  • Nevermind. Gave up on WDM, did it via USB and got it done. Ignore this post.

  • Same issues encountered here with the Z90D7 client and WDM 5.0.  Unfortunately, "gave up on WDM" is a fair summary.  I cannot commit to rolling out dozens or hundreds of clients if each one must be visited with a USB stick, or have several agents upgraded from the stock image before it can be managed, or require a hundred other workarounds as the current software does.

    Hopefully this new forum site is one indication that Dell has decided to start taking seriously the support of this software. 

  • Might want to try installing WDM_WDM50_MR1_HF050025214 

  • For what its worth, the error indicates SWREP connection failure.  With the device running gen1 6.0.0.45 Hagent I suspect there's a conflict with supporting HTTPS on your SWREP or use of windows authentication (new support included in new hagents).

    Sanity check in WDM GUI > Cfg Mgr > SWREP > MASTER> test connection

    If it fails - then deploying packages will fail too.  Check if the user pwd has expired (common issue).

    Swing into IIS on that same server an under the MyWDM site confirm WebDAV is enabled.  Check authentication and for testing disable everything but BASIC authentication.  We can change this back later if desired.  Disable require SSL.

    In SWREP properties > HTTP > uncheck the HTTPS/Secure checkbox

    test connection

    Retry your update.

    Also in the growing case for WAN or DMZ managed devices - make sure the IP or NAME defined for location in SWREP properties is accessible.  If the devices need to use an external name/IP to access WDM you'll want to enter it in place of the local IP it defaults to during install.

    -k

  • Thanks Karaziel. Deselecting the HTTPS checkbox caused the package to failover to FTP which allowed for a successful remote update.