System Freezes during Import-Module - Dell Client PowerShell Provider - Client and Mobile Solutions - Dell Community

System Freezes during Import-Module

Client and Mobile Solutions

Client and Mobile Solutions
Learn how to Deploy, Manage, Secure, and Virtualize Enterprise Client and Mobility solutions from experts and peers.

System Freezes during Import-Module

This question is not answered

I have a PS script to install the Nuget and then grab the Dell PS provider via the gallery which works fine on 90% of our machines. However, it seems on some of our newer hardware (with the same build as the others) it freezes the entire machine when it runs "Import-Module DellBIOSProvider" I ran it verbose and the last thing it seems to run is "VERBOSE: Performing InitializeDefaultDrives operation on the 'DellSmbios' Provider"

It's completely locking the computer, cant move the mouse, no BSOD, completely unresponsive and must be powered down. Any thoughts as to whats going on? 

Windows 7 Enterprise x64 deployed with MDT

All the pre-reqs outlined in the documentation

Latitude E7270 and Optiplex 7040

All Replies
  • Hello MICHAELCIV,

                                   We tried to repro the issue you are facing on a Latitude E7270. What we basically did was on a default older BIOS we imported Dell PS provider(DCPP) and did not get any issue(like freezing etc), then we flashed with latest BIOS version 1.13.4. Even here no issues for us.

    So requesting you to please share the BIOS version on your machines(you can get it by running msinfo32).Also you can try flashing latest BIOS and verifying if the issue still persists.