E7440 BIOS Update WMI query issue - Enterprise Client - Forum - Client and Mobile Solutions - Dell Community

E7440 BIOS Update WMI query issue

Client and Mobile Solutions

Client and Mobile Solutions
Learn how to Deploy, Manage, Secure, and Virtualize Enterprise Client and Mobility solutions from experts and peers.

E7440 BIOS Update WMI query issue

This question has suggested answer(s)

Ive been testing new bios updates through my SCCM task sequences and have found on the E7440 model, with the latest bios version being 1.13.4 that I cant get it to pick up based on wmi query as previously used on the older versioning scheme (A0x) format.

My wmi query is to run the bios update with the following:
SELECT * FROM Win32_ComputerSystem WHERE Model LIKE '%Latitude E7470%'


select * from WIN32_BIOS where SMBIOSBIOSVersion < "1.13.4"

now I have a E7440 with a bios version of 1.6.3, but it skips the update, as the wmi query thinks that 1.6..... is higher than 1.1..... and not taking into account that 1.'13' is higher than 1.'6'.

Has anyone else had issues targeting bios upgrades with the new version numbers?

My OptiPlex 7040 works as the latest for that is only 1.'5'.9 and doesn't go higher that 9.

All Replies
  • Hi

    - I'm having the same problem with E5270 and E5470 models.

    - I'm experimenting with going from BIOS 1.11.4 to 1.12.4 but the WMI query doesn't acknowledge any of it just comes back as a valid syntax.

    - Older models that uses the "AXX" format work fine.

    Below is the current setup I have

    Group - WMI query if the model is True or False

    Install Package - WMI query to establish if the BIOS version is less than the packaged version.

  • I have been having this same issue with the Dell Latitude E5470 laptops.  They came to us with 1.3.8 on them and I'm trying to update them to 1.13.3.  I'm trying to deploy it using an SCCM task sequence and when it does the WMI query it evaluates it to be false.  I've tried seeing if there are other differences using the Microsoft WMI Code Creator to determine if the current BIOS version is older than the new one but haven't found anything that will work instead.

  • The only way I've found to get the BIOS update to run on these is to us the following WMI query

  • After a bunch of fiddling with it yesterday I did discover that there are 2 items in the BIOS that I think will work for my needs... I have attached the queries here:

  • Did these work? I've tried the same thing and although the syntax is true and works in Windows I can't get it to run on the task sequence.

  • I have it working on my Windows 10 1703 upgrade task sequence. I have spot checked about 30 out of our 700 machines and they all have the updated BIOS.  One thing I did have to do is make 2 steps in my TS to get the BIOS update to work properly though.  One step copies the BIOS update .exe file to a "Utilities" folder on the C: drive and then the next step runs the executable.

    Step 1:

    Step 2: (NOTE: On the Options tab of step 2 I had to set the Success Code to "2" (without quotes).  That way the BIOS update package doesn't reboot the machine causing the TS to fail.  I just let the final (or next, depending on where it is placed in the TS) launch the BIOS update automatically.  Also, as with any BIOS upgrade it is required that the machine be on AC power in order for it to successfully complete it. Otherwise it will fail the TS.