E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup - Enterprise Client - Forum - Client and Mobile Solutions - Dell Community

E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

Client and Mobile Solutions

Client and Mobile Solutions
Learn how to Deploy, Manage, Secure, and Virtualize Enterprise Client and Mobility solutions from experts and peers.

E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

This question has been answered by Warren Byle

Hi all,

Just wonder if anyone else is having issues with Windows installation crashing with the Intel Management Engine Drivers injected directly in to the WIM Image?

The error message that pops up during the installation says "Windows could not configure one or more system components. To install Windows, restart the computer and the restart the installation". Once rebooted it will loops with the message " The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows click OK to restart the computer, and then restart the installation"  I've check the logs in X:\$WINDOWS.~BT\Sources\Panther\, but can't find any thing useful (or understand).

I can get installation to complete by excluding the the IME drivers, but this leaves the device with no drivers in the Device manager. The same drivers can be installed manually with out any issues after Windows has finished installing. 

The driver revision for the 7 series latitudes I am using is A00 released on 09/06/2013.


Verified Answer
  • Some of the Windows 7 drivers for the new Dell systems may require an update of the KMDF to version 1.11.  The KMDF is a component of the OS and the update is available from Microsoft at the link below.  The usual treatment is to include the KMDF update into your base image until it is rolled up into a service pack.  Some of you may remember seeing this issue with XP/Vista when Win7 came on the scene.

     

    Symptoms that a KMDF update is needed for a Windows 7 driver:

     1.       Yellow bang in device manager for components that you know you have a driver available

    2.       Black screen during OS deployment

     

    http://www.microsoft.com/en-my/download/details.aspx?id=38423

     

    Please post back if this helps address the issues you are seeing.

  • make sure your driver package targeting is correct.  That is usually the case, when Auto-Apply works but Apply Driver Package does not.

All Replies
  • Good morning allz,

    First of all, i'm new to this so apologize me.


    I experience a problem wen  deploy my Windows 7 x64 image through WDS. Everything goes fine until the step where Windows shows the screen "Setup will continue after restarting the computer". it hangs there but the screen is not frozen.

    I hard shutdown the computer and switch it on back and the process continue....

    I injected through DISm the KMDF 1.11 in my image but i still have the problem.

    BUT with 32-bit, everything goes fine...

    i don't understand where i messed up ?

    thank a lot for your answers and time spent :)

    Antoine

  • Updating the KMDF to 1.11 in install.wim is just part of the story.We found out that the kmdf 1.11 is also needed during the WinPE driver inject phase.

    Since we are running SCCM 2007 SP3 with WAIK 2.0 we are stuck. I tried importing WinPE 5.0 boot.wim that seem to include 1.11 (it's Windows 8.1 based) into sccm but that fails since the import wizard and also the update distribution point wizard all do DISM's in the background where they try to modify the 5.0 WinPE with 3.1 WinPE components and features, and fail.

    Any usefull comment is, ofcourse, highly regarded.

    gr, Henno.

  • Can we just Install KMDF after installation of OS?

    I have a similar issue with the latitude e7440 laptop. I haven't created any Custom image to install OS.

  • I am also using WinPE 5.0 for boot and Windows 7 SP1 plain Install.wim.  I found the below link incredibly useful, even though I'm running MDT at the moment.  I have SCCM 2012 SP1 but don't have imaging working there yet.  The trick has been to load the individual .cab from the MSU for KMDF 1.11 into MDT and add it to the Task Sequence before Windows Setup, but after the initial install image is laid down.

    http://deploymentramblings.wordpress.com/2013/10/24/osd-injecting-the-windows-7-kernel-mode-driver-framework-kmdf/

  • I have the KMDF 1.11 package in my WIM, and I am seeing this exact problem.  I use SCCM 2012 sp1 for deployment, and can get all models to install all drivers by way of a driver package for each model.  All but the newer models (Latitude E6440, Latitude E7440, OptiPlex 7010).  These models all fail to install all of their drivers, but work if I set them up to Auto-Apply drivers.  Any ideas?

  • make sure your driver package targeting is correct.  That is usually the case, when Auto-Apply works but Apply Driver Package does not.

  • Warren, thanks for the response.  The rules are all 100% correct.  I can go back and forth between the two, with the same WMI query to check for the model, and the driver package does not work, but the Auto Apply does.  Here are some details:

    • All older models work with packages (Latitude E6400, E6410, E6420, E6430, OptiPlex 755, 760, 780, 790)
    • No newer models work with packages (Latitude E6440, E7440, OptiPlex 7010)
    • Auto Apply drivers works with all
    • Auto Apply drivers with a category limitation set model-specific works, but is not how I would prefer to manage, especially since I see others say that packages should work

    So, by "driver package targeting" I assume you mean that the driver package includes the right drivers, they are enabled, are on the right DP, and are in a package that is selected for the right model?  All those details are all correct, and work on older models, so I don't think I am missing anything here.

  • Do you have the logs that show that the Apply Driver Package step is doing what you want it to do...but still not working?

  • I do save the logs, but am unsure which to check.  Ideas?  Also, I did not mean that this was doing what I wanted it to do, but was not working.  It is setup as the others, but is not working.  Any ideas are appreciated.

  • The SMSTS.log should provide the details on which package met your WMI qualifications and ran successfully.  

  • I'm seeing exactly the same behavior with x86 Windows 7 SP1 installation - I have injected  KMDF 1.11 and that installs fine but setup hangs for hours on "Setup will continue after restarting the computer"

    Waiting it out or powering the machine down moves the the deployment forward but none of the two are feasible solutions...

    Did you ever find out what was causing this?

  • Hi Adrian,

    if i remember well, i've updated the WDS image with the drivers and the kmdf 1.11 and it went all fine.

  • to be more precisely, i've update the Windows Seven image on WDS. Not the win_PE.

    i hope it will works for you too!

  • In my scenario, it actually was the driver package for the model.  The package was actually configured differently than the other model driver packages.  The two newer models driver packages were not configured for "Copy the content of this package to a package share on distribution points" like the rest.  Once I did that, these models got their drivers like the rest.

    I hope you resolve your issue.

  • The issue occurs on my 7470s the same way. I've updated the WIM (before sysprep) and still receive the same issue at boot. 

    I've attempted to add it in post, but that still fails.

    Please advise