Error Deploying USB Port Security - Desktop Authority Management Suite (DAMS) - Desktop Authority - Dell Community

Error Deploying USB Port Security

Error Deploying USB Port Security

This question is answered

We purchased licensing for USB Port Security, but have so far been unable to use it. It will deploy to some machines, but the install fails on most. All are Windows 7 64-bit.

I'm getting the "dreaded 1603 error" in sltrace. Here is part of the install log:

1: GetInstallDriver, Can not find InstallDriver in ROT table, Return Code = 0x800401e3
1: {8D4075AD-74DF-409B-9009-97AFF3DA3744}
1: Extract supporting files
1: Failed to extract ISRT.dll, error is 2
1: Failed to extract _IsRes.dll, error is 2
1: Failed to extract _IsUser.dll, Ignore it.
1: ISMsiServerStartup Failure, Failed to Initialize script support, Error = 0x800706be 1: MsiServerStartup failed. Abort installation.
CustomAction ISStartup returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
CustomAction ISMsiServerStartup returned actual error code 1603 but will be translated to success due to continue marking Action ended 13:41:12: ISStartup. Return value 3.


The package installs fine if it's run manually by a local admin.

I've tried all the usual things you do for a 1603 error (setting DCOM identify to launching user, deleting registry keys, etc). I've even tried modifying the port security install package, but nothing seems to help.

Is this a known issue with a quick fix? Or was this perhaps fixed in later versions? I'm currently on DA version 8.12 and would appreciate any hints. Thanks!

Verified Answer
All Replies