Dell C1100: How to update BIOS and BMC to the latest version.


Gain valuable insight from experts and peers to help you accelerate cloud deployment and reduce the complexity of cloud management - Hadoop, Crowbar, Boomi, Enstratius, Cloud Manager, and more.

Dell C1100: How to update BIOS and BMC to the latest version.

  • I want to write this guide because a lot of people are getting the C1100 off of Ebay or other sources and trying to update firmware but having trouble.

    • So you botched up the BMC firmware update? 
    • The orange/amber light is blinking and blue light is on and the power button does nothing?

    The C1100 is stuck at amber orange blinking light?

    • Open up your C1100 (powered off)
    • Close to where the PCI-E card is, somewhere on the motherboard there are a few jumper.  On particular one, should say something like CLR CMOS.
    • Put the CLR CMOS so that its its on the other two pins from what it originally was.
    • Put the power cord in, wait 10 seconds, Pull the power cord.
    • Put the CLR CMOS jumper back to original position.
    • Put the power cord back in.  The fans will go at full throttle.
    • Now wait for like 5 or so minutes!  Plug in your monitor, keyboard and USB Bootable Thumbdrive with DOS and firmwares (see below).
    • It will first say CMOS and BMC not responding, loading defaults etc and restart.  Wait another 5 minutes, press F11 to get the BBS Priority and choose your USB thumb drive.
    • If you pull the power cord at any other moment, you will have to redo the CLR CMOS to boot up again.

    Getting the BIOS and BMC Files together:

    • Get DOS on USB (search for Rufus, find on github or google)
    • Get the latest BIOS B23
    • Get the latest BMC 1.82
    • Put it all in directory of the usb flash drive (make sure directory less than 8 characters)

    Updating the BIOS:

    • Boot to DOS
    • Find the BIOS directory ( I called mine b23)
    • Enter command AFUDOS <ROM NAME>.ROM /P /B /K /X
    • This is the same as the F.BAT file that comes from dell but with the /X.  The /X is important because it tells to ignore ROM ID
    • Wait to finish (DON'T RESTART YET, DO THE BMC Firmware Update)
      • Note: nothing critical, it's just that I did mine one after the other and it worked.

    Updating the BMC:

    • You have to edit the batch file and move some files around before you put it on the USB thumb drive.
    • Copy the FIRM.BIN to the DOSFLASH directory in SOCFLASH directory. 
    • Edit the dosflash.bat file:
      • socflash cs=2 option=fc if=firm.bin skip=0x200
    • The firm.bin is now in the same directory as socflash.exe.
    • Now you should be right after the BIOS Update from above.
    • Go to your BMC directory -> SOCFLASH -> DOSFLASH
    • Run the dosflash.bat file.
    • Give it a few minutes and you should be good.
    • Now after a minute of waiting just pull the power cord, wait a few seconds for complete power down and plug it back in.  Give it a few minutes and you should be golden.
  • Thanks for helping out the community @Sysusrer2013!  

  • No problem!  I had thought I bricked my C1100 too, but after struggling and reading partial fixes back and forth I had achieved success.  I just wanted to help others that might be having the same problem too.

  • There is a new version of the BMC; 1.84. Would this be a possible upgrade candidate aswell?

    The filesize is more than the double though.. I will try with 1.82 for now until some successful stories appear.

    Thanks for a nice guide!

  • No problem. 

    The main crux was that you needed to move that firm.bin file into the same directory socflash.exe and edit the dosflash.bat file.  It seems like socflash doesn't really know how to traverse a DOS directory tree and may be trying to use a Linux convention to the firm.bin location; I had even tried doing if=a:\...\firm.bin and that didn't work either.  However, just dumping it right next to socflash and calling if=firm.bin works fine.

    Let me know if you run into anything.


  • Both my C1100 are flashed with success. Used BMC 1.82.

    Again, thanks for giving me enough confidence to dare try an upgrade :)

  • That's great to hear!  :)

    Since you mentioned the new BMC firmware, I might give that a try.  Right now the 1.82 BMC Web GUI looks a bit old fashioned (blue and white) and maybe the new BMC has that sleek black interface.

  • So following this post line for line actually ended up bricking my server when I was attempting to fix the "fan spinning up to 10,000 RPM every other second" issue. Reader beware if you have a "CS24-TY", do your research and figure out whether or not you actually have a Dell badged "Quanta". 

    Others with the same issue:

  • Note the skip=0x200 should not be used if you have a firm.bin that you dumped from another machine with socflash.  It is also only valid for that 1.82 file, use 0x250 with the current 1.85 on Dell's support site.

    I updated an ancient one to 3B23 and 1.85 with some hexeditor work.  I used the current files on Dell's site but you have to unpack them with 7zip or winrar or whatever (don't run the exe since you probably aren't on the Dell you're updating).  Find the payload directory and grab the file out of there.  The BIOS file (.hdr) is useless in AFUDOS4 (and the BMC BIOS update page) you have to chop the actual raw BIOS BIN out of the wrapping junk in the HDR file.  If you dump the current BIOS (also with same version of AFUDOS) and look at it in a hex editor, it begins with a flood of "FF" bytes, and then at 0x90000 the string "AMINCBLK", and then the result needs four bytes torn off the end (HDR file checksum I guess) and filled with FF so that the file is exactly 4194304 bytes.  Then this will work via AFUDOS (I only had luck with version 4) to update the BIOS to Dell official latest.  The MD5sum of my resulting, working, file is d1a7f209f74561ee6790dda515a908fa

    The BMC firmware 1.85 you should be able to use the original post instructions, but use 0x250 instead of 0x200.  Also if you are using a file dumped by socflash from another machine, there is no skip.  I happened to try this via IPMI which in hindsight was pretty hilarious.  Good thing my datacenter has external "spiders" to be able to get a console back.  Anyway don't try the socflash if you're booted via IPMI - these instructions assume you are physically at the machine.  There is a Linux version of socflash and you could update BMC from an ssh session as long as it isn't booted off any IPMI injected drives, and there is already Linux running on the server.  In my case, I did the same thing as the BIOS file and ripped the header off the file so it compared similar to a dumped BMC firmware, and padded it out to the full 16777216 bytes with FF.  The MD5sum of that result (1.85) was 5ea959125a06b8acc9b42503ad99e645

    I think the problem most people are having with 1.85 is that the header (skip= value) changed sizes so the 0x200 everyone seems to just use won't work.  Once you understand where the skip should point to (what a BMC firm.bin looks like) a hexeditor should let you find the right skip for any version.

  • Nope, 1.85 is more of the same.  It does seem to magically pull NTP though, not sure how, but the date is correct now and I didn't set anything.  Inventory and sensors seem to actually work too, the old one had no processors and no memory listed (lol?)

  • Also this successful machine was a 60:eb:69 prefix machine which lspci says is Quanta, but not the Quanta that people claim don't work (some other MAC prefix).  The main thing is if your machine has a 3Axx series BIOS revision, it is NOT the same as these 3Bxx ones.

    The (mis)information about Quanta == BAD is not exactly true.  I figured I was going to brick this one but ignored the rumors and it worked great (given a hexeditor).

  • This is the best page for info on recovering from a bricked C1100.  It's a pain to find iwth google though. I wish google would hit this page first for 'poweredge C1100 bios recovery"

    Spudz76: I just used dos socflash with skip=200 with the firm.bin for bmc 1.86 from the dell PEC1100BMC186.exe  and it worked ok for my system.

    After that success, I tried uploading the firmware using the BMC gui on systems with existing BMC 1.70 firmware. Surprisingly didn't work. Complained about checksum. And if I forced it, it then failed to update with a different hex error number. So that says, using tools from Dell, I couldn't update either at the linux cmd line, or from the GUI. I didn't use the Dell tool at the dos prompt. I used Aspeed's latest dos socflash booted from a usb key.

    There seems to be a bunch of pages out there with questionable info.  I recovered my BMC after a bad firmware load from linux (caused by using the linux firmware tool that Dell provided in the firmware file. It left me with nonfunctional bmc. I'm on a 64-bit  ubuntu and they require ia32-lib, and there's a .so file to use..didn't seem to work right ...but killed my bmc)

    One good hint was how you have to wait up to 5 minutes (see above) in 2 places. That was unexpected but true. And the poweredge C1100 refers to the jumper name for the CMOS clear incorrectly when it describes clearing the cmos, which is confusing. (I'm talking about the Dell Poweredge C11000 Systems Hardware Owner's Manual. pdf. can google).  

    Page 114 mentions "Troubleshooting Changes in BIOS Settings, with step by step instructions for clearing..but mentions J15 as the jumper. Page 117 has a picture, but there's no J15. It's J24..called "CMOS Setting". I thought there was another jump towards the back left of the board, not shown in the picture on page 117, but can't check right now. 

    Oddly, my system always eventually booted (just really slow) when the bmc was dead. But had fans running full speed. That is, until it got in the state after power cycle, where it just sat there. Nothing. No fans. I had to do the CMOS clear as stated to get out of that state (which causes full-on fans as noted/expected)

    Then booted the USB key per above and did the 

    • socflash cs=2 option=fc if=firm.bin skip=0x200

    I looked at a bunch of things on my system, and some made me think "Oh this is like what people say about a Qanta system. But it seems act like a true-blue Dell system. I think Qanta made the systems for Dell? I mean if I look at mac addresses etc, it seems to match up for what people say about Qanta, but I don't think this is a Qanta system (except maybe they manufactured it for Dell)

    current BMC firmware is now 1.86.24128

    current BIOS firmware is S99C3B23 8/16/2012

    I used socflash from aspeed at

    I used the dos version and put it on a bootable usb key with the dell bmc 1.86 firm.bin from the download page at dell (how come I can't seem to use links here)

    I notice in the socflash stuff from Aspeed, they have a 64-bit linux socflash. I'm going to live dangerous and see if I can use that to load the bmc 1.86 into another system.

    thanks for the info Spudz76. I was really liking the C1100, thought I killed it, but now I'm liking it more.


  • This Qanta vs Dell vs custom OEM vs "real" C1100 question bothers me :) Surprised we can't get to the bottom of it. I wonder if confusion reigns because people brick their bmc, and assume that means xyzzy.

    Maybe we could post MAC prefixes on our systems and compare 

    My 5 systems have (all now have b23 bios. bmc firmware is 1.61/1.70/1.86 mixed)


    which OUI lookups say is registered to Quanta Computer Inc

    ipmitool tells me the following about my bmc (this is version 1.70)

    There's a manufacturer ID and number (no names)

    ipmitool mc info
    Device ID : 32
    Device Revision : 1
    Firmware Revision : 1.70
    IPMI Version : 2.0
    Manufacturer ID : 7244
    Manufacturer Name : Unknown (0x1C4C)
    Product ID : 21401 (0x5399)
    Product Name : Unknown (0x5399)
    Device Available : yes
    Provides Device SDRs : no
    Additional Device Support :
    Sensor Device
    SDR Repository Device
    SEL Device
    Aux Firmware Rev Info :

  • I can confirm that using the v11101 socflash_x64 from Aspeed at a linux cmd line prompt worked to update to the 186 dell bmc firmware

    I unzipped their lxflash_v1101.tar.tgz

    I guess I was pretty cocky :) . I did this on a windows xp system at home, running cygwin, ssh'ed with vpn  to the target system, which was running ubuntu . I copied the relevant files there before executing the commands there.

    Don't you get nervous when the software from the vendor has typos in the output messages "Relacate"  :). But it works! better than the thing from dell

     # cat
    ./socflash_x64 cs=2 option=fc if=186.bin skip=0x200

    # uname -r

    # lsb_release -a
    Distributor ID: Ubuntu
    Description: Ubuntu 12.04.5 LTS
    Release: 12.04
    Codename: precise

    # ./
    ASPEED SOC Flash Utility v.1.11.01
    Find ASPEED Device 1a03:2000 on 6:b.0
    Relacate IO Base: ec00
    MMIO Virtual Address: f4052000
    Found ASPEED Device 1a03:3000 rev. 10
    Static Memory Controller Information:
    CS0 Flash Type is SPI
    CS1 Flash Type is NOR
    CS2 Flash Type is SPI
    Boot CS is 2
    Option Information:
    CS: 2
    Flash Type: SPI
    [Warning] Don't AC OFF or Reboot System During BMC Firmware Update!!
    [SOCFLASH] Flash ID : 1820c2
    Find Flash Chip #1: MXIC MX25L12805D
    Detect DELL Firmware Image
    Header Format Version:2
    Erasing Flash Chip #1
    Erase Flash Chip O.K.
    Update Flash Chip #1 O.K.
    Update Flash Chip O.K.

    I then used the already installed ipmitool to reinitialize the bmc lan ip information (could do this in the bios, but no reason to reboot for that)

    I use a static ip for the bmc 

    These commands are at the linux cmd line

    ipmitool lan set 1 ipsrc static
    ipmitool lan set 1 ipaddr
    ipmitool lan set 1 netmask

     ipmitool lan set 1 defgw ipaddr

    defaults seem good for anything but those

    remember they're slow! may take a while to get the prompt after each one (no more than 1 minute)

    yup. can hit it with browser now. Don't even have to reset the bmc
    although to be sure, I will

    ipmitool bmc reset cold

    have to wait a couple minutes for bmc to come back after that

    now the bmc is at version 1.86

    ipmitool mc info
    Device ID : 32
    Device Revision : 1
    Firmware Revision : 1.86
    IPMI Version : 2.0
    Manufacturer ID : 7244
    Manufacturer Name : Unknown (0x1C4C)
    Product ID : 21401 (0x5399)
    Product Name : Unknown (0x5399)
    Device Available : yes
    Provides Device SDRs : no
    Additional Device Support :
    Sensor Device
    SDR Repository Device
    SEL Device
    Aux Firmware Rev Info :

  • I just wanted to say thank you, I was able to get my BMC back and working again after following these directions.

    I had bricked my system last year after a failed upgrade attempt and got it back up through the similar recovery method as posted here using the Quanta firmwares posted elsewhere (I do not recommend them). My BMC never worked since. Following these instructions I got B23 and BMC 1.68 installed. I had to use skip=0x200, 0x250 does not work.

    My lan prefix is C8:0A:A9.

    Thank you