M820/M620 firmware update to Intel Ethernet x520 Mezz NICs fails - Blades - Forum - Blades - Dell Community
Blades Forums

M820/M620 firmware update to Intel Ethernet x520 Mezz NICs fails

Blades

Blades
Find insights from Dell experts on our Blade Solutions to help you deploy and manage your environment.

M820/M620 firmware update to Intel Ethernet x520 Mezz NICs fails

This question has suggested answer(s)

We have a mix of 11g M820 and M620s. They have Intel Ethernet X520 10GBE DP KX4-KR Mezz NICs. The current installed firmware version (as shipped) is 15.0.27.

The latest firmware is 16.5.20. Applying that via CMC fails. The iDRAC log error shows SUP0517 "The firmware image specified in the operation did not apply successfully. An internal error may have occurred." There is a suggestion to retry. I retried multiple times and downloaded new copies of the firmware

In reading the release text, two processes are outlined: 1 for firmware 14.5 or below, and 1 for firmware 15.0.28 and above. Ummm...well, we are between those two versions.

I also tried following the steps for the earlier version. I tried applying the patch for 15.0.28. That failed. I tried applying the patch for 15.5.0 firmware, but that failed too.

I did try searching for this, but I didn't find anything in the KBs or other forum posts.

Of the 19 blades, 8 have ESXi 5.5 installed. The others do not currently have any OS installed.

Any help, suggestions, or insight will be greatly appreciated.

FWIW, we've had mixed success with the other updates via the CMC. Most/all show up as failures even when they succeed. The BIOS, Perc, and iDRAC all upgraded.


V/r

Brian

All Replies
  • Hi Brian,

    From the release notes on the support site, this is a known issue with updating to 16.5.20 from 15.0.27.

    Please note : If you are using CMC GUI, then it uses what is referred to as the Lifecycle Controller Method below:

    If you currently have FW 15.0.28, do one of the following procedures to update FW:

    - Option A: Run FW DUP 16.5.x on a supported OS
    - Option B: Lifecycle Controller Method 
    1. Upgrade from 15.0.28 to 15.5.0 via Lifecycle Controller and reboot
    2. Upgrade from 15.5.0 to 16.5.x via Lifecycle Controller

    The 15.5.0 FW-DUP is required when updating firmware in Lifecycle Controller. This sequence is referred to as a two-step firmware update process and is required due to an Option ROM mapping change in the firmware.

    If you are upgrading the firmware from 14.5.x or later to version 16.5.x in Windows or Linux, then you do not need to apply 15.5.0 first.

    Regards,

    Ajay

  • Ajay:


    Thanks for the quick response.

    I tried following the release notes, but it failed:
     updating from from 15.0.27 to 15.0.28 generated the same error.

    Doing this from the OS is not an option because 1) most of them don't have an OS yet, 2) those that have an OS are ESXi.

    Those instructions only mention 15.0.28 and 14.5.x. There is no mention of 15.0.27.

    Thanks,

    V/r

    Brian

  • Hi Brian, can you try this?

    - Boot the server

    - Press F10 during boot to enter the Lifecycle Controller GUI

    - Click on "Firmware Update" on the left hand side menu;

    - Provide the 15.5.0 Windows 32 bit DUP file as input on a local USB drive or on a CIFS/NFS network share. 

    - Perform the update

    Let me know if that works.

    Regards,

    Ajay

  • This was fixed in the latest firmware --

    Intel NIC and NDCs Firmware Family Version 17.0.0, A00, Released 13 Dec 2015, Recommended

    Version 17.0.12, A00  -  I350, I354, X520, and X540  - Adapters / Mezz Cards / NDC

    From the release notes at http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=F8H29

    Fixes:

    ...

    Firmware DUP update from 15.0.28 to 16.5.20 fails on X520 devices