Changing root user password from calvin (CLI) - Blades - Forum - Blades - Dell Community
Blades Forums

Changing root user password from calvin (CLI)


Find insights from Dell experts on our Blade Solutions to help you deploy and manage your environment.

Changing root user password from calvin (CLI)

This question is not answered

I'm trying to change the root accts password from the default.  I've tried via the GUI and the password won't change.  I am trying to change the password via the CLI and need some help as to what the actual command syntax would be.

racadm config ?



All Replies
  • I copied this from the iDrac 6 guide

    Adding an iDRAC6 User

    To add a new user to iDRAC6, perform the following steps:

    1 Set the user name.

    2 Set the password.

    3 Set the Login to iDRAC6 user privilege.

    4 Enable the user.


    The following example describes how to  add a new user named "John" with a

    "123456" password and login privileges to iDRAC6:

    racadm config -g cfgUserAdmin -o cfgUserAdminUserName -i 2 john

    racadm config -g cfgUserAdmin -o cfgUserAdminPassword -i 2 123456

    racadm config -g cfgUserAdmin -o cfgUserAdminPrivilege -i 2 0x00000001

    racadm config -g cfgUserAdmin -o cfgUserAdminEnable -i 2 1

    To verify the new user, use one of the following commands:

    racadm getconfig -u john

    racadm getconfig –g cfgUserAdmin –i 2

  • So maybe "racadm config -g cfgUserAdmin -o cfgUserAdminPassword -i # 123456"  Where # is the no. for the actual root acct?  (I believe it's 0 or 1)  I think I did try something like that but will give it another go and post back.

  • If I'm not mistaken it is 1.

  • Entered

    racadm config -g cfgUserAdmin -o cfgUserAdminPassword -i 1 mydesiredpwd

    syntax error returned

    What am I missing here?  Would I have to enter every racadm command like I'm setting up a new user even though I simply want to change the password on an already existing login/user/acct?

  • information about the # for the root account is in the following thread:

  • Peter

    Thanks for the link.  However that is the exact command I entered to attempt to change my root password and I received a error.  See below.  The picture does not contain my password but I did enter one.


  • have you tried to do this locally instead of through remote shell (rsh)?

  • Nassim

    No I have not but definitely will shortly.  I would be essentially issuing the command via a KVM that is attached to the chassis, as opposed to going through the exact same KVM via it's http web management tool.  Not sure how that would make a difference but again I will give that a shot.

  • Nassim

    By the way if you meant locally as in changing the root password via the CMC iKVM web interface.  Yes that is the first way I tried.  I receive a "the operation has completed successfully" notification after hitting apply.  However when I log out and attempt to log back in the password has not changed from the default of CALVIN.

  • That's weird, how about creating another admin account and then changing the root password.

  • Yes, that is what I meant, locally sitting in front of the KVM Chassis. sorry I didn't notice you wrote two answers, just read the last one.

  • This particular chassis does have an admin acct already configured before I tried to change the password.

  • To clarify my last post.  There is already an admin acct set up.

    Still no resolution

  • Hello Nevayield,

    I was just checking to see if you had a resolution to this problem.

    You are using the correct syntax. As you can see from the screen shot below that I used the same version of CMC you have and the same syntax. After changing the password I verified that it changed by logging in using the new password.

    From looking at your screen shot the error returned is complaining about a semicolon in the command. If you didn’t use a semicolon in your password then maybe try a different connection method. I’m using a common free telnet program from the internet.


  • Thanx Corey that sounds promising as I did use a semicolon in the password to keep it uniform with the other passwords of my organizations other Dell Chassis.  I will try a different connection method and hopefully that yields me a better result.  Either way I will post back and let you know.