Follow-up: Ubuntu on the Precision M3800

Follow-up: Ubuntu on the Precision M3800


TechCenter is a community for IT professionals that focuses on Data Center and End User Computing best practices. Here you can learn about and share knowledge about Dell products and solutions.

Follow-up: Ubuntu on the Precision M3800

In my previous post about the Precision M3800, I noted that there are still a couple of pieces that do not fully work on Linux. Those were the touchscreen, which requires a "quirk" to fix, and the SD card reader, which did not work. I have some updates on those.

Kent Baxley of Canonical and I are working on getting the quirks for the touchscreen included in the official Ubuntu and the upstream kernels. Until then, you can still use the packages available at <>.

As far as the SD card reader, there is a fix in the upstream 3.13-rc1 kernel's rts5249 driver. We have worked with Canonical so that this fix is expected to be in an upcoming Stable Release Update (SRU) kernel for Ubuntu 13.10. For users of other Linux distributions, I am working with the patch's author to try to get this patch into older Linux stable kernels.

Comment Reminder

Unrelated comments or requests for service will be unpublished. Please post your technical questions in the Support Forums or for direct assistance contact Dell Customer Service or Dell Technical Support.. All comments must adhere to the Dell Community Terms of Use.

  • I am very interested in the M3800 as my next work computer, which I need to order very soon. Did you try to run it with 2 external monitors and how did that go? Thanks!

  • Thanks a lot for the efforts. If the fixes are going upstream this would be very nice. What about official Ubuntu/Linux on m3800/XPS15 ?

  • Hello! I have forgot the bios password. Can you help me?

  • Nice to hear that there is work being done on these machines also.

    Hoping for an official preinstall version for work use. But possibly getting one of these in Finland to testing.

  • How was the battery life under Ubuntu?  Is it like Windows (from various reviews) - less than 3 hrs?

  • abyzthomas: I've managed to average anywhere between four and six hours depending on usage. Note that I don't keep the screen brightness at max but typically somewhere in the lower 50%. I also always install the intel-microcode and laptop-mode-tools packages (and do some profiling with powertop to see what's using up cycles that I don't need). I also use XFCE with the awesome tiling window manager. If you use Unity or GNOME Shell, your results might be different.

  • Thank you Jared.

    I bought M3800 and loaded OpenSUSE 13.1.  WOW! amazing.  Everything works including wireless, graphic card, webcam, touch screen.  

    I went with the QHD+ (3200x1800) and the fonts are not that nice.  I was able to adjust most of the fonts since KDE is so customizable and beautiful, but some of the things are still too small.  Maybe I should have bought the lesser resolution model. :-(

    Other than the resolution issue, I am loving the system.  I played with Win7 before I installed OpenSUSE to make sure all hardware was working in Windows.  I was pleasantly surprised to see that the OpenSUSE is running at least 10 times faster than Windows.  Even wireless seems to be much faster.

    Thank you for this post.  It helped me decide on buying this system.

  • Thank you so much Jared for your support!!! You make things happen. I have received my brand new M3800 on Monday. 8 gb + qhd (NOT qhd+). I haved added 8 gb + a M2 ssd of 480gb. I boot on the ssd and didn't touch the 2.5 disk reserved (for now) to Windows. Everything works. I had some problems with Bumblebee. Bumblebee didn't work as expected. I had to follow a document. On  the M3800 Totem does not always play the videos correctly. By example the sound is lost after a few seconds! Don't know why. I had the same kind of problems reading usb keys, sd cards (yes no problem to read the sd cards!). After I have switched to VLC it was fixed. The touch screen works very well. A mouse emulation with the fingers. You cannot do much more (imho). The SuperSpeed USB 3.0 does not work (as expected) :-( I mean the lcd monitor attached is not seen but the ethernet port is seen and all the usb ports. A lot of customers like me (maybe naive) thought that it was a docking station that can reload the battery and provide power to the laptop. It is not! The only problem I have is that I cannot record a video using the webcam. I have tried many things. Even using VLC and not much success. The recording of videos does not work. Thanks again for your work. I even put a video on youtube. Please excuse my French accent :-)

  • Hi Rudy,

    I don't mind the French accent at all. In fact, I rather wish to visit Belgium one day (the Ardennes!). :-)

    I didn't try Bumblebee much so can't comment too much on it.

    I've not had trouble with USB 3.0 devices, but you're right that video support for USB 3.0 docks is unfortunately non-existent on Linux. :( I hope that vendors like DisplayLink hear the feedback of Linux users like us and does something about this!

    Could you file a bug report on the webcam issue? It worked for me when I tested with Cheese and Google Hangouts on Ubuntu 13.10 and Debian Wheezy.


  • It is of because of people like you! that the world is a littlle bit more opened ! (and I have also to give credit to Barton George).