TechCenter Blogs

Dell OpenManage 6.3 for Ubuntu

TechCenter

TechCenter
DellTechCenter.com is a community for IT professionals that focuses on Data Center and End User Computing best practices. Here you can learn about and share knowledge about Dell products and solutions.

Dell OpenManage 6.3 for Ubuntu

The Dell Linux OS engineering team is pleased to announce the immediate availability of Dell OpenManage Server Administrator version 6.3 compiled for Ubuntu 9.10 or later and packaged in .deb format. This release is community-supported only, meaning that support is available only via the linux-poweredge@lists.us.dell.com mailing list. To download and install this release, go to http://linux.dell.com/repo/community/deb/. For detailed installation instructions, see the instructions posted on the repository start page.

This release of Dell OpenManage for Ubuntu was completed with the help of a generous donation from Canonical, who donated several engineer-weeks of time to get the Dell Linux team up-to-speed on debian packaging, packaged the initial set of debs as a proof-of-concept, and provided assistance and package review. Although this release is not officially supported by either Dell or Canonical at this point, Canonical employees were critical in bootstrapping the process, and we would like to thank Brent Fox at Canonical who pulled the necessary strings to get things moving, as well as Brian Thomason who dedicated his time for several weeks to complete the port. Prudhvi Tella is the Dell Linux Engineering team member who lead the technical work packaging OpenManage.

One notable aspect of these new debs are that they are natively compiled on Ubuntu 9.10 and natively packaged using the deb package manager. Dell uses a private instance of the OpenSUSE Build Service (http://build.opensuse.org) to compile all of our OpenManage code, and the build service's native capability of building debian packages from the same source tarballs used to compile the release RPMs also helped immensely in this porting effort. This is different from previously-available OpenManage debs that have been available which were just repackaged versions of the binaries from the OM RPM release.

There are a few interesting differences in packaging between the OM RPMs and DEBs. First, versioning is handled differently in the DEBs. In the RPMs, each RPM is individually given the version of the overall OM release that it is released with. For example, all of the OM 6.3.0 RPMs have the same version: 6.3.0. If you examine the RPM with 'rpm -qip rpmname.rpm' you will see the component's individual version in the Description field. For the DEBs, we have instead given each individual component the version of that component. This means that all of the srvadmin-* DEBs will not have a uniform version number.

The second notable difference is that several components which are not supported on Ubuntu are not present. The main examples are the OM Shared Service, and all of the infrastructure for updating firmware, the dell_ie_* RPMs. We lacked the resources to convert these packages for this cycle. Additionally, wsman integration is missing in this release due to the fact that the native packages for wsman on Ubuntu are too old.

If you like this release and would like to see this officially supported, please talk to your account manager or sales rep to provide feedback. Direct feedback from customers to your reps is the best way to get your voice heard.

For documentation of OpenManage, please see http://support.dell.com/support/edocs/software/svradmin/

For questions, please use the linux-poweredge mailing list: https://lists.us.dell.com/mailman/listinfo/linux-poweredge

To post a comment login or create an account

Comment Reminder

Unrelated comments or requests for service will be unpublished. Please post your technical questions in the Support Forums or for direct assistance contact Dell Customer Service or Dell Technical Support.. All comments must adhere to the Dell Community Terms of Use.

  • Michael,

    Great news, and thanks to you as a Debian/Ubuntu advocate and Canonical for the donated effort!

    As a facility that has thousands of Debian Dell systems, we most certainly welcome any movement

    in that direction.

    --stephen

  • How difficult would it be to make i686 builds as well for those of us with 32bit ubuntu installed?

  • Hi Michael

    Is there an online demo available for us to look at?

    Thanks

    Andrew

  • This is great news. But why aren't there any 32bit packages yet?

  • A third vote for 32-bit debian packages.

  • Hey Michael,

    Just wanted to let you know we really appreciate your hard work on porting Dell OMSA to Ubuntu. As a Dutch hosting company that runs only Ubuntu/Debian on Dell servers, about 50 of them,  this *really* helps us out.

    I spent hours today looking for a solution after I found out that the OMSA 6.0x provided by Sara ( subtrac.sara.nl/.../omsa_2_deb ) doesn't support the H700 RAID controller. I was ready to give up and resign to a production server without any RAID monitoring when I found out about this great project.

    Thank you and Canonical for taking Ubuntu/Debian users seriously, as Ubuntu really is superior to RHEL/CentOS in every way (hoping i'm not stepping on any toes here :), but with no OMSA support it's a real problem for us...

    Great stuff and I really hope it can be continued for future versions!

    Thanks,

    Robin

  • Hi,

    These packages don't work on Debian (at least squeeze) for a couple of reasons:

    1) they depend on some binaries that in Debian are in libsmbios-bin - in ubuntu they're just smbios-utils

    2) for some bizarre reasons Squeeze doesn't even have the libsmbios packages right now

    I got around it by building my own smbios packages from upstream, and had them "Provides:" smbios-utils in the package control file, this allowed me to install the other packages from the site once my new package was installed.

    If you could provide a similar deb, you'd find this stuff just working on Debian (which is a good thing...)

    HTH

    Mike

  • is there a plan to 'backport' to Debian lenny (stable) ?

  • I've installed this package on Debian Squeeze, with the help of two packages from Ubuntu.

    This is a constant problem with getting vendors to recognize Debian.  Guess what?  No Marketing Department means no press releases, and no visibility.

    Years ago I was supporting a Linux Template at our University for all Computer Science students to use.  We used Slackware three years in a row, and no one in the world knew about it.  I decided to give Xandros a whirl, in attempts to have an easy to use interface for configuring the then emerging wireless in Linux.  Bang!  Dell and Xandros each issue a press release about the roll out, bragging about their role in this deployment, and I get a phone call from a reporter at Computer World asking if Linux on the Desktop is arriving.  But while we used non-commercial OS, our deployment was not on the map at all.

    Debian is way more common than vendors believe.  Even more people would deploy Debian if the vendors supported it better.  Its like they say: "if you build it, they will come".  If hardware vendors (and backup solution providers) support an OS, sites will adopt it.  If you support Debian, the underlying base of many distributions, then you are also supporting Ubuntu and Mint Linux, etc. automatically.