How do you restore your system, when system restore won't open? - Virus & Spyware Discussions Forum - Virus & Spyware - Dell Community

How do you restore your system, when system restore won't open?

Virus & Spyware

Virus & Spyware
Perspectives on PC security, including antivirus, anti-spyware and firewall solutions.

How do you restore your system, when system restore won't open?

This question is not answered

I believe I have a virus that has disabled my system.  I cannot open system restore.  Control panel is blank.  Windows is not working.  I've lost my internet connectivity.  To top it all off, I can't even re-install my operating system because the computer won't run the DVD. 

If a bit of history will help: After realizing I might have a virus, I tried updating Windows decurity updates, because McAfee hadn't alerted to anything.  Updates failed repeatedly, even after following all Microsoft support advice particular to those errors.  Decided to re-install Windows to see if that would fix update problems.  (Vista Premium Home, 64 bit)  Still had potential virus activity after that, so ran full scan on McAfee.  Nothing came up.  Had RegCure so ran scan and fix. (That was probably a big mistake, but nothing I've seen online about RegCure indicates it could cause this type of problem.)  Afterwards, McAfee wasn't working properly, (RegCure probably deleted files) so decided to re-install McAfee.  Set it to reboot when done.  Came back and found empty desktop.

Anyone have any ideas?

All Replies
  • Addendum: I've tried running in safe mode and still am unable to access anything.  I couldn't restore the system, and all of my McAfee files are .dll and unusable.  Although I opened in safe mode with networking, I still have no connectivity although router is obviously working since the laptop I'm using is fine.  I was able to check my problem log and noted that the last problem listed was APPCRASH of the RegCure previously mentioned.  I don't know if any of this helps, but at this point, I feel that I've tried everything that (in my limited ability) I know to do.

    Thanks to all willing to help!


  • Hi samaynerd, and welcome;

    I don't use Vista, but maybe something here will help, if you can boot into Safe Mode with Command Prompt:

    As an aside, I would avoid using RegCure or any other registry editor as a general cure for problems such as yours. They just compound the problem.


    Dell Forum Member since 2,000

     Use OpenDNS   MalwareBytes' Anti-Malware Free

    Windows 7/sp1 (64- Bit): Malwarebytes 3.x Premium, Windows Firewall, WinPatrol PLUS, Emsisoft Emergency Kit Free and HitmanPro Free (on-demand scanners), OpenDNS, MVPS Hosts file, SpywareBlaster, Pale Moon web browser, Secunia PSI, Sandboxie, CCleaner Free.

    Windows 10 Pro (64- Bit): Same protection.

    "In the future, everyone will be anonymous for 15 minutes" - Banksy

  • Thanks!  I'll give it a try now.


  • I attempted system restore in the command prompt safe mode and got the message that it does not appear to be functioning correctly on this system.  The volume shadow copy service used by system restore is not working.  Any other ideas, or am I done for?


  • Hi Karen.

    I do not get it. Why do you want to do a system restore? If it is a restore to a point before the infection, it is not going to help. Now if you want to do a PC Dell Restore to factory settings for Vista read this:

    Remember to back up all your documents, picture, videos, and E-mails since this restore will set your sys when you first opened your PC.

    On the other hand you can post your problem in the Malware Removal Forums here:

    Read this before posting:

    Hope it helps.


    Dim9200/XPS 410.C2D 2.40GHz.2GB RAM.XP Pro_86 SPk3. IE8 & FF38

    Avast!Free 2015. CIS 5.12(FW/D+). MBAM Premium. MCShield. WinPatrol +. WOT. OpenDNS. SAS(o/d)

    "We are all ignorant, but we don't all ignore the same things..." Albert Einstein

    "When you've excluded the impossible, whatever remains, however improbable, must be the truth..." Sherlock Holmes.

  • Wow. I have VERY similar problems.  I've lost all connectivity to the internet when it working fine everywhere else.  I cannot run any virus diagnostics.  They just go into limbo. All hardware diagnostics check out fine. 

    What did you end up doing?