SC4020 Initial Config - Compellent - Storage - Dell Community

SC4020 Initial Config

Storage

Storage
Information and ideas on Dell storage solutions, including DAS, NAS, SAN and backup.

SC4020 Initial Config

This question is not answered

I have a SC4020 that is in the process of being re-licensed, and am working to get everything in line for deployment. I got my hands on a deployment guide and have connected it to a machine using an onboard serial port, but I haven't been able to get anything out of the console port. Settings are 115200, 8,N,1. I'm having a coworker check the cable as I'm not onsite to do it myself, and should have an idea if the cable is bad on Monday.

I ended up gaining access to it via the MegaRAC, and got to an initial screen that says:

login: SCOS (R06.05.20.018) FAILED - Pre - Join information not complete; see "platform prejoin show".

This is expected as when it was removed from service, it was reset to defaults, so it needs to be completely re-initialized. The problem is I can't log into it - the deployment guide doesn't list any default passwords other than the one for the Web GUI, which I've tried with no success.

I did note that it seems you are supposed to put the controller into 'safe mode' by removing and reseating the battery, after which you can run the 'platform prejoin show' command. The problem is, as mentioned, for whatever reason, I'm getting zero output from the console port. I've tried two different machines and three different ports, all with the same result. If the cable tests bad, will a cable like this one or this one work, or is there something specific to the Compellent one? I tried getting a Dell P/N to order one, but was told it couldn't be found.

I did determine that both controllers were assigned 192.168.1.1, isolated controller 1 and set controller 2 BMC to be 192.168.1.2 so I can access both, so will this work the same as if I was using a serial port to set the config?

If the BMC console will not work and the cable tests out good, any ideas why I'm not getting any data out of the serial port?

Edit: The cable has been tested and appears to be ok - have expected continuity on all pins. So it would seem that for some reason, the 4020 isn't sending anything out the serial port.

All Replies
  • Let's assume you're using Windows, make sure that properties of the serial port under device manager-> serial port-> port X are configured like this -> 115200, 8,N,1 and let's assume you're using putty to connect into the serial, make sure under putty/serial you have the same config -> 115200, 8,N,1 and keep an eye to flow control setting(should be set to XON/XOF) both side. 

  • Some notes

    - Pre and Post SCOS 6.5 versions uses slightly different install routines. So be care full when using a wrong guide ...... watch also to msg on the screen during setup!

    - Pre and Post SCOS 6.5 uses different licenses

    - Failure #1 for me was always to forgot to connect the 2 SAS cable for the controller interconnect 1A<->2B and 1B<->2A

    - In later SCOS versions dell took the BMC out of the game. There was a technote that the BMC have to on a non routed network and no GW shoult be used. I think in my latest installation they used a PIPA address like 169.x.x.x. 

    - You can perform a factory reset if you got your serial again.

    Regards,
    Joerg