Remember way back when Dell was selling EMC storage? Well, at the time, we bought an AX-4 and an NS-120 for 2 different sites. The NS-120 went largely unused for several years, as it had been installed in a brand-new facility that hadn't really figured out what it wanted to be when it grew up. 

Well, as you may recall, Dell and EMC parted ways, and this event happened to occur while we still had an active support agreement on our NS-120. We made several attempts to get a firmware upgrade from Dell, but all we did in fact get was lip service and the run-around. Then the support agreement expired.

Fast forward to today. Money is tight, and we are desperately seeking some inexpensive nearline storage for backups. Now, I realize that relying on old, out-of-warranty hardware is hardly ideal, but we own it, it's essentially unused, and it contains gobs and gobs of disk space, enough to back our stuff up 10 times over.

So, here's the problem. The firmware. It's old. You have to use a version of Java in the 6 family to use the web interface. We don't want to/can't do that, because that ancient Java will show up on our weekly vulnerability scans, and some manager 3 levels above us will lose their mind if they see that.

My question. Is there any way at all to get firmware for an old system like this? We thought that since Dell and EMC are getting back together, there might be a chance, but inquires sent to both parties went unanswered.

Any suggestions?

thanks