Forums

Storage

Storage
Information and ideas on Dell storage solutions, including DAS, NAS, SAN and backup.

MD3200i and vCenter Add-In

This question has suggested answer(s)

Hello,

I installed Add-In on my vCenter Host (4.1). But if I start the plugin in vSpere Client, it tells me "User is not authorized to use this plug-in
Please contact the Administrator and ask for StorageAdmin.readwrite or StorageAdmin.readonly Privileges". But I am logged in as user of admin Role and this role has the StorageAdmin.* Privileges.

I found no further dokumentation for this. Links from http://support.euro.dell.com/support/edocs/systems/md3200i/en//index.htm to manual is broken.

Any hints?

 

All Replies
  • OK, after added User direct to Admin Role all works fine. User was only meber of a group which was member of admin Role.

    But the Dell guys should fix manual link for MD3xxx.

  • Hi,

    I have the same problem but I have no idea about Roles yet. Where did you add User to Admin Role, please?

  • That links was broken to me at first, too ... then I removed the double / / from between /en and /index and it worked ?

  • Thanks, it works.

  • Once you get the user's guide link working (see other comments), check out the Configuring Storage Administrator Roles section --  I believe it will answer your questions. By default, vCenter IDs start out with no rights to access the array. Once you add the appropriate roles, you're set to go.

  • Thanks again. I've got through.

  • But the plugin does really little more then give quick overview of the array status, no much use really

    Seb

  • This thread has been confusing, but I finally found the passage in the manual. However, I am using vSphere 5 and the manual does not match up with vSphere 5. However, I am having the same problem. I did try setting up a Storage Administrator role and assigned a local (VMcenter) server group for it allowing all administrators access and then setting the permission on the cluster (to propagate down. I still get the same error message.

    Also, during the process of setting all this up, several of my user permissions reverted to read-only and I cannot delete them or modify them to set them back to administrator access - so I have an additional issues now.