Windows 8 Dell Backup and Recovery Manager doesn't work - Windows 8 - Software & Operating Systems - Dell Community

Windows 8 Dell Backup and Recovery Manager doesn't work

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

Windows 8 Dell Backup and Recovery Manager doesn't work

This question is not answered

I have an Inspiron 7520 and uninstalled and reinstalled the new version of Dell Backup and Recovery Manager -- upgraded to premium to make sure that I would have full ability to use the program. Note: the old version didn't work at all -- hung up on backup, etc.

I have rebooted.

When I try and open the Manager interface, I can't. All I get is the clock logo with the hand spinning. I cannot set the destination. I cannot select what I want to back up. I've tried this several times and just get the spinning clock which I end up ending through Task Manager. 

I have tried opening the Manager from the installed link on desktop, from my list of programs, from the Start menu, and from the tray icon. Nothing works.

Any suggestions?


All Replies
  • I have the same issue with the non premium version, I made the mistake of upgrading to v1.0.0.4 that is available for download and now have the same spinning clock, the program never loads so can't do anything with it. I have tried twice now to uninstall and then reinstall but still the same issue with spinning clock.

    This is on a brand new XPS 8500 running windows 8. The reason I tried upgrading is that the version I had would not create recovery disk on usb key (would take forever to see the usb key and then would fail with pretty much useless error message before writing anything to the usb key, all it would do is format it to something that could no longer be read by windows.

  • So today I get a pop-up message to upgrade Dell Backup and Recover to v1.0.0.5 again and I let it install and then after the required restart I start Backup and Recovery and yes you guessed it, still the spinning clock, the program still will not open. I don't get this, this is a dell built machine and their own software won't run, do they not do any testing before releasing updates?

  • I got an even worse situation: I tried to open as an Admin. Got the spinning clock. Ended task with Task Manager. Then got this error message: "Dell Backup and Recovery has not been able to detect the Recovery Partition on this computer. It may be missing or corrupted. To recover your computer to the original factory state and restore the Recovery Partition, please use your System Recovery Discs.  Note: you will not be able to preserve your data with Dell Backup and Recovery System Backups until the Recovery Partition is repaired."

    Really? You want me to do system restore? You've got to be kidding me. New computer. Nothing wrong except that the Recovery partition was probably screwed up  when I bought it because Dell Backup has NEVER worked. So I'm not holding my breath on that particular option.

    I would bet that it still won't work and I will have spent hours and hours on this for nothing. Maybe when I have a few days with nothing else to do AND I've read that others have resolved all other issues with this stupid program.

  • I've had this problem too and after hours on the phone with support I just decided to go with a cloud backup solution from since it works for all our desktops, laptops, servers, and VMs.

  • I'm using Slimware's Reclmg Manager which I actually had to use to go to a restore point and it worked, so better than nothing. And  better then wasting time trying to do a system restore when Dell Backup didn't work when I took my computer out of the box. Thanks for letting me know that you have similar issues.

  • I had an even worse experience.  After starting the recovery process with Windows 8 on a new Dell laptop, I inserted an 8 GB USB drive in into the computer.  After the recovery process failed, the USB drive became unusable.  It cannot be read, it cannot be formatted.  It was destroyed.  Please be careful with the Dell software on a Windows 8 computer, it will damage other computer peripherals.

  • Hi marcb52,

    As you have mentioned the recovery process failed, please share if the system is booting right now or not. Were you trying to recover the system using the flash drive? Are you getting any errors?

    You may run the hardware diagnostics to check for the hardware functionality. Please follow the steps below:  

    • Reboot and press F12 to enter the Boot Menu
    • When the boot device list appears, highlight Diagnostics and press Enter
    • The computer begins to run the Pre-boot System Assessment, a series of embedded diagnostics that perform initial testing on your system board, keyboard, hard drive, and display
    • In case any hardware component is bad, you will get a corresponding error

    Dell Backup and Recovery software should not affect the flash drive. You may try to format the flash drive from the command prompt. Please follow the steps below:

    • Press ‘Windows’ key + R on ‘Desktop’ screen.
    • Type ‘cmd’ in the run box and hit ‘Ok’
    • Type ‘diskpart’ ->Enter
    • Type ‘list disk’ ->Enter
    • Type ‘select disk X’ ->Enter (x is the allocated number for the drive).
    • Type ‘clean’ ->Enter

    Keep me posted with the information. I will be glad to assist further.

    Thanks & Regards
    Amogh G
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

  • So I noticed today that there is a newer version, I have installed it and this stupid program still won't start, just the spinning clock on the desktop forever!

    I have to wonder if Dell ever test this software, this is the third version I have tried and none of them have worked, ( at least started but couldn't actually do a backup so it was useless, wouldn't start, just the spinning clock and now the same spinning clock).

    I don't think I will bother trying any further versions of Dell's Backup and Recovery software, time to move on to something that works.

  • I have been getting the spinning clock too. The Windows 8 application log shows an abort in DBR.exe.  I paid $39.00 for the upgrade Dell nagged me to make.  Did anyone get their money back?  Dell support acts like they never heard of anything called Backup and Recovery.

    Faulting application name: Dbr.exe, version:, time stamp: 0x50ae2f1c
    Faulting module name: unknown, version:, time stamp: 0x00000000
    Exception code: 0xc00001a5
    Fault offset: 0x00330049
    Faulting process id: 0x34c
    Faulting application start time: 0x01ce6e97bce4f01c
    Faulting application path: C:\Program Files (x86)\Dell Backup and Recovery\Dbr.exe
    Faulting module path: unknown
    Report Id: 52a9bd2b-da8b-11e2-be8e-c48508b3eaf1
    Faulting package full name:
    Faulting package-relative application ID:

  • Dell Backup and Recovery updated itself yesterday to v1.5.0.0 and I am shocked it actually works! The spinning clock runs for about 30 seconds and then it finally opens and I was able to do make a factory reinstall disk to usb key. Now it wants me to upgrade to premium so I can do scheduled data and system backups, no way to do that with the basic version. I don't think I will bother, I have another working backup solution I am not going to waste money on Dell backup software now.

  • The utility cleaned the disk, but it still cannot be formatted by windows.


  • Beware cloud backups. I used Carbonite for backup solution on two computers. Even paid premium to backup my USB drives. All appeared to be backed up correctly... until I needed to restore a damaged disk to a new disk, then I learned that the USB drive was NOT backed up... well about 1% of it was, but 99% of the documents, pictures, music files, and videos were not in the backup on Carbonite.

    I lost Carbonite after getting a NOOP on their customer service, just run-arounds. Then found that Acronis backup can't handle SSD drives worth a dime. Ended up with Macrium for backup solution. Recommend them as they actually  work on a DELL XPS 2720 with a 30GB SSD Drive RAIDed to a 2TB HD.

    I won't go with another cloud storage option forever. They limit the types of files you can backup, then don't backup what they claim to handle. Worthless waste of money in my opinion.

  • I had good advice many years ago, always do a test restore after setting up new backups to make sure what you think is being backed up really is being backed up and do regular test restores (monthly or quarterly depending on how important the data is to you). Never assume a backup worked as you expect just because you didn't get any error messages. I think that is good advice whether you are using cloud or any other method for backups.

    I remember one coworker being in tears after she lost all of her data after a hard drive failure despite doing daily backups to the server. She discovered to her horror after doing a restore that all that was available to restore was a lot of empty folders (her wild cards to decide what file types were to be backed up were not set correctly so no files were backed up, just directories) Needless to say she had never once tried to do a test restore to verify her backups were working properly. I felt bad for her, not really her fault, she had been told to do daily backups and she was but no one ever told her to test them by trying a restore.

  • I made the mistake of letting mine update itself too.  It hung at "Restarting..." and the GF turned it off.  After a very long chkdsk and a few days it tried updating again and is now spinning forever on "Restarting..."

    The drive is occasionally active, the spinning marbles are going around and around and the mouse pointer still moves.  It's reachable as an SMB server on the wireless network and writing the Win8 file history backups to another server . . . but on its console it's been spinning the marbles beside "Restarting..." on a black screen and nothing more for about four hours now.

    The mouse pointer moves but clicking does nothing.  The caps-lock light toggles.  Ctrl-Alt-Del: nothing.  Alt-Tab: nothing.  Windows-C: nothing.  Windows-R: nothing.  

    I'm starting to wish I'd installed a way to do an orderly shutdown without a working console.  SSH to cmd, even.

    Tapped (didn't hold) the power button and it went dark and eventually shut off.  Came back up with version available (after a good two minutes of the spinning clockface) and claiming to be the current version.  The file shows compiled Nov 4th, 2013 16:53:14...  so whatever version was pushed right before that is the one that flubbed the restart process.

    Ugh.  Oh, and starting the 'restore' process shows it unable to find any of the dell backup I did a month or so ago, though it remembered the network folder I'd chosen as the destination.

    Starting a new backup I got the same vague "an error has occurred" message as last month.  The folder receiving the backups shows six files, two roughly CD sized and one about a fifth of that.  As before, trying to restore shows nothing to choose from.  

    I'll stick with Windows File History and Norton 360 for backups, for now.  The built in backup stuff finally seems pretty good under Windows 8.1.

  • The following morning I've confirmed that version (whose executable says it's version doesn't work for backups.

    It wrote 13 files to the network drive: three small ones and ten meaty ones at about 666,500KB, give or take a few hundred K.  

    The first three meaty ones are dated about 15 minutes apart.  The next six are dated about an hour apart.  The last one, about half an hour later (about five hours ago now).  They total about 5.8GB.

    The most recent two of the small ones are dated three minutes after the fourth one back in the meaty series.

    The Dell software says in white type on a blue background "An error occurred during the process".  The green progress bar is all the way to the right.   A blue spinner continue to spin beside "Backing up".  In the bottom right corner a button says just "   OK   ".

     I pressed okay and took a look at the options under data restore.  After "Data recovery" and "Yes, continue" I got "Dell Backup and Recovery encountered a problem and needs to close.  We are sorry for the inconvenience. [Close]"

    So, right, backup doesn't work.  Anyone tried the recovery disks it burns?  The bootable system restore thumbdrive it wants to make?