DataSafe stops working when I turn my computer on. - Productivity Software Forum - Software & Operating Systems - Dell Community

DataSafe stops working when I turn my computer on.

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

DataSafe stops working when I turn my computer on.

This question is not answered

When I login to Windows 7, I get the following error...

DataSafe Update Launcher has stopped working.

A problem caused the program to stop working correctly.... (Windows doesn't notify me of any solution).

Events leading up to the problem

I uninstalled DataSafe Local Backup, and during the shutdown part of the reboot process a Windows 7 critical update was installed.  After the computer cycled power, the Master Book Record was corrupted (I dual boot with Ubuntu) and the computer would halt saying no boot sector was found.  Using F12 I first tried rolling back to a Restore Point, which didn't work.  Second I used F12 again to access the command prompt and used "bootsect.exe /nt60 SYS /mbr" to fix the Master Book Record.  This fixed the boot-up problem, but now I'm getting these DataSafe Update errors.

Extra Info

  1. DataSafe Local Backup is back in the installed programs list, and I can't remove it.  The uninstall process doesn't even begin.
  2. I've tried using DELL_DATASAFE-LOCAL-2-0_A01_R249580 to fix the problem, but there is no change.

All Replies
  • ****DataSafe Update Launcher has stopped working.***

    Go to Programs and Features in Control Panel and uninstall a software called Dell Datasafe Local Backup - Support Software

    Restart the computer.

    This should take care of the above error message.

  • I did try the above troubleshooting step and it worked.

  • Greetings!  I tried removing the program and all the associated files. Instead of completely removing the program I now have two programs listed under Programs and Features:

    Dell DataSafe Local Backup

    Dell DataSafe Local Backup - Support Software

    Both show nothing in the file size column and I am still getting the errors. Are there additional steps I can take to get this off my computer?