Forums

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

FastAccess Facial Recognition software, Windows 7 x64 bit, and Studio XPS integrated WebCam camera

This question has suggested answer(s)

I just received a new Studio XPS laptop with integrated webcam, running Windows 7 x64.  The FastAccess facial recognition software does not work consistently.  sometimes no image is displayed in the image box; it will be black with either a green or red border.  Also, it is eating up about 20% of my CPU time when idle; if I 'Disable FastAccess Temporarily' the usage drops right down.

When I called support (I called the day I received the laptop) I was told that the integrated webcam may not be compatible with Windows 7 x64.  I was also told that I needed to call Dell's advanced software support line, and that I would be charged for the call. 

So, in other words, Dell sold me a laptop with incompatible hardware and software, and expects me to pay for service to take care of it?  I hope that is not the case.

Anybody out there that can point me in the right direction?  The FastAccess software does not show up in the software downloads area for my laptop.  I don't believe the integrated webcam driver was there either.

Thanks in advance

All Replies
  • I have the exact same experience and feelings about the situation.

  • I'd be happy to try to help. Let's take a few points from your message step by step.

    1. What version of FastAccess are you running? Version 2.4.7 or newer is fully compatible with Win7.
    2. CPU usage is measured by Windows in a strange way. When your system is at idle, the processor gets throttled back considerably to save power. The percentage used by any app is reported as a percentage of the total cycles available at the slower speed. This make the percentage jump way higher at idle even though to the total cycles being used by FastAccess aren't any more than normal.
    3. The image not being displayed is certainly an important question. Without a consistent video feed, FastAccess clearly can't do it's work. It sounds like there is some sort of difficulty attaching to the integrated camera. 
      • With FastAccess disabled, does your camera work in other applications?
      • How exactly is it showing up in the Windows Device manager?
  • For no apparent reason, Fast Access has begun using 20% of my CPU. I have version 2.4.7 on Vista 64 and I use Face Login mode only. This is absolutely ridiculous.

  • Sensible Vision is committed to providing software that not only provides significant workflow and security benefits, but that provides those benefits in a way that’s as efficient as possible. Here is some information to start the discussion. Please feel free to contact Sensible Vision directly using the support email address (available on our website). We are most eager to reproduce any non-standard behavior and resolve it.

    1.       1. Security Mode: The different security modes have different functions, purposes and CPU usage.

    a.       Face Login:  About 45 seconds after a login/recognition FastAccess CPU usage should approach 0%. Do not take CPU measurements until this time has passed.

    b.      User Switching and Continuous Security: Both modes have real-time features (automatic switching between users and automatic desktop locking) so somewhat higher usage is expected due to ongoing video analysis.  3% to 5% is normal.

    2.       2. Virtual camera: If using another video application that is running, FastAccess will report much  higher usage. This is expected as it provides video to the other application.

    3.       3. Measurement techniques: When measuring CPU use, bear the following in mind:

    a.       Measurement Tool:  Both the Task Manager and Resource Explorer report usage as a percentage of CPU speed available at the time. How much speed is available (and hence the percentage reported) can vary widely as Windows slows the CPU to save energy.  Either measure in the “Max Performance” Power Plan which minimizes this throttling or use Microsoft’s “Process Explorer” to get a more accurate measurement.

    b.      Usage Spikes: Very brief, transient spikes of higher usage are always possible. If Process Explorer is set to sufficiently high resolution, these peaks may occasionally be visible. They have very little effect on system performance or battery life, however, and can safely be ignored. What’s important is sustained average usage (over 2-3 seconds).

  • Thanks for all that. Unfortunately, none of it helps. I have no other camera apps running, I'm using Process Explorer, and the CPU hogging is not a spike.

  • Kleinzeit

    Thanks for all that. Unfortunately, none of it helps. I have no other camera apps running, I'm using Process Explorer, and the CPU hogging is not a spike.

    Very good - thank you very much for the additional detailed information. I do appreciate it.

    Would you be willing to contact me directly for support? There are some additional questions I would like to ask and tests to run that would be easier to set up using actual emails.  We would, of course, look to share anything that we learn back here on the forum.  If you're willing, there is a support address on sensiblevision.com or you can send me a private message and I'll return with my personal address. Thanks!

  • I would like to help but I've already uninstalled it. To be honest, at this point I don't see myself re-installing (which would presumably be necessary to run these tests.) Thanks for trying to help though.

  • I understand and thank you for the information.

    Just FYI for everyone - Sensible Vision has expended considerable time and effort recently re-testing on all possible Dell platforms with an eye specifically toward CPU utilization. Reproducing the symptoms reported here is the key to addressing them. Thus far we have been unable to create the levels of usage reported here in any of our tests.

    Based on this, our theory is that there may be another program or process (which we don't have) that is causing an unexpected and undesired interaction with FastAccess. We are trying to identify the specifics through communication and testing with users who are experiencing it. Therefore if anyone who is seeing this issue would like to contact me directly, I would be happy to work with you.

    Thanks.

  • I've posted this elsewhere but since this thread is getting a response I'll repost it here:

    I have had nothing but trouble with the facial recognition software on my new Dell Studio laptop. I have updated the software, I have uninstalled and reinstalled from the Dell website (since there were no disks included).  I have gotten the Windows login to work but still can not get the web login feature to work. I have windows 7 and IE8, i've tried playing witht the security settings but if there is something specifically I need to do, i'm not sure. Strangely the web login feature worked when I first got the computer and mysteriously just stopped, before I changed anything...

  • Nickmartell

     I have gotten the Windows login to work but still can not get the web login feature to work. I have windows 7 and IE8, i've tried playing witht the security settings but if there is something specifically I need to do, i'm not sure.

    Make sure that the "Add-On" that FastAccess uses to interact with IE is both present and enabled. To do this, in IE go to Tools > Manage Add-ons. The one that you want to be there is called either "FAIESSOHelper Class" or "SSOIEAddonBHO Class". If any other program (or something like "In-Private" browsing) happened to disable this Add-on, then interaction between FastAccess and IE would not be possible until it's turned back on.

    For further details, see FAQ #18 on page #11 of this FAQ:

    http://www.sensiblevision.com/v/dell/faq.pdf

  • FAIESSOHelper is present and enabled. I reviewed the FAQ and none shed any light on my problem.

    When I go to enable the web log-in function in the settings it will not stay selected (meaning I select the box and save settings but when I go back it is unselected again.

    Thank you for your assistance.

  • No problem. Sorry that the obvious answer wasn't the right one.

    What version of FastAccess are you running? 2.4.7 is required for Win7 compatibility. Right click the FA icon in the system tray and choose "About".

    If you're already on 2.4.7, then as obvious as it sounds I'd actually recommend a de-install and re-install. I've never personally seen the symptom that you describe where the setting won't stay selected so there may be something that was corrupted with the installation itself.

    Just to confirm as well, you're logging in with an account that has administrative rights, correct?

  • I am running 2.4.7 and have tried re-installing once already, that fixed the problem when it was not working at all; as I say now it's just the web login that won't work.  and yes I am logging in as an administrator.

    I'll try re-install again...

  • Let me know how it goes.

    Random question - what anti-virus are you running? It might be worth disabling it when doing the re-install on the off chance that it's incorrectly identifying a FastAccess component as malicious and damaging the install somehow. This is just a theory for now, but it would explain things if multiple re-installs end up having the same issue. Believe me, I've seen stranger things....

  • OK disabled McAfee anti-virus and did the full uninstall / re-install, same results: No web-login feature working...is there something ridiculously simple that I need to "turn-on" or enable or needs to be done to get web-login working. Again strange thing is when I first received the computer from Dell everything worked fine, no idea what has changed. and yes checked the add-on after re-install and it is there and enabled.

    Frustrating, thank you for your continued assistance.