"Dell Dock has stopped working" - Very annoying! - Productivity Software Forum - Software & Operating Systems - Dell Community

"Dell Dock has stopped working" - Very annoying!

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

"Dell Dock has stopped working" - Very annoying!

This question has been answered by Lily 333


Normal 0 MicrosoftInternetExplorer4


I cannot tell you how much time and effort I put into trying to solve this but it seems impossible.

I bought an Inspiron 1525 laptop just 4 months ago and was quite happy with the Dell Dock feature as it made life easier when working with Office. That was until the bleeding Dell Dock went bananas and doesn't run anymore. It's quite annoying because every time I turn on the computer I get the error message about 5 times in a row! And when I try sending the error report I get another error!!!! How frustrating...Angry

I tried getting rid of it and reinstalling but it won't work neither.

Called Dell and they told me they do not offer support for this and I'd need to pay ££ to get help.

Now....this is ridiculous! I did not ask for the software, "Dell geniuses" decided to install this piece of faulty software in my machine and now refuses to offer help!!! Shame on you Dell!!

Well, if you are a user and is having the same nightmare, please let me know if you found a solution, I'll be very grateful and might light you a candle.Wink

BeerRight Hug

Verified Answer
  • My husband has a Dell Inspiron Zino HD that had the same problem.  I went to www.delldock.com.  They have a free download for dell dock.  I did the download and it fixed this computer.  No more Dell Dock errors.  It's worth a try and it is free.  Good luck.Big Smile

All Replies
  • Ok, here is the my thought on the whole dell dock thing going on. I have read some of the other statements people have left. Most of them are the same things being said. “ my dell dock just stopped working and when I try to send the error report, I get another error message. I also have uninstalled and reinstalled the dell dock, and I still get the same messages. When I called dell all they said is software and hardware warranties are not the same . The software is not covered buy the warranty.” I thought that was kinda strange, The dell dock just stops working out of the blue, and I can not send an error report……Hhmmmm Sounds very fishy to me. so I decided to give dell a call and see what was going on . Sure enough when I called all they tried to do is get money out of me. They told me it would cost me “ up to $500.00 ! ! Depending on witch deal I wanted. SO, TO EVERYONE OUT THERE WOUNDERING WHATS GOING ON WITH THE DELL DOCK………, MY THOUGHT IS THAT PROGRAM IS A TRIAL VERSON ONLY ! ! WHEN IT EXPIRES THEY WANT MORE MONEY FROM YOU ! ! ! Dell was so good to me when I first got my computer, one year later they treat me like a pile of YOU KNOW WHAT.

  • I went through something similar on my new laptop=- they told me I had a software problem and it was not covered under warranty and offered be costly assistance- I told them I cannot afford that!! He then offered a one time software support deal for 100 dollars plus- I said - no thanks and during the time and being on hold- I tinkered w things- went back to a previous restore date and that looks like it fixed it- the man told me- it is only a temp fix and blah blah blah!!!  I could not believe my ears!  I read earlier about someone going throught the same thing- and trying to be sold costly software support-0! I had owned a dell before- not a laptop= thought  I would try this- I don't appreciate customer service like this. You might want to try system restore to a previous date- hope it works for you.

  • dell wireless wlan card wireless network controller stopped working and was closed

    Dell DataSafe Online


    All these three have died on my daughter's two month old dell inspiron 1750 Vista Home Basic.

    They are all functioning on my di 1750 Home Premium

    There is a clear issue when various windows updates are overlaid such as Office Live Add-In.

    It does not help that vista service pack 2 is not installing properly.

    If I get to the bottom of this I will provide an update, so far touring google ftp downloading the original copying between machines is not getting to the root of this.

    You can tell something is up if you go to support apps on dell and try a download and then .net chokes (dfsvc.exe has stopped working).

    It might be Dell (stardock.com) or it might be microsoft


  • Microsoft Office 60 day trial, I think this is somehow connected.

  • hi all

    i got the same thing today. i was thinking it might be the result of malware as just before this happened i found something with malwarebytes and removed it. i get the message dell wireless wlan card wireless network controller stopped working (thank got the wireless internet is actually working). i also get the delldock has stopped working message and this one has in fact dissapeared. i tried to dowload drivers from the website but is says dfsvc.exe has stopped working...what's going on? any solutions? these pop up messages are soooo frustrating

  • "dell wireless wlan card wireless network controller stopped working and was closed"

    This can be surpressed as follows: "Control Panel->Administrative Tools->Services" and search for "Dell Wireless WLAN Tray Service"

    Double Click on the item change it to manual and also select stop.

    This will mean the irating message box does *not* keep popping up, does not solve the issue.

    If you folks are still on this while you are there attempt to open the Event Viewer because I want to know if it chokes with CLSID FX b05566ad-fe9c-4363-be05-7a4cbb7cb510 which tells me it is locked by one of these dell things or office 60 day trial having a game. If you know about the run command %SystemRoot%\system32\eventvwr.msc /s is the same as going through control panel. I am trying the big boys toys from www.sysinternals.com now owned by microshaft e.g. procmon.exe but as yet nothing is sticking out as obvious. http://www.stardock.com/products/objectdock is a free download of the Dell Dock product but I would rather get what shipped with my computer working.

  • Hi,

    Any news on this problem yet?

    I have exactly the same on my son's Inspiron 1545 which is about 4 months old.

    Dell wireless wlan card wireless network controller stopped working and was closed

    Dell DataSafe Online


    This is so annoying, the Wireless Lan card pops up after everthing he tries to do!

    Please help!


  • The wireless card message can be surpressed as outlined above. It is not office 60 day trial as I cleaned that from my daughter's machine and put office 2000 pro in place.

    I have to run procmon on the two machines might get around to that tomorrow


    is a nice tutorial on procmon http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx By Mark Russinovich and Bryce Cogswell

  • Chezzi, I have tried everything. From procmon I found where the delldock was exiting and studied the entry points of the vista system dll entry points. One is just an address and clearly the problem. Could not unintall the one shipped with PC as such could not get the version you can download to install (dell downloads do not work if you have the problem we have so I downloaded via my machine). It also appears to be a 32 bit application (according to procmon) installed in "program files" when that should be "program files (x86)". I might try to attach the visual c++ 6.0 debugger and then try and run it but that would mean putting my development kit on my daughter's computer. I even moved delldock.msi and tried to cheat the original into using that for repair, which it did up to the point of running delldock.exe. I think windows update has deprecated something that the program depends upon. The one thing I am left with is that EVENT VIEWER is not running on the machine. Can you run event viewer? (Control Panel->Administrative Tools) as to make any progress I need to know what is common with your machine and my daughter's machine. Are you using vista home basic? The only other path to explore is to contact the authors of the product by email. If I had the source code then it would be a walk in the park.

  • Rat1960


    Chezzi, I have tried everything.


    Given your obvious knowledge, and how deep you've gone to try and resolve the problems, I probably know the answers to these already.

    But humour me please, by confirming "everything" includes reinstalling/updating the wireless card drivers, and reinstalling/updating Dell Dock?

    Have you also tried downloading/installing the stand-alone version of Vista SP2, rather than doing it through Windows Update?

    From experience, I've found that:   “Beauty is in the eye of the beer-holder”!!


    XPS M1730:

    Smoke Grey Magnesium Alloy Chassis - with White LED Backlights
    17" UltraSharp WUXGA Widescreen TFT (1920 x 1200) with TrueLife
    Intel Core 2 Duo Processor T9300 @ 2.50GHz (800 MHz FSB, 4MB L2 cache)
    4GB (2x 2GB) Patriot Signature PC2-5400 @ 667MHz
    DUAL 512MB Nvidia 8800M GTX cards in SLi + 128MB Ageia PhysX
    640GB SATA II (2x 320GB WD Scorpio Black 7200rpm)
    8x Super-Multi DVD±RW
    Creative X-Fi Notebook (ExpressCard) + Creative GigaWorks T40 Series II
    Integrated 2MP Webcam
    Dell Wireless 355 Bluetooth 2.0 Module
    Intel Next-Gen Wireless-N Mini-Card
    TV Tuner and Dell Travel Remote Control
    4-in-1 Flash Card Reader (SSD/MMC/MS Pro/xD)

    230W AC Adapter / 9-cell Lithium-Ion Battery

    Windows 7 Home Premium (64bit)

  • When I say I have tried wveryhting, i mean within my limited capability, I am not a computer whizz!  I have tried the various suggestions I have found on the web, ie uninstalling the LAN card and reinstalling etc, running all updates etc etc. nothing too complicated.

    I have sent a reques to DELL as this machine is under warranty and let you all know the result IF  I get any help from them!

    I have not tried the Vista SP2 direct, all updates have been doen via the usual WIndows update facility.


  • Fireblade there are three issues: a) dell wireless wlan card wireless network controller stopped working and was closed. For this one I have simply stopped the service b) Dell DataSafe Online. I have not bothered with this but it goes crash and

    c) DellDock. Now this one I have tried everything. Firstly on my daughter's home basic you *cannot* download from dell, see earlier in the thread, so I know it is all the one symptom. I cannot uninstall the version shipped with the machine as delldock crashes during the uninstall. The downloaded older version from dell which I can download on my dell which is running home premium has no problems with these dell utilities. She gets the issue whether or not SP2 is present or not. Delldock stopped working prior to SP2. Ofcourse I have not tried *everything* we could re-load the entire OS and all our other stuff from the disks (if I could find the home basic disks). Somewhere in the registry is a screwed up reference which I suspect does not go wrong in HP but does in HB. Besides one of the first things I tried was to copy my working delldock to her machine, so it is not actually in delldock or its dll's but in one of the vista files that it calls. As such reinstalling dell utilities is a waste of time.

  • Hi, running windows 7 home premium 64 bit had exact same problem with dell dock, I think i have managed to fix it.  I deleted everything from both program fiels folders and the hidden program data folder that was related to dell dock.  I also had to end all related processes to completely remove them.  I then downloaded the drivers from this link:


    and it started up and is working fine.  hope this helps


  • Luke, useful!! I am going to grap the girl's computer and try this 

  • Nope. It is something to do with Vista Home Basic. You can download from www.delldock.com if like my daughter your dell toys are bust you *cannot* download from dell drivers.  I know that whatever is stopping event viewer from running is at the heart of it. There are no msdn blogs on what is causing that on my daughter's machine. If you goto c:\windows\microsoft.net and have only framework ( eg HB ) then you have the problem if you also have framework64, then you do not have the problem. I think a value in machine.config is stuffed along with a value in the registry.