Dell Dock Won't Run - Productivity Software Forum - Software & Operating Systems - Dell Community

Dell Dock Won't Run

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

Dell Dock Won't Run

This question has suggested answer(s)

I have an XPS M1530 running Vista- Ultimate 64-bit, about a week ago my Dell Dock stopped working and it would just give me a message that it encountered a problem and needed to close, I cliked on send error report, and a check was place on restart Dell Dock, it just tells me that there was an error submitting the report to try again, and it just won't do anything after that. I've tried reinstalling it and still the same problem. Anyone have the same problem or a fix?







All Replies
  • 1. Ran services.msc

    2. Look for Dock Login

    3. Double left click on it, check if its set to disabled.

    4. If its disabled, select Automatic on the drop down box.

    5. Then click apply or OK, restart the system

    Let me know if it works..



  • I reinstalled it to try what you suggested but it's working fine now. I'll try what you said if it gives me any problems but it seems odd that after reinstalling it works fine since I had tried that many times before.





  • Hi Loise I have the same problem Marcos had with his Dell Dock however I have an Inspiron 1525 on vista and I tried your solution and it didn't work. Do you have a solution for Dell Dock on my system?



  • Hi Erika, the best way to resolved that issue is to uninstall the dell dock by going to programs and features in control panel, then after you uninstall it, restart your computer. go to, download the application and install it on your computer.

    Let me know if it works..



  • It went through a period of that with some Microsoft updates, seems to be not erring out quite after about three days of errors. But I have another issue that I'll have to post elsewhere if I cannot find a suitable posting of the issue.

    XPS 630i Intel Core² (Wolfdale) 3.0 GHz; BIOS: 1.0.13; 4 GB DDR2 @ 800 MHz;
    Hard Drives: 320 GB, NCQ Western Digital; 640 GB, Seagate;
    Optical Drives: 48x Combo CD-RW; 16x DVD+/-RW; Creative X-Fi PCI Sound;
    Nvidia GeForce 9800 GT w/ 512 MB; 19 in 1 Media Reader w/ Bluetooth;
    Windows 7, 64-Bit (Primary), c/b Vista 32-Bit, 32 Bit (OEM); 2.4/5 GHz Wireless 1505 PCIe WLAN

  • I hope you don't mind if I ask you for some help. I have the same problem about my "dell dock" as Marcoshid had.

    The only thing is under my task manager, the dock login says it's running.

    I stopped the running and then restarted the running but still won't work.

    I also have Vista Home Premium, 64 bit.

    Also my recyle bin is on the dell dock and I deleted something that I wanted back and I can't.

    I don't have a recyle bin on the desktop.

    If you have any ideas please let me know. I would greatly appreciate the help.






  • Inspiron 1525 with Vista Ultimate (SP2 fully updated) 32bit

    I also have the same issue here are some pix (see below). I have tried everything, uninstalled then restarted and downloaded the latest version from delldock then reinstalled and restarted, and checked that the service is set to automatic and running, (several times) all to no avail, i still get the same error.

    I contacted dell who wanted me to pay them £57 for them to restore my system to factory setting ...eek no thanks. Please is there another solution to fix this?


    Bunny to get your recycle ban back right click on the desktop and select personalize at the bottom of the drop down box. Then select change desktop icons under tasks on the top left. Make sure you then tick the box for the recycle bin and select OK.



  • Spent several hours searching the web for a solution to this, as I said in my post the uninstall/reinstall doesn't work even after cleaning the registry. I find it most unusual that not even dell themselves have a solution, and it seems that this is happening to many users of dell dock all over, seems to be from around April this year. if all that can be offered is a return to factory settings then surely they should look into it or withdraw the software which comes pre installed. With a 4 year on site warranty I'm astonished that is all that can be offered to fix the problem and wanting to charge nearly £60 sterling as well after all this came pre installed and is dell software admittedly made by stardock.

    The same rings true for the failed blue ray playing software media direct, this is another sad story. After spending a lot of money on a top end machine I'm a tad disappointed. I love the laptop but little things like these let the customer down. The idea of including dock software is great but it has to work, and if it does go wrong the reinstall should fix it. Well i've removed it for good now and have installed rocket dock which i hope will suffice instead, just means i have to start again and customize everything. Fortunately though it is free and very well supported. As for media direct, it looks like I'll have to purchase something that actually works like windvd. It's great that my laptop comes with blueray but not much use if the supplied software doesn't work properly. I know I'm going off the point somewhat and I apologise but I understand it being hardware warranty but I really think they should support their own proprietary software such as MD and delldock.

    i am aware too that it isn't just my machine either as we purchased several and they all exhibit the same issues with MD not supporting consistent playback of all BD movies. There is no update available so we are left hanging in the wind and as far as I am aware this is an issue on inspiron and studio models i have tested.

    Well that's enough rambling for now I do hope that they find a solution for those who want their dock back for whom the reinstall option hasn't worked.

  • Well here's an update, that I hope may help others in the same predicament and maybe dell themselves will take some notice and look at fixing this as it seems their own software is corrupt as opposed to my pc.

    Firstly started using rocket dock which has a wonderful interface but lacks the "Grouping" facility of dell dock...meaning grouping similar shortcuts together  say all your email links or applications related to media etc.  Then I thought I'd try object dock the free version made by stardock, who also make and licence the dell dock software. Again this is really great with a wonderful interface, but again lacks the grouping feature in their free version. You have to pay to get that as well as some other features. It seems stardock have made the dell dock quite boring compared to the other two and lacking somewhat in functionality, but the grouping feature is a must in my opinion.

    Well the advice on the dell support page is go to and download there and install. Well if one does that it doesn't work we get the errors indicated above. So i took a look again at the downloads and drivers section for the inspiron 1525 and under apps is the dell dock. Annoyingly dell have changed this to force you to use their ridiculous download manager which you have to install. Whoever had that bright little idea should really be not working in IT. I had previously always recommended dell on how easy it was to find the right drivers and quick to download them.  After waiting half a minute for it to validate it proceeds to download a zip file V E R Y   S L O W L Y. This is a tiny file that shows as 0mb but takes ages yawn, and I'm on a 20meg connection. Upon extracting the contents of the zip I'm amazed to find just a text file telling me to go to Is this some sort of a practical joke, because i cant help feeling that this little surprise wasn't worth the wait.

    After a prompt deletion of this timewasting file a closer look on the page reveals a link to Other Versions (link below)

    In there it seems there are two other downloads. Both seem to be the same version though with different dates. One has a 3rd July 2008 date the other 14th July 2008. I thought I would try the later one 1st (14th July 2008). Again going through the painful experience of the awful download manager i eventually got the downloaded app.

    DELL_DOCK-APPLICATION_A03_R192718.exe which when extracted to a folder has the exe install file and a text file with version info. Upon attempting to install it appears this is only an update version. The installation fails stating there are missing files and a previous version is not installed. I then downloaded the early version from 3rd July 2008 STARDOCK_DELL-DOCK-APPLICATI_A03_R186613.exe. This I extract and this time it installs correctly and even runs...and works. I am astonished.

    Some of my links and old setup from before remain intact others not but at least i can rebuild it again. I've yet to try the updates to see what will happen and when i try install the 14th july version and then maybe the version from dell

    Surely the advice on the download page should not be go to but at least a mention that one should 1st install the earliest version and indicate the the later of the 2 other versions is strictly an update version.

    I will post back when i know what happens when you install the other 2 versions on top.


    The 14th July update now installed, it seemed all my previous links were there just that the main icons for Internet and chat were missing, very strange.Just installed the version from over the top it now requires a restart so i'm hoping it works after that.

    If so the advice would be uninstall the non working version.

    Install the 3rd July 2008 version

    Install the update from 14th July 2008.

    Install the latest from [maybe here's hoping ;-) ]

  • This is the error I now get on restarting after installing the version from now to try and find a solution for that..oh dear dell what a kerfuffle over a simple piece of software,,,,Huh?

    It seems the programme structure of the files in this new version is somewhat different to that i had installed before. Fortunately for me at the very beginning befor the 1st uninstall I backed up the delldock program files and prog data folder which i can now compare to this new install.

    It seems that the Default.lang.xml file was missing from the ENG folder C:\ProgramData\Dell\DellDock\ once i copied this file from my original backup the dell dock now runs. As to why this doesn't install correctly i don't know. I think that is something that both dell and stardock should look at ASAP.

    And now upon trying to alter the settings (bearing in mind the dock was running) i get this error and we are back to square one. Seems another missing file, the BaseSettings.xml as well as the uninstaller.xml. Oddly these files are only missing from the ENG folder they are present in all the other language folders. Upon copying my backed up settings file from my older version install the dock now runs and settings are accessible. Though whether this will have an effect being from an older version I'm not sure but now that I know that works it's worth trying to copy a file from one of the other LANG folders to see if alternative settings are  accessible. This works but changes to the other language as soon as anything is altered.

    The missing files also exist outside the ENG folder in the parent directory and copying those 3 into the ENG folder seems to be a successful solution for now.


    So to summarise if you get the errors on this topic you might to try the following if a simple uninstall/restart/reinstall doesn't work.

    1.Uninstall corrupt version and restart

    2.install 3rd july version

    3 install 14th july version.

    4 install latest (faulty) version from

    5.replace the 3 missing xml files in the ENG folder from the parent directory  as indicated above.

    I just wish dell knew this as opposed to telling me to reformat my system and return it to factory settings. After all that's what good tech support is all about.

  • I have a studio xps 1640 64-bit just for one week when the dell dock crashed after windows updates. I spend hours with the dell hotline to bug fix with no succes. That's a shame. Lucky me I found lucids recommendation to download the "3rd July 2008 STARDOCK_DELL-DOCK-APPLICATI_A03_R186613.exe". version. Folks, it works perfectly after this. Lucid, you're a good man - (woman). Tks. Thomas

  • Thank you for your comments I'm just glad that someone found some use and help from the above info. The newest version does have some slight increase in functionality though i can't remember exactly what that is now. The only good thing about all this hassle is that i now use both rocket dock and the free version of object dock in addition to the dell dock,

    Thus you can spread items and favourites/links between the differnt docks to help you organise. Although these other apps haven't got grouping you can with additional software create stacks which work in a similar way and tag this to the dock.

    Comparing these 3 docks I really can't help but feel that they have really disabled the functionality of dell dock on purpose. The most obvious thing being that when the dock is hidden it is so slow to respond and pop up when you move the mouse pointer near it. Though it may only be a small fraction of a second you notice the difference when using the other docks which respond instantly.

    Also the sizing isn't correct either. What I mean is if you make the dell dock a certain length it fits everything as a horizontal bar on the top or bottom but when at the side positioned vertically it goes into scroll mode. now this is normal if you have too many icons to fit but it is set too short so when it should fit without having to scroll it doesn't just to fit say 1 more icon on each end, which it could do without scrolling. There is also no option to change the size of icons or ability to make them popup or grow in a slightly more "enthusiastic" way than they do at present.  i also note than when it is hidden there is always a little edge showing, this makes it useless if you wanted to put it at the right side of the screen because whenever you want to say for example scroll down say on a webpage  and try to put the pointer on the scroll bar the dock pops out hindering scrolling, this is most annoying.

    Well enough for now..

    Zip it!

  • Doesn't work for XP - Vista only. Boo Hoo. Obviously Dell don't care as their response has been comedic and foolish. If they  had actually written the applet I would have dumped them immediately.

  • Unfortunately it doesn't really work for vista either, it seems the latest version i tried is corrupted and needs an update to fix it. If you haven't already read the whole of this topic you'll see the procedure that had to be gone through to enable it to work. As to whether anyone from dell actually pays any attention to remedy these kind of issues i do not know.

    Though i am of the opinion that mostly it is the customer that will discover certain issues 1st and things are not tested properly.  This even goes as far as BIOS which does not work with hardware, and I'm not talking of older systems. There are issues with the latest studio 17 laptop range such that the only way to resolve it is to put the bios back to a much earlier version so that certain hardware works. As far as I'm aware an update for that issue is still forthcoming though in reality a coder could fix it in under a day though it has been months.

    Regards to the dock and xp, maybe try rocket dock or object dock instead. And if you need to group application shortcuts or links google to find out about creating stacks that you can attach to the dock.

  • I have uninstalled DD and won't be pursuing it. Thanks for the reply and suggestions.