Inspiron N5110 proper Alps Touchpad driver - Linux Forum - Software & Operating Systems - Dell Community

Inspiron N5110 proper Alps Touchpad driver

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

Inspiron N5110 proper Alps Touchpad driver

This question has suggested answer(s)

I've got an Inspiron N5110 with Alps Touchpad. I've installed the driver found here in downloads, but it works pretty awful. It is actually a Dell Touchpad driver, which I think is a universal driver for touchpads on such laptops, but I don't think it's the Alps Touchpad native driver. I've tried to find out the Device and Vendor of the device to find the proper driver myself, but to no avail. Did anyone else try to install another driver then that on the Thanks in advance.

P.S. Also would be good to know if there is also a Linux driver for this touchpad: it works fine on Ubuntu 11.04, but I can't even disable it since there is no native driver. Thanks! 

All Replies

    This is the ALP Touchpad Driver , the driver is from Alps although its branded as Dell.

    The software would adds certain additional features so that you can make the best use of your Touchpad, and since you haven't stated what the issue is there is very little i can help you out with.

    If you are not comfortable with the movement of the mouse , you can always uninstall the Alps Software and let Windows install its native drivers.

    And you would also get any updates ALPS releases for the touchpad via windows update.

    If you let windows install its native drivers certain functionality will not work.

    If you want a driver for Linux, try the Linux Forum .

    Forum Member Since 2010

  • I just installed this driver in Ubuntu Oneiric Ocelot on my N5110 (Q15R)

    and it successfully addresses a known issue with older Alps drivers misrecognising the Trackpad as a PS2 mouse, detailed here...

    Thanks to all the launchpad contributors for catching this one, and testing it to death before I bought my Q15R

  • The driver listed by cefnhoile seems to be working for me.  e6510 with Ubuntu 11.10.  When I first got it going, the sytem stopped resonding to mouse clicks.  I fixed with these commands:

    sudo modprobe -r psmouse

    sudo modprobe psmouse

  • i installed this package before, but it didn't helped me. ill try it again, and try the commands vab3 gave.

    and i have a question, can you now enable and disable by clicking Fn+F3?\



    i intalled this driver again, and it didn't help. my touch pad is still recognized as "PS/2 Generic Mouse".

    Any more suggestions?

  • Fn+F3 on my keyboard brings up battery/power information.   I did notice a few posts about using the synaptics drivers in place of the alps drivers, but I'm not sure how to make that work:

  • finally, i got "AlpsPS/2 ALPS GlidePoint" in "xinput list" and at settings i have touchpad tab :)

    i did this:

    "If you want to enable your Dell Inspiron 15R Touchpad , download that alps-dkms package and install it in /usr/src , from terminal navigate to /usr/src/psmouse-alps-0.10/src and than gedit alps.c , in alps.c scroll down and copy the /* Dell Vostro 1400 */ line completely , in that line you will have to replace first 3 matchings that is , replace 0x73 , 0x02 , 0x50 with 0x73 , 0x03 , 0x50 , save the file and return to the terminal , in terminal type "dkms add -m psmouse -v alps-0.10 " after this type "dkms build -m psmouse -v alps-0.10" after build is complete install it "dkms install -m psmouse -v alps-0.10" , after it installs it successfully , type " rmmod psmouse && modprobe psmouse " , it will reload your psmouse module, after this type "xinput --list" to see whether it loaded successfully or not, if it shows Alps/PS2 Alps GlidePoint in the xinput , than congrats. And i bet it will show as i got it working by this! If you need complete patched module , you can ask me :)"


    now when touchpad is recognized as GlidePoint, synaptiks says it support only one finger. and my touchpad is dualpoint and supports 3.

    how can i fix this?


    changed it to DualPoint and i can see it like that at "xinput list", but still "synaptiks" lets me use only one finger.

    maybe it does not depend on the model (not talking about hardware, im saying somewhere linux recognize one finger).


  • I bought a Dell N5110 15R in December 2011, and I'm using Ubuntu Oneiric.  None of the touchpad drivers I've tried, including the one at, have worked.  I've read other posts where people with the N5110 said that the above driver worked for them.  I assume that there are different versions of the N5110, and that the later version I have has a slightly different touchpad.

    Using the tool at, I get an E7 report saying "73 03 50".  I tried modifying the driver to add that E7 number, but it didn't work.  I was able to get the driver to recognise the touchpad as a touchpad, but I was unable to disable tapping, enable scrolling, etc.

    I have a been a proud and outspoken Dell user for over ten years, but I am extremely disappointed that they seem to be abandoning Linux users by using hardware for which there are no open source drivers available.

  • i am at the same situation. it seems that there is some file that tells the settings and apps as "synaptiks" that we have a touchpad that supports only 1 finger, so they don't allow 2 finger scrolling. about the disable, i also have no idea.

    dell, can you get an alps supporter to answer our questions?

  • Same issue here, cannot make two-finger scrolling and muti-touch function work, however, at least, I can disable the touchpad, method below,

    run "xinput list" , find " PS/2 Generic Mouse id=14", remember that id,

    run "xinput list-props 14 (the id listed)", see Device Enabled (126): 1? Remember the number,

    run "xinput set-prop 14 126 0", the touchpad is disabled, isn't it? You can add this line to .profile or other similar file to disable the touchpad at boot.

    Hope DELL will put some work on Linux support!

  • BTW, I'm using Archlinux on Dell N5110 15R.

  • I could disable the touchpad (there are several ways), but I actually want to use it.  The problem is that I need to disable tap to click, especially since even light brushes of the touchpad cause clicks all over the place.  Also, if possible, I'd like to enable scrolling.  I really wish ALPS and/or Dell would address this.  I've heard different versions of who's withholding the information needed to create open source drivers for this device, not sure who to believe...

  • Ubuntu 12.04, in the mouse system settings, now shows both my Alps touchpad and my mouse.  Gives me a little more leeway to use the touchpad-indicator software to disable the touchpad while mouse is intact.  I still have problems with the touchpad being too sensitive to my palm and moving the mouse pointer around.  I haven't tried the updated driver.  

    I did notice this article about a new dell latptop with ubuntu pre-installed.  Maybe a better driver will come out of it:

  • i want keypad and touchpad driver for dell inspiron plz help me guys to download this driver................

  • Hi shree1993,

    Below link would help you with the configuration of touch pad drivers:

    Try installing the driver from the below link:

    Let me know if this helped.

    Thanks & Regards
    Rajesh R
    To know  more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US ; UK; India. For Dell support videos click Here.
    If a post answers your question, please click "

  • This is a Linux forum.