Fixing the lid-switch problem (blank screen)

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

Fixing the lid-switch problem (blank screen)

  • Hello all,

    I've recently gotten a Dell D610 from work. When closing the lid, and opening again the screen remained blank.

    After some digging, I came up with this script which restores the LCD when you open the lid.

    It requires the ACPI VIDEO module loaded.

    Create the file /etc/acpi/lidswitch.sh, with content:

    #!/bin/sh
    # /etc/acpi/lidswitch.sh
    # Re-activates the screen when the lid is opened again

    LID_STATE="/proc/acpi/button/lid/LID/state"
    LCD_STATE="/proc/acpi/video/VID/LCD/state"

    grep -q open $LID_STATE

    if [ $? -eq 0 ]; then
    echo 0x80000001 > $LCD_STATE
    fi
    [/code]

    Put this in /etc/acpi/events/lidswitch:
    # /etc/acpi/events/lidswitch
    # This is called when the lid is closed or opened and calls
    # /etc/acpi/lidswitch.sh for further processing.

    event=button[ /]lid
    action=/etc/acpi/lidswitch.sh


    This effectively makes my LCD come back to life.

    Jan
  • Hi. You answered a question off here http://askubuntu.com/questions/248967/laptop-screen-stays-blank-after-lid-is-reopened with this answer. I'm having the same problem and would like to try this solution, but I don't understand where I'm even suppose to start with this solution. Could you walk me through it with steps? Thank you.