Linux on Inspiron 1100 - Linux Forum - Software & Operating Systems - Dell Community

Linux on Inspiron 1100

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

Linux on Inspiron 1100

  • Are there any experiences running Linux on Inspiron 1100?
  • Mandrake 9.1 installed very easily and almost everything is working - sound, display, built in ethernet, mouse (built in and external USB).

    Things not working - winmodem and power management.

    For PCMCIA to work I had to manually install the pcmcia_cs rpm from the disk and change the /etc/sysconfig/pcmcia, the only line that needed changing was PCIC= to PCIC=yenta_socket

    I love the Inspiron 1100.

  • Sounds good. Thanks.
    More experience reports are welcome.
  • I haven't used LInux yet, but after hearing that mandrake works well I think i'll try. Any advice as to what linux software to use, and any suggestions on other posible distributions?
  • tarapoa,

    Well, I just got a Dell Inspiron 1100 (Pentium 4, 2GHz) and I got RedHat 7.3 to install !

    This was VERY unexpected since all emails I've found about installing RedHat on this laptop point to version 9. I selected SVGA as video type and for the monitor I selected Dell's flat screen 1024 x 764.

    This got Linux to install right away, including GNOME! The only thing is that linux does not use the entire available screen space. I think this is ralated to not having the latest video driver for the INTEL video chip. I also need to tweak with the system to get the sound and NIC to work.

    The thing is that I did try to install RedHat 9, but the installation ALWAYS got stuck while probing the components of the laptop even though I did use the keywords "mem=256M noprobe".

    So my approach was to try to install a previous version of RedHat (in this case 7.3) to then upgrade the system. So far my attempts to upgrade to RedHat 9 keeps failing. So I will try to resolve all the issues under 7.3 and if that works then I see no point in trying to upgrade the system.

    I hope this helps you somehow.

    Good luck!


    - Guillermo.

  • Dear Dell-Linux community,

    I wanted to correct and update my previous email about installing RedHat 9 (clean installation no patches applied at all) on my Dell's Inspiron 1100 (256 MB of RAM, 30 Gig Hard Drive).

    The laptop I have came with Windows XP Home edition. Since this OS come with limited networking capabilities (i.e. it cannot network with PCs running Windows 2000 Pro) I decided to get rid of it and install Windows 2000 Pro instead.

    For some reason the laptop came configured with the first 5 sectors (approx. 39 Mb of hard drive space) unsued while the rest of the hardrive was in NTFS format. In any case, I went to the BIOS by pressing the F2 key during the bootup process and set it so the system will start accessing the CD ROM first. I entered the Windows 2000 Pro CD ROM, saved the changes in the BIOS, exited and started the installation for Windows 2000 Pro.

    During the installation process I erased the "C" partition, recreated it to my needs (in this case to 18 Gigabytes), leaving the original first 39 Mb untouched (I will use that space later for the installation of RedHat 9). Then I proceeded to format the new "C" partition and selected the NTFS format. After that Windows 2000 Pro was installed as expected. (NOTE: To get Windows 2000 Pro to work on the Inspiron 1100 you have to make sure you download all the necessary drivers from the DELL website BEFORE HAND. If you can have them on a CD-ROM the better).

    Once Windows 2000 Pro was successfully installed and the Dell's drivers were installed I proceeded to install RedHat 9.

    I used Druid to set the partitions for the RedHat installation. I selected the first "unused" 39Mb to install the "/boot" partition (ext3 format), the rest of the unused hard drive space (the one right after the "C" partition) was divided in 2 sections: The first part was to install the "/" partition (ext3 format), and at the end of the space I selected about 500 Mb of space for a swap file (swap format).

    I selected to install everything and when I was asked to select either LILO or GRUB. I opeted for LILO and got it set in the mbr master boot record. And then I proceeded with the installation.

    RedHat 9 installed without a problem! The problems I had initially reported in this forum were due to errors on the installation CDs I created from the original ISO files. I discovered the CDs were not good because now RedHat 9 allows to scan the media PRIOR to the installation process! A nice detail from RedHat if you ask me.

    The installation worked flawlessly. The system recognized a USB Logiteck Trackball Mouse I had plugged in during the isntallation and RedHat used it without a problem along with the laptop built-in touchpad!

    One note of caution, for some reason RedHat recognized the USB mouse as a GENERIC parallel 2-button mouse. When I changed it to Logitech's USB the mouse stopped working. Changing it back to GENERIC parallel 2-button mouse got it working again. So far RedHat 9 is working with it with no problems so I won't fight it.

    RedHat 9 does not support the built-in NIC card. I got it to work by compiling the source code (do a GOOGLE search for the file bcm4400-1.0.2.tar.gz, a website that points to this file is at ). (IMPORTANT NOTE: In order to compile this file make sure you have installed the development kernel utilities).

    Open a terminal, go to the directory where you saved the above file and uncompress it by typing:

    tar xzvf bcm4400-1.0.2.tar.gz

    Now go to the newly made src directory and compile the driver by typing:


    For some reason in my case I got lots of warning messages during the compilation process. Don't mind them.

    At this point you should have a file called bcm4400.o (there are other ".o" files, don't mind them either).

    Now to install the NIC module type:

    insmod bcm4400.o

    To make sure the module is loaded type:


    This should show bcm4400 at the top of the list. If you are not in a GUI environemnt (e.g. GNOME, KDE) then go to it typing:


    Open a terminal and type:

    Now do "service network restart" and reboot the system. When RedHat boots up it will recognize and load up the NIC module and it will ask the settings for it. I selected the DHPC configuration, selected the "OK" button and the NIC is now set to be used every time you run RedHat 9!

    A strong word of caution: It appears that if you update the kernel the NIC will stop working and you will need to follow the above installation steps again to get it to work.

    With the above process I have a fully working dual-booting system having RedHat and Windows 2000 Pro fully working on my Dell Inspiron 1100 laptop.

    I hope this post helps others setting up RedHat 9 on this great laptop.



    Dr. Guillermo Morales.
  • There's a great article on-line with a pretty well written step-by-step guide on installing various flavors of linux on the Inspiron 1100.
  • I'm running an Inspiron 5100 (basically, the same computer) on Mandrake 9.2 with very few issues.  Everything works except the WinModem, (although a driver is available online) and suspend (crashes system if ACPI is on).  PCMCIA, ACPI, Firewire, etc were all configured out-of-the-box.  I have a short webpage about my experiences if you're curious:

    Hope this helps...

  • hi all,

    i've just purchased the inspiron 1100 from dell uk and hopefully it should get here next week. i can't wait! i'm going to erase everything and start again installing both windows xp pro and red hat 9.0. hopefully it wouldn't be much of a trouble. the idea is to network the laptop to my home pc which is also using xp pro & red hat 9.0. by the way, does red hat 9.0 (or indeed other linux distros) support wireless networking? if it's too much i'll just need standard wired network, not an issue. 

    help appreciated. it's been very interesting read on you guys' experiences.


  • afaik the first 39m is the dell diagnostic utilities.
  • Hi...
    I have been trying to install linux on my dell inspiron 1100...
    tried 7.3 but it did not recognize the intel 845 display card..

    now with redhat 9, it recognises the card but says unknown monitor....
    the install is complete and it shows me both the text as well as graphics mode as a tiny 7" window....

    any clues how i can fix it?

    I have tried changing the monitor type to dell laptop display panel and the generic laptop panel ... 1024X but its the same
    even selecting a 14" svga shows the same thing...

  • Check out: