Dell XPS L702X Restore To Factory Settings After Repartition

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

Dell XPS L702X Restore To Factory Settings After Repartition

This question is answered

Hi Guys

 

First off, I'll start by admitting that I'm an idiot.

 

I got my awesome XPS L702X yesterday.  I played around in Windows (Windows 7 Professional) for a bit, and then I set off to install Ubuntu, which I need for work.  I didn't want to settle for the default partition settings, since I want only 70GB for Ubuntu.  I got the format tool the wrong way around and I ended up formatting my Windows drive (I said I'm an idiot).  The 70 GB partitition is now my primary partition, and there's an NTFS partition of about 8 GB - I assume that is for recovery.

The first thing I tried was to start the machine up as is; it prompted me to restore Windows.  I tried to use the Dell Factory Image Recovery and Datasafe option to restore to factory settings.  It shows my Windows drive as 'Unknown' (instead of a drive letter), and although I can see the factory image, I get an error (with only a long number) when I try to use it.

 

I then tried to reinstall Windows on the 500 GB of free space on my drive, hoping that I could restore from that.  After installing Windows again, I now seem to have Windows showing up twice in my boot options.  One of them doesn't work, and the other is an absolute blank install; no drivers, Dell software, zilch.

 

I'd really like to get my Windows installation back to the factory settings - I loved it as I got it.

 

Any advice will be much appreciated.  Thanks a lot guys.

All Replies
  • Since you have changed the boot sector on the hard drive (by what you did) the Dell recovery partition can no longer be used.  You will have to a manual install using discs.  You will need the Dell Windows 7 disc and a Dell drivers and utilities disc or download the needed drivers from the Dell downloads.

    Although you needed Linux for your work, you should have given it a couple of days to make sure the hardware is all working properly and that you want to keep it and not send it back. 

    If you are in the US, you can request a set of discs from Dell   HERE  

    The drivers can be downloaded from www.support.dell.com   use your service tag number to access the downloads.

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • Thank you for your response Fireberd.  

    I was really hoping that I'd be able to recover.  The fact that the recovery partition itself seems to be intact (since the original Windows installation still show up in the boot menu) led me to believe that I could still recover from it.  My conclusion was that I'd be able to restore if I could somehow get my failed Ubuntu partition  formatted as NTFS again, and marked as the primary partition.  As they say, hindsight is 20/20 vision.

    I think that I'll hold out for one or two extra answers.  I have the OS and the utility disks, but I want to use them as a last resort.  I don't want to lose the Dell Datasafe feature and other pre-installed goodies forever (I might be mistaken, but to my knowledge, I cannot reinstall that from the disks).

  • Bump...

  • If you do a search on this forum you will find out that the answer I gave you is correct.  

    I'm not a big fan of the datasafe anyway.  It has been known to cause some problems.  And, if you backup and data to a "datasafe" partition on the hard drive it's not really "safe".  If the hard drive were to fail what you have backed up is gone.  Only backup data to a separate storage device.

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • Hi fireberd

    I acted on my hunch that I'd be able to recover using the intact recovery partition - and I'm pleased to report that I've succeeded.

    If anyone else experiences the same issue in future, here's how I fixed it;

    1.)  I booted using a live Ubuntu CD and I used  GParted to delete my ext3 Ubuntu partition.  This left me with the Dell recovery partition and the boot partition; the rest of my drive was unused.

    2.)  I used GParted to create a new, primary NTFS partition from the unused space.  This left my drive in the state that it was in when I got it (apart from the fact that the boot partition now contained two references to Windows 7 and the NTFS partition was empty).

    3.)  I restarted and booted into the original Windows installation.  Windows failed to start and tried to repair itself; this failed.  I then used Dell Datasafe to restore to factory settings.  This succeeded, but it repaired the second Windows installation; i.e. the one that I tried to use to repair the broken installation earlier.  This meant that the advanced boot options on the working Windows installation did not include Dell datasafe.

    4.)  I logged into the repaired Windows installation and I used the boot tab on msconfig the set original Windows installation as the default (the sequence of operating systems shown in msconfig should correspond to the sequence that you see when booting your machine).

    5.)  I restarted again, and tried to boot into the original Windows installation, which again failed to start and failed to repair itself.  Again, I ran Dell Datasafe to recover to factory settings.  This time it picked up the correct Windows installation to (it seems to pick up the default from msconfig) and it repaired it.

    6.)  Finally, I logged into the original (fixed) Windows installation, ran through the initial setup prompts and used msconfig to delete the second Windows installation.  

    The machine now seems to be in the exact state that it was in when I got it.  Of course, there might be a file or two from the other Windows installation floating around somewhere, but I think that that is negligible.

    I understand your concerns with Dell Datasafe; with everything on one drive, your data is not as safe as it could be, and it's always a good idea to keep backups on a separate storage device.  To me, it's more of a mental thing - I bought a new machine, and I wanted it to be as new.  I could reinstall from scratch, but I didn't want to lose my pre-install Dell software and the stuff that I paid for.  Also, I would've had to go through a lot of driver installations if I installed from scratch, and you never know whether you've missed something.  

    Now I'm off to install Ubuntu again.  This time round, I've decided to boot from the live CD and use GParted to create my Ubuntu partition manually, prior to the installation.  That way, I'll have a partition to point the Ubuntu installer to, rather than having the installer create a partition.  I suspect that Windows will fail on startup after I've resized the partition, but it should be able to recover from that by itself.

    My advice to anyone who installs Ubuntu on a new machine with pre-installed software, particularly if you have things like Dell Datasafe, recovery partitions, etc. is to be very careful (even more so if you have no recovery media); make sure that you know exactly what you are doing, and just to be safe, boot from the live Ubuntu disk and create an ext3 partition beforehand.  

    Fingers crossed that the new Ubuntu install will be without incident...

    P.S.  Disclaimer:  To anyone who uses my advice and attempts the steps listed above; this worked for me, but I accept no responsibility if it doesn't work for you.  However, if it works for you or if you'd like to add something, please feel free to post back to this thread.

    Update:  I've installed successfully Ubuntu.  Instead of using GParted from the live Ubuntu disk, I used Windows' Disk Management to reduce the size of my Windows partition.  Upon installing Ubuntu, I selected the "Install Ubuntu alongside Windows 7" option and the installer automatically picked up and used the unpartitioned space.