Any way to fix the "DellUtility" and/or "RECOVERY" partitions? - Microsoft OS Forum - Software & Operating Systems - Dell Community

Any way to fix the "DellUtility" and/or "RECOVERY" partitions?

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

Any way to fix the "DellUtility" and/or "RECOVERY" partitions?

This question has been answered by Tom Green

Through some chain of events that apparently involved installing Ubuntu onto a USB flash drive, the "DellUtility" and "RECOVERY" partitions on my hard drive somehow got messed up ... Both partitions still exist and are their original sizes (41 MB and 12 GB, respectively), but neither one seems to be bootable any more, and the "DellUtility" partition somehow "lost" all of its original files ... (However, the "RECOVERY" partition still seems to have all of its original files) ... This is on a Dell Studio XPS 8100 system (now discontinued) running Windows 7 Ultimate Edition, with two 1-TB hard drives configured as a single 2-TB RAID 0 array ...

I don't think this is a "critical" problem, because I seem to be able to perform the functions of both partitions using: (a) the Dell "Drivers and Utilities" disc supplied with my system; and (b) the two "System Recovery" DVD's that I created -- from the "RECOVERY" partition, I guess -- when I first set up the system ... But I'd kinda like to have the "original hard drive(s)" with the "original functionality", if possible ...

Is there any way to somehow "re-populate" the "DellUtility" partition -- either from the supplied Dell "Drivers and Utilities" disc, or from some other source -- and make it bootable, as it was originally?  Separately, is there any way to make the "RECOVERY" partition bootable, as it was originally?  (I also seem to have its files somewhere on the two "System Recovery" DVD's, if needed) ...

It would be perfectly OK if the "OS" partition were to get erased and/or (re-)formatted in the process, since I just (re-)formatted it yesterday and performed a Factory Restore/Recovery onto it ... I can always do that again, if necessary, because I haven't started "using" that partition yet ...

Any ideas, suggestions, or advice?




Verified Answer
  • Hello Kevin

    Sorry to hear this.

    The only thing I can think of is a complete start over. I'm sure you have everything you need to do so.

    If you do have to start over, get the DellUtility installed and working first. Sounds like you did get the

    Recovery working, may I ask what command you used to get it going? Another though, you might

    want to install that DellUtility on a flash drive and not install to the array. You might do a search and see

    if posible to have it on just one of the drives apart from the array that might help also. I think I read some

    where that the Boot can be setup like that also.

    I feel like you have learned enough that you can get it going again. Keep me posted.


All Replies
  • See THIS recent forum thread (obviously you didn't look over the forum before you posted as this is on the next page of posts).   If that doesn't work you will probably have to get the backup discs from Dell and do a manual install.  If you are in the US you can request a set of discs  HERE  there is a minimal charge.

    I am not a Dell Employee

    Dell forum member since 2002

    Inspiron 15 - 5577 Laptop

    Home Built Desktop PC with ASUS Z170, i7 6700K CPU,  Windows 10 64 bit Pro. SSD drive.  Studio One 3 Recordng Studio Software.

    Dell SE2717HR 27" Monitor


    Member of Nashville based R.O.P.E.

  • Uh, thanks there, fireberd ... I can assure you that I Google'd this issue extensively before posting here, so if I didn't find the solution to this particular issue in the Dell forums, it wasn't for lack of trying, anyway ... I'll check it out and let you know how it goes ...


  • I happened to have seen that thread just before I saw and answered your post.

    I am not a Dell Employee

    Dell forum member since 2002

    Inspiron 15 - 5577 Laptop

    Home Built Desktop PC with ASUS Z170, i7 6700K CPU,  Windows 10 64 bit Pro. SSD drive.  Studio One 3 Recordng Studio Software.

    Dell SE2717HR 27" Monitor


    Member of Nashville based R.O.P.E.

  • Hello Kevin

    Glad you got your system up and running. Good Job!

    I don't understand what you mean about boot recovery, your other post said the F8 was working and you could get to advance repair system.

    When you ran the setautofailover command it makes the partition hidden but if when using the F8 you have at the top Repair Your Computer,

    then it is working. usually when in disk management you left click on that partition it will have option, If only option is help, then the partition

    ID is set to 0x27. but if the options allow you can give it a drive letter then you can see it again.

    The DellUtility is a DOS partiton at front of drive that you boot by selecting it from boot menu when you wish to run diagnostics on computer,

    it is also hidden with ID as 0xDE and not active except when selected as above. If it needs repaired you will need to change its type and make

    active them system it with DOS then copy your Diag CD files to it then change every thing back the way they were.

    Hope this helps.


  • Hey Tom,

    Well, "Good Job" thanks to YOU!  BTW, I read your recent post on where to get the "setautofailover.cmd", which would've been really useful to me, except that I needed it the night before in order to follow your instructions ASAP on my original critical problem, which is now fixed ... As it happens, after some Googling, I ended up getting it from the same page and in the same manner (copy-n-paste) as you later described ...

    As for what's happening NOW, the F8 key on system boot does indeed bring up the "Advanced Boot Options" menu, with "Repair Your Computer" as the first option, but when I select it, the system simply boots to Windows anyway ... And I guess that's because the "RECOVERY" partition is no longer bootable, although the files seem to be there ... (Of course, the "DellUtility" partition is no longer bootable AND is now empty, having "lost" all of its files) ...

    I'm currently trying to locate a (working) version of "PTEdit32.exe" OR "ptedit.exe" -- neither version from seemed to be compatible with my system -- so that I can follow your instructions in both your recent post and your post above ...

    Thanks again, Tom ... You've been really helpful here!



  • Kevin

    I had a recovery problem like your talking about once. Can't seem to remember what I did to fix it.

    I think somewhere in the recovery it made an extra directory called recovery and in that directory

    it had a directory with a (GUID) number. Best I can remember, I deleted that and it went to the correct

    recovery rather than a second recovery. Of course I knew I could rebuild the boot and the setautofailover

    if had to do so. Check inside d:\boot for a directory called recovery if there, delete it.

    About PTEdit32.exe is a 32 bit program for windows and ptedit.exe is a DOS only program.

    Some computers need  pqvxd.vxd to run PTEdit32.exe

    About the DellUtility partition, after you use ptedit32 and change the DE to 06 and change the 80

    to that partition, note only one 80 on disk as this marks active partition so you need to set 00 where

    the 80 is at then 00 to 80 on first partition. then you will need some way to boot into DOS that will

    allow you to system that partition. Dell uses DRMK 8.0 but any DOS will work . Be very carefull here

    as when you system that partition it will write track 0 with DOS MBR and I'm not sure what might happen

    to your RAID array, but should work. You will need the DellUtility CD files to copy into it then change

    the 06 back to DE and move the 80 back.

    Good luck


  • Hey Tom,

    Well, it turns out that the files I had fetched from -- most notably, "PTEDIT32.exe" and ""PQVXD.vxd" (after extraction) -- actually DID allow me to use PTedit32 (the 1999 version), once I tried running it in Windows Compatibility Mode (for XP SP2) ... So now I'm looking at a partition table for "Drive 1 (1907726 MB)", which appears to be the 2-TB RAID 0 array, as follows:

    1.  Type=0xDE  Boot=0x00  (no "Boot Record"?)  Partition Info: 39 MB

    2.  Type=0x07  Boot=0x80  (has "Boot Record")  Partition Info: Installable File System (NTFS, HPFS), Bootable, 11142 MB

    3.  Type=0x07  Boot=0x00  (has "Boot Record")  Partition Info: Installable File System (NTFS, HPFS), 1896551 MB

    4.  (none)

    Obviously, #3 is the "OS" partition, and #1 and #2 are (supposed to be) the "DellUtility" and "RECOVERY" partitions, respectively ...

    I'm still chewing on your last several posts here ... Thanks again ...


  • That looks about right, I would turn off the old array before doing diskpart as not to get the wrong drives plus

    your H drive and change size to match size your post    39           11142       and rest for   OS.

    You are using new drives for new array?   They should be the only ones on when you use diskpart.

    I'm under a tornado watch here and might not be able to get back to you later. Good luck!


  • Hello Kevin

    Some remarks in last post, a bit confused with watching the weather and two post with much same problem.

    The other poster installed the new drives and doing the disjpart setup on Raid 0 Array,

    Sorry about that. Let me know how it turned out.


  • Thanks for the clarification there, Tom, and I'm glad to hear that you weathered the tornado watch OK ...

    Well, I was right in the middle of a (longer) post when the power blipped and I lost it all ... Anyway, I don't see an extra "recovery" directory like you were talking about ... I generated a listing from Ubuntu (Linux) of the "RECOVERY" partition files, in reverse order of creation/modification, omitting directories and omitting any files dated before I ordered the system ... Does anything look amiss here?  (Those are byte counts, BTW) ...

    2010-07-19: Ordered the system from Dell

    2011-03-18: Powered it up for the very first time (don't ask)

         32768 2011-04-10 21:17 ./Boot/BCD
         29696 2011-04-10 21:17 ./Boot/BCD.LOG
           345 2011-04-10 21:17 ./Master.log
         20480 2011-04-09 00:28 ./System Volume Information/tracking.log
             0 2011-04-08 23:55 ./DRECOVERY
            11 2011-04-08 23:55 ./AUTORUN.INF
           512 2011-04-08 23:35 ./Boot/OS.DAT
            22 2011-03-18 22:53 ./preload/CD1
            28 2011-03-18 22:38 ./preload/AskCD1
            22 2011-03-18 22:38 ./preload/CD0
         21504 2011-03-18 22:38 ./Recovery/WindowsRE/BCD.LOG
             0 2011-03-18 22:38 ./Recovery/WindowsRE/BCD.LOG1
             0 2011-03-18 22:38 ./Recovery/WindowsRE/BCD.LOG2
    2281599956 2011-03-18 22:33 ./dell/IMAGE/FACTORY2.WIM
    2281599956 2011-03-18 22:33 ./preload/BASE2.WIM
    4077813165 2011-03-18 22:32 ./dell/IMAGE/FACTORY.WIM
    4077813165 2011-03-18 22:32 ./preload/BASE.WIM
            58 2011-03-18 22:03 ./preload/BASE.DAT
          1398 2011-03-18 22:03 ./preload/CSP.DAT
            54 2011-03-18 22:03 ./preload/DESC.TXT
      25590896 2011-03-18 22:03 ./preload/ALL.CRC
           192 2010-07-20 23:49 ./ResSys.ini
             0 2010-07-20 22:41 ./Boot/BCD.LOG1
             0 2010-07-20 22:41 ./Boot/BCD.LOG2
         65536 2010-07-20 22:41 ./Boot/BOOTSTAT.DAT
          1073 2010-07-20 20:31 ./Recovery/system32/Recovery/ReAgent.xml
     186153782 2010-07-20 20:13 ./Recovery/WindowsRE/winre.wim
       3170304 2010-07-20 20:13 ./Boot/BOOT.SDI
           409 2010-07-20 20:13 ./ST_InstallBackup.ini

    As for the "DellUtility" partition, I didn't quite get what you meant by "system the partition"?  Thanks again, Tom ... Meanwhile, I think I'll have a look at those "log" files on the "RECOVERY" partitiion ...


  • BTW, I'm holding off on setting up my Windows system ("OS" partition) again, following the last Factory Restore, until I see the outcome of this thread -- whether I can or can't make my "DellUtility" and "RECOVERY" partitions functional again ... I don't wanna lose any (more) work on setting up Windows if there's any chance that the "OS" partition might get blown away (again) while trying to "restore" the other two ...  Wink



  • Kevin

    The     /Recovery/system32/Recovery/ReAgent.xml    is probably what we are looking for.

    Can you change the name of the systen32 folder?  Then I see your Recovery is setup

    loading winre as an image. You might need to add  /wim to the setautofailover.cmd.


    As to the DellUtility, it need to be system if it doesn't have any files. In DOS when you system a disk

    you make it bootable and it puts two hidden system files  and When you boot into dos

    with the drive type set to 0x06 you will be able to see that drive but not the NTFS drives


  • OK, I still don't know how to "system a disk/partition" ... I changed the "DellUtility" partition type from 0xDE to 0x06, and I moved the 0x80 flag from "RECOVERY" to "DellUtility" ... Then I booted into DOS -- the Norton Bootable  Recovery Tool (NBRT) CD version, because that's the only way I know of to get a DOS command prompt *AND* see all the partitions with their drive letters -- but then what do I do to "system" the "DellUtility" partition, make it bootable, and get those system files on there?

    At this point, I'm no longer able to boot to the "OS" partition -- instead of just cycling through the BIOS as before, I now get the message "This is not a bootable disk" ... So I went back and did "BCDBOOT" and ""setautofailover" again, but that didn't help ... Do I need to undo the "DellUtility" partition changes before I can boot to Windows again?

    At this point, I've been back and forth with changes so many times that I don't know what's what ... And I guess part of the problem is that I'm trying to follow instructions, and to "repeat what worked before", without really understanding what I'm doing ... I wouldn't blame you a'tall for getting frustrated here!

    BTW, this time I can mount (in Ubuntu) and examine (in Ubuntu and DOS) the "OS" partition, so I know it's not totally hosed like last time ... I just can't boot to it, that''s all ...




  • OK, I was able to run "PTedit32" from (NBRT) DOS, so I reversed the changes to the "DellUtility" partition, and now I am indeed able to boot Windows again ... But now I'm just back to where I started?  Tongue Tied   (In this thread, anyway) ...




  • Hello Kevin

    The 80 flag tells computer which partition to boot from. Your correct in the fact that the

    first partition doesn't have a system and can not boot. I use MS-DOS 6.22 to boot

    computer and the command from DOS prompt is:                   sys x:

    x: being the drive letter of the DellUtility. If you need to get back to your windows, change the 80

    flag back to where it was but leave the 06 until finished. Then your windows will boot and you can

    look on the net  for           DOS flash drive bootable    it will help you to get a flash drive working for

    this project.