What is NTLDR missing and how can i fix it - Microsoft OS Forum - Software & Operating Systems - Dell Community

What is NTLDR missing and how can i fix it

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

What is NTLDR missing and how can i fix it

This question is not answered


Hello Again

I think I was happy before I should, 

After what I thought had been fixed resetting Dell´s system recovery, I cannot bring the computer to factory defaults.

I used all the instructions and the software from http://www.goodells.net/dellrestore/fixes.htm and when through all the fixing procedure

I thought it was fixed because in the starting sequence the blue top line with the Dell logo does appears which is where the Ctrl+F11 can be used to return the computer to the state as when it was shipped from the factory.

To my surprise when trying to use the system restore there appears a message that says:

PBR 3 Done

NTLDR is missing

Press any key to restart

Pressing any key brings this same message again shutting off the computer does not work either, when its turned on again the same message appears again.

I have no idea how I was able to boot into DOS again to be able to then shut off and boot windows normally again.

So here I am with this new problem, and I have no idea what to do about it.

Dell Dimension 9150

XP home

It came with the OS installed and not a single CD proudly saying the system restore was there instead of the CD´s

I would certainly appreciate any help solving it out.

I really need to get my computer back to the state when it was when new.


The full story  here, it all begain when i was trying to fix system restore.


Thanks so much 

Mario (Mexico)


All Replies
  • Hi again Mario


    Thanks for the feedback, great that you managed to re-enable the <Ctrl> <F11>


    Could be bad news about the missing NTLDR file?


    I’m assuming you have changed BIOS device boot sequence back to normal settings?

    And the primary HDD (where boot loader files are located) is drive 0 (zero)


    If correct then other common causes are either:


    1. Hardware – bad/damaged Hard Drive Disk (HDD) sectors or loose HDD/mobo cable connection

    2. Software – missing/corrupt Windows XP boot loader files (includes the NTLDR file)


    Sorry but as previously mentioned, you really do need to source the Dell OEM CDs/DVDs that should have been supplied with computer purchase


    Assume the editing of MBR partition table did point to the recovery image partition, if correct & the DSR image was restored then it tends to point to bad HDD boot sectors or cable issues?


    Check cable connections

    If you don’t have the Dell OEM Resource CD to run hardware diagnostics, download diagnostics utility, install on your bootable USB drive & run diagnostics to check HDD


    If it were just a software related problem then you could either use Windows Repair Install or copy NTLDR & other boot loader files from XP CD to your primary HDD XP OS partition

    But then you don’t have the Dell OEM XP CD!!!!!!!


  • You havent got a pen drive in the USB socket have you lol- try this http://www.computerhope.com/issues/ch000465.htm

  • I wrote this in another question you had.

    This can happen when the DSR doesn't go back to a seal state.  With the dsrfix used in DOS was another

    file called     "PTEdit"     which looks something like this

                                                   Type             Boot       Cyl

                                   1              DE                00

                                   2              07                 80

                                   3              DB                00

                                  4              00                  00

    Do NOT change anything in the other columns but check that  #3  is set to DB for type and the Boot is set to 00.

    Check #2 for the 80 in the Boot column this sets that partition to active so it boots and not PBR3. You can only have ONE of the 

    4 partitions set to active. If as I think your #3 is set to 80, change it to 00 and change #2 to 80, or set like above and it should boot

    the correct partition.   Hope this helps.


    Hello Bell Boy

    I have no words to thank you for your kind attention.

    Ok please help me clear my stormy mind, let’s see:

    You mentioned if I have changed BIOS device boot sequence back to normal settings.

    I tend to think yes, but again I’m not completely sure.

    In the boot set up (where there is a tiny list with: floppy, hard drive, cd-rom, usb) as I understand the numbers are the order the computer will try to boot, beginning from number one till if finds a bootable source.

    Number one is placed to the hard main hard drive, but there is no number so I could be sure if it´s drive (0) zero.


    I don’t think there is a damaged HD or cable problems since I’m using the computer right now to write you, so it did boot XP and its working fine so far.

    So ok I never got any CD´s for this computer from Dell

    (I still have this fool piece of cardboard printed with a CD shape and the proud Dell logo, saying this computer does not need any CD¨s Grrrrr)

    So how can I get out of this dead end, is there a place where I can download this CD´s?

    I have tried contacting Dell here in Mexico and If I’m not under guaranty time I can have no assistance, help or information at all, not even paying, (which I find very rude by the way)

    So I feel lost, frustrated and really confused.Sad

    With Goodells DSRFIX I got this:

    *good : boot code matches dell mbr v3.

    *good : pbr descriptor 1 is type DE.

    *good : pbr descriptor 2 is type 07.

    *alert:  pbr descriptor 3 is type OC and not DB.

    *Info : pbr descriptor 4 is type 00.

    *good: pbr1 is fat16, label is dellUtility..

    *good: pbr1 is fat32, label is dellRestore.

    *good : reference partition table in sync.

    Of course I don’t understand what this means, but probably you can see something in here.

    I really liked Windows 7 a lot but if I had known this would have happen I would have never ever installed it.

    Again I have no words to thank your help

    MarioBig Smile




  • Mario

    With Goodells DSRFIX I got this:

    *good : boot code matches dell mbr v3.

    *good : pbr descriptor 1 is type DE.

    *good : pbr descriptor 2 is type 07.

    *alert:  pbr descriptor 3 is type OC and not DB.

    *Info : pbr descriptor 4 is type 00.

    *good: pbr1 is fat16, label is dellUtility..

    *good: pbr1 is fat32, label is dellRestore.

    *good : reference partition table in sync.


    I think you need to run the dsrfix /f again and answer yes to all questions.

    The alert pbr descriptor 3 is 0C and not DB.

    the line that said *good pb1 is fat32, label is dellRestore should have been pbr3.

    Check again.

    Once you get this all showing good the Ctrl F11 should work and restore the image.

    Once that is done, if the system doesn't seal you will get the PBR3 done again.

    You will need to use the ptedit and set the third partition Type to DB and the boot to 00.

    Them set the second partition type to 07 and the boot to 80.

    Then boot, should work.

  • Hello Tom

    Thank you so much!!!

    I have just ran the PTEdit again.

    I did disconnect the secondary HD and also the external one just to be sure.

    So this is what i got:

    there are two drives in the PTEdit, I assume one of those drives is the USB pen drive where I’m booting from.

    so the power Quest Partition Table Editor says this:


    DRIVE 1 (1927MB)

            TYPE      BOOT      CYL

    1        OC          80

    2        00           00

    3        00           00

    4        00           00

    Partition Information Fat32 bootable 1927MB


    DRIVE 2 (152586MB)

            TYPE      BOOT      CYL

    1        DE          00

    2        07           80

    3        DB          00

    4        00           00

    Partition Information 31MB



    So I suppose the drive 2 is the real main HD no?

    It seems to be in the way you suggested.


    Have tried running again the DSRFIX /F and chose to fix the recommendations, but it remains as the report i sent previously it does not seem to be able to go beyond this point.

    Thanks so much beforehand



  • Hi Mario

    The second drive is the real drive and looks good.

    Have you did a restore yet with ctrl +F11 ??????

    You might need to remove the usb drive to let the real drive c boot first.

    Let me know what happens.

  • Mario


    Having multiple threads running makes continuity in replies confusing


    Drive 0 (zero) is under Drives NOT Boot Sequence


    When using Clean Install, DSR or Repair Install options you must disconnect all peripheral devices (includes e.g. NIC adapter cable) before initiating any reboot wipe options (excludes monitor/keyboard/mouse)


    Suggest you only have the USB flash drive connected when using dsrfix then when finished, remove it & then reboot to System Setup (BIOS) to restore Boot Sequence back to default, then exit saving settings


    When using dsrfix did you try the DSRFIX /F /81 command??


  • Hi Again Tom

    Thank you so much.

    So I ran again the DSRFIX and this is what i got.

    *good : boot code matches dell mbr v3.

    *good : pbr descriptor 1 is type DE.

    *good : pbr descriptor 2 is type 07.

    *good:  pbr descriptor 3 is type DB.

    *Info : pbr descriptor 4 is type 00.

    *good: pbr1 is fat16, label is dellUtility..

    *good: pbr1 is fat32, label is dellRestore.

    *good : reference partition table in sync.

    Ready to queue changes…

    No changes queued.

    This last part of the queued changes, is normal or does it means something went wrong?

    I still don’t know what this means: the line with "info" does this means an error, or just that there is no 4th partition?

    Im now afraid to hit the Ctr+F11 the last time I made this i got:

    PBR3 done

    NTLDR is missing

    hit any key to restart


    But it does not restart but just returns to the same message endlessly and shutting it off works for nothing since once turning it on again it goes back to the same loop.

    I was suffering a while ago to be able to get it booting normally again took me a few hours

    So probably with this new DSRFIX info you might be able to tell me if my next intent could be a bit more successful

    Thank you so much again


  • Im very sorry!

    in my previous post there is a mistake:

    where it says:

    *good: pbr1 is fat32, label is dellRestore.

    it should say:

    *good: pbr3 is fat32, label is dellRestore.

  • Mario

    Bell Boy pointed out that you may need to use     DSRFIX /F /81    and I believe he is correct.

    The "info" is normal which means no partition 4 on the drive.

    What is not looking correct is:

    *good pbr1 is fat16, label is dellUtility.

    *good pbr1 is fat32, label is dellRestore.

    It should look like this:

    *good pbr1 is fat16, label is DellUtility.

    *good pbr3 is fat32, label is DellRestore.

    When it said

    PBR3 done

    it is trying to boot into partition 3 which does not have NTLDR file.

    This can only mean that partition 3 is active . Use ptedit to change the 80 upto partition 2

    and save your changes. Besure to remove USB drive when you boot to use CTRL + F11

    to do the restore and after you change ptedit.

  • Hello Again Tom

    Thanks so much for your kind patience.

    I know I must be very clumsy with all this, but really for me it´s like if I was a gardener sent to a mission to the moon.

    so thanks for explaining me all this that for you must be so obvious and clear and for me is such a confusing atmosphere.


    Yes when i run the DSRFIX what i type to check the system is: 


    After that to make the changes I type:


    and proceed to say yes to all (y)

    The last readings I had are this ones :(and yes sorry I had a typing mistake in my previous post so data was inorrect)


    *good : boot code matches dell mbr v3.

    *good : pbr descriptor 1 is type DE.

    *good : pbr descriptor 2 is type 07.

    *good:  pbr descriptor 3 is type DB.

    *Info : pbr descriptor 4 is type 00.

    *good: pbr1 is fat16, label is dellUtility..

    *good: pbr3 is fat32, label is dellRestore.

    *good : reference partition table in sync.

    Ready to queue changes…

    No changes queued


    So I also ran the PTEdit. here the readings:


    (NOTE: These three "vertical" sections are in one horizontal window in the PTEdit but I had to place them in a vertical fashion here because otherwise it gets completely messed up as its posted, numbers 1,2,3,4 in the two last sections are only to illustrate the order in the PTEdit window but to not appear in the editor)



    Hard Disk: Drive 2 (152586MB)


        Type    Boot  Cyl   Head    Sector       

    1   DE        00     0        1           1      

    2   07         80     4        0           1  

    3   DB       00   1023    254       63 

    4   00        00     0         0           0   




             Cyl     Head    Sector

    1        3           254         63

    2       1323     254         63

    3       1323     254         63

    4        0           0              0 




            Before                 Sectors

    1      63                        64179

    2      64260                300993840

    3     301058100       11438280

    4     0                        0




    Still unfortunately I´m trapped in the endless loop

    PBR 3 Done

    NTLDR is missing

    type any key to restart.


    When I manage to boot XP normally I have noticed as the top blue stripe with the Dell Logo appears (when the Ctrl+F11 command can be used) just for an instant under the stripe there´s this message that says:

    PBR  2 Done

    This is probably a half a second as it continues opening XP

    I wonder what I am doing wrong?

    Again thanks so much.



  • Hi Mario

    It should be ready to restore. When you see the blue bar at the top of screen and you

    press CTRL + F11 does it show a restore screen? Or is that when it does the

    PBR3 DONE thing????

    It should try to restore. More info here:


    You only have about 2 seconds when the blue bar is on the screen to press CTRL then F11

    then release both at the same time. If you miss, try again you have to be fast. Good luck!

  • Hi Tom

    Yes I have tried restoring my pc (it’s something I have done many times in the past so I’m familiar with the process.)

    So no restore window appears.

    And unfortunately the Ctrl+F11 shoots the 

    PBRr3 done

    NTLDR is missing

    press any key to restart

    This is a hard to break loop.

    No matter how many times I press any key this message appears again.

    And yes of course I have unplugged the USB pen drive to do this

    Thanks again for being here.

    I really hope I can solve this out, now I feel I have patience to try what ever.


    If i turn the computer of and then on again it goes straignt to the same mesage in loop again.

  • Mario

    If you use the ptedit and set the DB partition to 0C for the type

    and 80 in the boot making sure only one partition has 80.

    Boot from your USB and you should be able to enter the partition

    and look in a directory called img for the fi.gho files. should be two

    or more and be sure to SAVE them. You can rebuild the rest of the

    partition as per Dan Goodell info.             good luck