ERROR: iastor.sys - Microsoft OS Forum - Software & Operating Systems - Dell Community

ERROR: iastor.sys

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

ERROR: iastor.sys

  • I recently experienced the BSOD with an error message referring to the above. I have 2 questions - 1. Does anyone know what this is and how to avoid it happening again. 2. Please read below - how do I fix the disk error message?


    After trying to reinstall windows XP it went part way through and then went back to this error message, so I was stuck!

    I used the DELL support and having checked the hardware (with no problems) was put thro to software support. AFter a LONG telephone call and paying £59 for support the system has finally been repaired after reinstalling Windows XP MCE and of course all other files drivers etc. (Disks were sent to me by DELL)


    However I still get an error message at startup - after the DELL screen it goes to one that shows the option to go to configuration utility (CTRL/I) and details the 2 hard drives I have. Altho all now appears to be working well I have an error message next to one of my disks (0)-

    Physical Drives > Disks 0 & 2 > Type status > error occurred


    Altho all appears to be working well how do I either get rid of this message OR does it suggest more trouble due?

  • Please post your model of Dell, so others can help you. 


    "Type status > error occurred"


    This message does not mean there will be future problems, it just notifies you there was one in the past, I am told this status message will disappear after so many reboots, not sure if this is true or not, I have this same message on my system after one of the Sata cables went bad, replaced it and no more problems, just the same status message you have.


    I suggest going to Intel and download the latest chipset driver (Intel Matrix Storage Manager) software and install it.


  • howOk sorry. My system;

    Dimension 9150

    Pentium D CPU 3.0 GHz

    2.0 Gb of RAM

    Windows XP MCE

    Plus various other bits.............


    ANy idea how I found out what my chipset is so I can download the correct drivers?

    Message Edited by MancBEX on 05-12-2008 11:26 PM
  • Ok, I did some investigation, an iastor error can mean 3 things.


    1. A disk is failing


    2. A disk had errors for whatever reason, but has corrected itself, but iastor has marked the disk as failing.


    3. The iastor driver is faulty, upgrade to the latest Matrix software.


    You can use the Intel Matrix software (advanced Mode) to mark the disk as "normal", this will get rid of the error status on boot up.


    Look in All programs for the Intel Matrix storage manager software (console), it is usually installed by Dell, and start the console software, do a "view" > "advanced Mode"  you should see the drive marked as failing or in a error state, right click on the drive and select "return status to normal" or similar. This should clear the error status on boot message.


    If you do not have the matrix console software installed, go here 


    and select the  945P express chipset, when the page loads, select the support Tab, find 945P in the list and slide to the right and click "download" in the Intel® Matrix Storage Manager column, select #1 under "drivers", then select your OS, then agree to the license, download and install the software.


    If you continue to get these errors on the same drive (after resetting the status), suspect it is failing and replace it.


    I suggest installing the latest Matrix software from Intel even if the program is installed by Dell, It will also install the latest raid drivers (iastor), which may be the source of the problem in the first place.







  • My system is similar to the original poster of this thread.

      Dimension 9100
      Pentium 4 3 GHz CPU
      1 GB RAM

    My computer will not boot Windows.  I get a Blue Screen which says:

      Technical Information:
      STOP: 0x000000D1 (0x00000018,0x00000002,0x00000000,0xF722F261)
        iastor.sys - Address F722F261 base at F7220000, DateStamp 426d0c8c

    Also, I cannot boot into Safe mode, either plain or with network or command line.  I get a long list of drivers being loaded, and then the computer freezes.  The last loaded driver is Mup.sys., which is the 13th driver loaded after iastor.sys.

    I tried "Last Known Good Configuration", but that did not help either.

    I ran a full diagnostic of the computer from the Utility Partition.
    It found an error in the hard drive in one block:

      Error code: 0F00:0244
      BLOCK 0399125927 of 0976773167 blocks

    I saw another message in this forum that said to goto to System Setup and change the SATA operation from RAID/AHCI to RAID/ATA, reinstall something, and then change SATA back to RAID/AHCI.  But when I changed to RAID/ATA, the computer would not boot and I got the same Blue Screen.

  • I have XPS/Dimension 400 almost the exact issue....cannot boot up in Windows in any, safe with network, etc. I do not always get a blue screen but when I did, the following info

      Technical Information:
      STOP: 0x000000D1 (0x00000028,0x00000002,0x00000000,0xF7B1D87a)
        iastor.sys - Address F7B1D87A base at F7B0A000, DateStamp 42b2df42

    Called Dell, have complete care and limited Tech support.....had me try abunch of differnet things...nothing works!!  Not too please with the assitance or lack there of.....anyone HELP!!!!