My videos won´t play in Windows Media Player 11. Audio codec missing??

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

My videos won´t play in Windows Media Player 11. Audio codec missing??

  • Two weeks ago, I purchased a Dell Inspiron 6400 with Windows Vista. I copied my personal videos from my laptop at work (a Dell Latitude 600 with Windows XP) to my new laptop.

    • In my work computer, if I double-clicked a video file (ASF-extension), Windows Media Player opened, and played the file.
    • In my new computer, Window Media Player (version 11) opens, pauses approx. 20 seconds, and tells me an audio codec is missing. I got no sound and no picture.
    • Windows Media Center also refuses to play the videos, but doesn't show error messages either. It just shows a black silent rectangle for the duration of the video, and than tells me it's ready and asks whether I want it to play it again.
    • If I open the file in the ULead video-editing software that came with my camera, the video plays without sound.
    • Dell MediaDirect does play the files correctly (so - this tells me that some good audio codec must be present somewhere).
      However, that doesn't really help me, because I can't get MediaDirect to show my videos on double-clicking the video file. If I make MediaDirect the standard program for .ASF files, double-clicking an ASF file only starts Dell MediaDirect, but will not play the file, until I navigate through my folders to find the video file and open it again.

    The videos are .ASF files, created with a Traveler DV 5070 digital camera.

     

    I downloaded an ran GSpot to test one of my video files and determine the type of audio codec it requires.

    Result: It requires the 0x0002 ADPCM audio codec.

     

    Windows Media Player 11 on my new laptop reports to have this codec installed :

    • Type  = ACM
    • Name = Microsoft ADPCM CODEC
    • Indeling = 0002
    • Binary file = msadp32.acm
    • Version  = 6.0.6000.16386

    I found that msadp32.acm file in the C:\Windows\System32\ folder.

     

    So, the strange thing is, that Windows Media Player complains that the audio codec is missing, while in fact it is present all along!

     

    On my work computer (the Dell Latitude/Windows XP), a file msadp32.acm is also stored in the System32 folder. When I viewed that file in a text editor, I found an indication of the version, 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158) .

     

    Clearly, the versions of the msadp32.acm file are not the same.

     

    Searching the internet, I found a description of a similar problem with Windows Media Player, where the solution consisted of going through the commands for installing new hardware, and when the operating system asks for a disk with the drivers, point to a file on in the C:\Windows\System32\ folder. That solution involves a file C:\Windows\System32\mmdriver.inf Such a file is present on my old (work) computer, but not on my new laptop.

     

    To summarize, my questions are:
    1. Can I get Windows Media Player 11 to behave decently and play my videos if I ask it to do so?

    2. If yes, how?

    3. Or else, can I get Dell MediaDirect to show my video immediately if I double-click an ASF-file?

    4. Or else, is there another player available (for free or cheap) that might be willing to show my videos without hassle?

    5. Are other forums more suitable to post this question? Which?

     

    My hope is, that if I can get Windows Media Player 11 to play the ASF-files, that my ULead video editing software also can play the sound again.

     

    Hoping for help -- Johan Lont

     

  • Install this codec package for WMP11

     

    http://shark007.testbox.dk/

     

  • Johan, I've had alot of the same problems as you when I use WMP11.  My solution is to download the free Divx player which comes with lots of codec.  That usually solves my WMP11 problems

  • I wish to thank mombodog and rcarrosq for their advices.

    Unfortunately, these tips did not solve my problems with Windows Media Player (WMP), but I did find some workarounds.

    Downloading DivX did not solve my codec problems in Windows Media Player, but I can use DivX to view my videos. In general, I prefer WMP, but DivX is an acceptable alternative.

     

    To make ULead VideoStudio (the video editing software) work with my video files, I first convert the files with Stoik video converter ( http://www.stoik.com/products/svc/ ). The basic version of that program can be downloaded at no charge. That idea was posted by oepkje on a Dutch-language Help forum, called 'www.helpmij.nl' ("helpmij" is Dutch for "helpme" ).

     

    To proof that this method works, just see the first movie I posted on YouTube: http://www.youtube.com/watch?v=U49KthU4NFc It was created with the method described here.

    Message Edited by Johan Lont on 04-03-2008 09:55 PM