need XP drivers for new Inspiron 531

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

need XP drivers for new Inspiron 531

  • Just bought an Inspiron 531 that came loaded with Vista. I did a clean install of my own copy of XP but now I need drivers for the SM Bus Controller, a PCI bridge device (the network controller?) and another unidentified PCI device. None of these are listed at the driver page for this computer and XP. The chipset is listed as an Nvidia® MCP 61. I don't know if I need updated drivers for that either. Can anyone steer me in the right direction? Thanks for any help you can offer.

    Driver list is here: http://support.dell.com/support/downloads/driverslist.aspx?c=us&l=en&s=gen&impid=-1&vercnt=1&osl=en&SystemID=INSP_DSKTP_D531&catid=-1&deviceid=14246&releaseid=R159026&servicetag=&os=WW1&formatcnt=1&libid=1
  • I did a search and coulden't find any other drivers apart from the ones on the Dell site allready.
    You could try contacting Dell as your Inspiron is new and Dell will now have all the drivers available now.
     


    Inspiron 1501

    MK36 AMD Turion

    2 GB RAM

    ATI 200MSeries

  • Nvidia MCP 61  chipset is what is used in the Inspiron 531

    Known drivers that work for the 531 and most likely the 531s, install the in the following order for best results.

    1. Chipset, 2. Video, 3. Sound, 4. Modem, 5. AMDlive patch  

    Video   Video, covers many models of Nvidia cards including the integrated chip, click the "products supported" tab  Special thanks to "episodic"
    **UPDATED**
    It is a Realtek ALC888 sound chip
    The Vostro 200 Xp Sound drivers are reported to work for the 531    R158510 
    again, thanks to Don "etherion" & "episodic" for this tip
     
    The Vostro 400 Sound drivers are reported to work for the 531 also.   R162030
    thanks to hemiii0 for this tip
     
    Phone Modem, **verified to work** Special Thanks to DaveC210  R73044
    Newer Phone modem Driver, not verified R131301
    For the     ACPI/AWY0001..." Unknown Device Special thanks to Scott "yodigity" for digging this one up
    This link works, the one posted by Scott is broken for now.
    If you have a Dell Bluetooth/Card Reader (CAB-200) see this, special thanks to Fitzman
    Wireless ASUS WL-138gE
    pick "wireless" for products "client card" for series  and "WL-138gE" for model. XP Driver file is 3100640.zip
    Special thanks to wa1349 (Bill)
     
     
    As you can tell I have revised this post to reflect new changes and drivers posted by others in this thread, trying to make it easy for the technically challenged to downgrade their 531's
    Thanks to everyone for contributing, please post any updates, error's or problems with the info in this post.

    As some of these nvidia links may become broken, you can get a complete nVidia driver pack here

    http://outerheaven.c-reality.com/archives/84-Dell-Inspiron-531-Windows-XP-Driver-Pack.html




    Message Edited by mombodog on 04-08-2008 09:05 PM
  • Mombodog - thank you VERY much for coming up with those. I went with the link to the nvidia site first and it worked like a charm. Good to know since tech support told me my only option was to return the computer and buy a different one or reinstall Vista. Reinstalling Vista would have been a challenge since I don't know if Dell's reinstallation disk would have worked after the clean install of XP. Thanks again man!
  • Thus the reason for my handle, mombodog, I dig up things.
     
    You are Welcome, and thanks for posting back about the success.
     
    So, is device manager clear of any missing drivers now? Post back any other links to drivers for that model and XP, besides the few on Dell's site.
  • There's one more incomplete item on device manager - listed simply as a PCI device. Not sure what it is yet. On the surface, everything else looks functional - i.e. DVD burner, media card reader. If you have any thoughts, let me know. Thanks again.
  • Try this free utility to help identify that device.
     
     
    Probably a modem, what pci cards are installed?
  • The only card installed is video (drivers on CD worked for XP). There are two empty slots. The missing link is sound. Right now there is none. It's integrated but not identified in device manager. The Belarc site indicated "none detected" for multimedia. So I think I'm now hunting for an elusive sound driver for the nvidia board. I'll let you know what I find out. Unfortunately my hunting time is limited so if you run across anything before me, send it on over. Thanks again. It looks like PC manufacturers (at least Dell) is starting the divorce from XP and the marriage to Vista in a no-turn-back manner.
  • It is a realtek ACL888 sound chip
     
     
     
    newest version here


    Message Edited by mombodog on 09-26-2007 12:05 AM
  • mombodog - you da man! Thank you again. All is well now. No yellow flags in device manager and everything works on a new Inspiron 531 with XP. Hope your links help someone else too in the near future.
  • Hi from France ! Thanks you guys , kentw79 and mombodog are my two Heroes ! No sound on a Pc is soo bad ^_^ . I download the last link and the sound didn't apeard but after make sound event in "Properties of sounds and audio peripherals" (traduction of french window :p ) and : let there be sound !!! Thx you all again and sorry for my bad english xD
  • Hi there
     
     
    Thanks for your help with the INSPIRON 531. 
     
    Would you happen to know where the drivers are for the INSPIRON 530 ?
     
    It is a Celeron CPU.
     
    Thanks in advance.
  • Would anyone know where I could find he WindowsXP drivers for the Inspiron 530?
     
     
  • Click on the Drivers and Downloads button in the left panel of this page . . navigate to your pc and download any and all drivers you need . .

  • I have already checked there prior to posting.  The DELL website does not list all the drivers for WInXP.  :smileysad: