“A service installation section in the INF is invalid.” - Microsoft OS Forum - Software & Operating Systems - Dell Community

“A service installation section in the INF is invalid.”

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

“A service installation section in the INF is invalid.”

  • My son has an iRiver H10 20GC MTP player. His laptop has stopped recognising it; but my desktop recognises it fine.


    In the Device manager on his laptop there is a yellow exclamation mark.

    It has no drivers (code 28) and when I attempt to install them I get an error message:-


    “A service installation section in the INF is invalid.”


    I contacted iRiver who sent me Firmware and said that would sought out the problem; but it has not (nor did I think it would as the H10 workd fine on my desktop.


    I then followed this thread from the Dell forum….


    Just a detection issue and your pc just needs to recognize it again ..... Like I said on your thread in the Dell forums:

    Just wanted to make sure that you did the following steps:

    Connect the 'bad' Ditty Open up Device Manager

    Locate the 'bad' Ditty, right click and seled Properties On the Driver tab click on Update Driver

    Depending on how many updates you have for Windows a message may appear saying to connect to Windows Update, select No, not at this time and click Next Choose the option for Install from a specific location (Advanced), click Next Choose the option to Don't search. I will choose the driver to install, click Next Click on Have Disk

    Browse to: C:\WINDOWS\inf


    Here I was able to browse to C:WINDOWS\inf but not within the folder so I could not execute the rest.


    Click on wpdmtp

    Click Open

    Choose MTP Device Click on Next

    It will install the necessary stuff and hopefully your Ditty will work ...


    So I went on to do this – but to no avail….

    Otherwise you can go into the registry:

    From the Properties window of the 'bad' Ditty click on Details From the drop-down menu select Hardware ID's

    Write down the first line which appears. Eg mine says:

    USB\ Vid_041e&Pid_ 4132&Rev_0100

    Remove the following: USB\Vid_ &Pid_ &Rev_ so your left with: 041e41320100

    Open up your Registry (Start Run regedit)

    Browse to: HKEY _LOCAL_MACHINE\SYSTEM\CurrentControISet\Contro I\UsbFlags\

    Find the number that you have above, so I would be looking for 041e41320100 Delete this key, the whole folder.

    Connect the 'bad' Ditty and see what happens.


    The Device “details” in Device Manager on both machines is …



    The driver on my GOOD desktop is wpdusb.sys


    As a said, there is no driver on my son’s BAD laptop and whenever I attempt to install one using the Device Manager Troubleshooter I get the same…


    “A service installation section in the INF is invalid.”



    Please can you help?


    With thanks and best wishes,





  • I found you posts all over the internet, sorry no solution yet. I wish I had one of those so I could investigate for you.
    Does it give a name or loacation of this inf file?

    Message Edited by mombodog on 06-17-2007 12:54 PM
  • No, I assumed:-
    Thanks fro trying.
    Bws,  RICHARD
  • Thanks, but that is the inf folder store, it is looking at a specific inf file in that folder.
  • Yes, sorry - it is not specific.
    The file in the store which contains details on my son's HD10 seems to be wpdmtp that is some sort of text file; and I know not what to do with that.
    Howeever, I think your question is does the error message define a particluar *inf file and the answer is - No, it does not.
    Thanks again and bws,  RICHARD
  • Try this, go into device manager, expand "universal serial bus controllers"
    There will be a bunch of entires in there. What you are going to do is right click on some of them and choose "uninstall"
    The one's I want you to uninstall are "Generic USB Hub" and USB Root Hub" No others
    You have to uninstall them one at a time.
    Be sure all your usb devices (external hubs also) are unplugged before doing this, leave the keyboard and mouse plugged in.
    What ever you do, do not uninstall any "Host Controllers'
    Reboot the PC when they are uninstalled. Windows will reinstall them, then try the device again.
  • Well, I tried - but to no avail.  It led to the same error message.  I must go and be (un)productive elswhere now but if your beauty sleep brings any inspiration, then please let me know.
    Thanks again and bws,   RICHARD