HELP: Doing a Repair Installation - Question: CTLFACE.SYS - Where is it?

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

HELP: Doing a Repair Installation - Question: CTLFACE.SYS - Where is it?

  • First, I am not computer savvy so hopefully this is something simple and it's just me not being very experienced. 
     
    I am performing a Repair Installation on my parents Dell Demension Desktop.  I have gotten to a point in the repair installation where I have the following prompt:
     
    The file 'ctlface.sys' on Creative WDM Audio Driver Disk is needed.
    Type the path where this file is located then click Ok.


    I understand a device driver is being asked for but I can't figure out where the heck it is. I've put in all the Dell disks that were sent with the system but no luck.   I tried the following CDs:
     
    Dell Tools CD for Reinstalling Dell-Installed Software
    Dell Dimension ResourceCD for Reinstalling Device Drivers and Using Diagnostics, Utilities, and Online Documentation
     
    I even tried searching these disks in another computer for the file name being asked for - no luck.  I would have thought that the driver would be on the device driver CD.  Maybe it is but I don't know the right path or it is part of a install, ZIP, CAB file (realize I might not be using the right terms here)???

    What do I do? Can I cancel without cancelling the repair? Is there somewhere other than the Dell disks that came with the system where this file would be located.   I even tried going to the Creative Labs web site and searching there site for this file name - it came back and said there were no updates available but didn't show me where the driver is so I could download it.

    Frustrating since I understand what is being asked for but can't figure out what to do.....
     
    So, I'm stuck.  Can someone please help???
     
    Many thanks,
    mhagan
  • Denny,

    Thanks.  Not sure why I didn't find that as I thought I did a search of the site for ctlface....

    Either my parents never got a Creative Sound Blaster Live! CD or it's lost - we don't have it.  So, those instructions in particular, I can't use.  

    How do I proceed if I don't have the CD?  I did search the Dell Resource CD looking for an Audio directory but didn't find one.   It can't be that difficult, can it?

    Thanks again for your reply and help.

    mhagan

     

  • hi,
     
    if you don't have the cd's for your parents creative labs soundcard, i recommend to search the creativelabs website . updates of new drivers are usually on the site. the wdm audio driver loads once you install the driver file. look in device manager under hardware in sounds. you will find it there.
     
    good luck and happy holidays
  • 4500
  • screwer,

    I did try to search the Creative web site but I must be too computer illiterate to figure it out.  I tried searching on the for ctlface.sys and I got a message saying that no updates were available but no link or directions on how to find or download the driver. 

    haganm
  • New problem:  Got past the CTLFACE.SYS issue (my dad, thank goodness found the Sound Blaster CD).  The repair installation proceeded ok until I got the following message.  Again, I'm not very computer savvy so I have no idea what the heck this means:

    COM+ SETUP ERROR

    Sub component COM+ raised an exception while processing the OC_COMPLETE INSTALLATION setup message.

    d:\nt\com1x\src\complussetup\csetuputil.cpp (line 3406)

    Error code = 0x8007007f

    The specified procedure could not be found. 

    Failed to load library 'C:\Windows\System32\catsrc.dll'

    The only option in the message window is 'OK'.   There is no RETRY or CANCEL. 

    I haven't yet clicked on 'OK'.

    My questions:  Any idea what this message means?  If I click ok, will I be able to continue the repair installation?  If not, what options do I have to complete the repair installation?  Any recommendations what I should do next?

    Any help, assistance, suggestions are welcomed as I have no idea what this message means.

    Thanks in advance,

    haganm

  • More info:  I clicked on ok to see what would happen.  The repair install concluded.  However, upon reboot, I am getting the same thing happening that prompted my initial post  - the blue windows login screen without the ability to login anywhere and with the only option a "Shutdown" button at the bottom left portion of the screen.
     
    I tried doing the repair installation again and encountered the same COM+ message.
     
    So - again questions are still:  What does this message mean and is there anything I can do so that the repair installation can complete successfully?  I can do a full re-installation but would prefer not to since I do have some data that is not backed up (most of it is).  
     
    Welcome any help, assistance, suggestions, etc
    Thanks in advance,
    mhagan