Problem with Windows 7 "Starforce Copy Protection System".

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

Problem with Windows 7 "Starforce Copy Protection System".

This question is not answered

First; Hi. I'm new to these forums, and my Dell Studio XPS just arrived, I really like it.

And to the main point, I just finished installing my my new laptop with Windows 7 and whatnot, and I just installed one of my computer games. Unfortuantly, when I try to launch it, now that I've installed it, this "Starforce Copy Protection System" pops up, and says "To install this application, you must have Administrator privilages on your computer."

Odd, seeing that this is my first account and thus, I do have administrator privilages over my computer.

Thanks, and sorry if this is the wrong area in the forum. I wasn't sure where to post this.

All Replies
  • jacos,

    Thank you for using the Dell Community Forum.

    If you right click on that pop up and choose run or install as an administrator may help.

    #iwork4Dell

  • It seems this is affecting most games.

    Also, if I attempt to run it as an administrator, it will say it works and ask me to reboot, and when I reboot, it seems to have reinstalled everything.

    Also, when I attempt to run a game called Rogue Survivor I enjoy, it never works.

    It seems this new laptop isn't very good - nothing freaking installs or runs!!

  • jacos,

    This system is not designed for playing games too well unless you have a video card that meets games requirements. Which XPS Studio system do you have? I will look up the specs.. What vide card do you have in this system? What is the minimum size video card does the game say to use in order for it to work properly?

    #iwork4Dell

  • "Dell Studio XPS 1645/1647"

    I talked to some representative or somebody like that while I was shopping for a laptop, they referred me to this one which I am now using, as I told them I was looking for one which was decent for gaming.

  • 1. According to the Dell site (shop) the XPS Studio 16 uses a ATI Mobility Radeon™ HD 5730 - 1GB, which is more than ample to run most games.

    2. “To install this application, you must have Administrator privileges on your computer."  This is not a video card problem, but a system configuration problem.  Possibility you are not actually the administrator.

  • I've checked. I am an administrator.  Any other ideas, please?

    Also, earlier I said it "reinstalls" everything when I run it as an administrator. It also uninstalls the game.

  • Hello? I'm still needing an answer!!

  • Well Hello to you! Maybe you should have tried "please" & "Thank You" instead of demanding an answer.

    Good Luck.

    Jeff Beer

    XPS 8100 i7-860(8MB Cache, 2.8GHz), 8GB Dual Channel DDR3 SDRAM @ 1333MHz, 750GB SATA 3.0GB/s 16MB Cache, nVidia GeForce GTS2401GB GDDR3, Dell ST2310 Full HD Widescreen Monitor, AverMedia G2 Combo hybrid TV Tuner, dual 16x DVD+/- RW dbl layer, Microsoft LifeCam Cinema HD, Running Windows 7 Home Premium, 64 bit. 

    If your question is answered here on the forums; PLEASE post back! It may help another user.