Will Windows 7 work on my E520?

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

Will Windows 7 work on my E520?

This question has suggested answer(s)

Hi all,

I have a Dell E520 with 4gb ram and a Q6700 processor (yes, I upgraded).

Will Windows 7 install OK on this?  I hope so as I've already pre-ordered from Amazon...

Thanks in advance!

All Replies
  • If you have Vista, it will work. You might have some hardware or software that needs to be removed or upgraded. Run the Windows Upgrade Advisor to see. Download it  Here.

    If you have Windows XP, the installation is a little more difficult since you must do a clean install using the Upgrade disk, so you will have to backup all your personal files and reinstall all your software. But do not remove XP or reformat before you start the install. You must prove eligibility for the upgrade by starting the Custom Install and reformat from Windows. Lots more info on this at the Win 7 site.

  • Same system, same question, but can I assume that the RAID setup referred to by Dell as "Data Protection" will survive under the radar of the Win7 upgrade? I'm guessing that the RAID setup is a BIOS construct which is not affected - true? I've broken my mouse looking for a straight answer to this on Dell's site. Thanks.

     

  • shreddog,

    Thank you for contacting the Dell Community Forum.  The RAID setup on your system should survive the Windows 7 upgrade, because the RAID itself is configured and stored in a separate utility that is outside Windows, and should be unaffected by the change in OS.  You might have to install a separate RAID driver to install the OS, but since this system was made in 2006, Windows 7 most likely contains those drivers already.

  • Please help.  I'm confused about upgrading to Windows 7.  There are  many issues that I currently have with Vista, and I'm hoping that upgrading from Vista to version 7 will resolve them. 

    Dell does not list the E520 as a system that can be upgdated to Windows 7!  I've already purchased the Software, but I can return it if I don't open the package.  Is it true that it is my risk if I purchase Windows 7, and that I'm simply expending more aggrevation, time, and money if the update fails?

    Can either of you, shreddog or Chris Bu, confirm that you've successfully  updated a E520 from Vista to Windows 7, even if there were a few 'gotchas' that were not deal breakers?

     

    Many Thanks,

    djaugh (pronounced 'joe')

  • Hi,

    I can confirm that I have gone from XP to Windows 7 (64 bit) on my Dell E520 without a hiccup - every single device picked up by Windows during installation, didn't have to search for a single driver myself.  Very impressed with how smoothly it went.

  • Hi,

    I have just upgrated from Vista to windows 7 with no problems,runs great,  but if you have issues

    with Vista I would go the clean install route, it will take you longer, but  you will be sure of a successful

    installation of windows 7

     

    Bob Moyer

  • Hi, Folks

    My clean upgrade from Windows XP SP3 to Windows 7 on my Dell Dimension E520 ran fine, EXCEPT...

    I backed up all the files on the C: drive to a new 250GB Seagate Barracuda 7200.10 IDE drive housed in a Galaxy Metal Gear Box USB2/Firewire external enclosure. I used the USB2 interface. Backups ran perfectly under XP. But after the upgrade,  Windows 7 had no clue about the external drive. Period. Galaxy has no Windows 7 drivers because the drivers bundled with Vista worked fine and they assumed it'd run fine under Windows 7. WRONG-O, guys!

    So now I have a smoothly upgraded Windows 7 PC with NO user data, no easy way to get it back, and an invisible external drive.

    Be aware of this in upgrading - just because external storage works in XP or Vista is NO guarantee that the driver is present in Windows 7!

    I will have to pull the raw drive out of the enclosure to free it from the useless Galaxy circuitry and see if I can set up the interface so that the drive is visible in Windows 7. Haven't pulled the E520 case apart yet to see what's available. The Dell specs are vague on the exact count of IDE interfaces.

  • Many thanks to all of you who have responded.

    I decided last night to return my unopened Windows 7 update to Best buy.  However, based on the replies, I'm reconsidering the decision today.  I'm very resentful that I need to pay lots of $ to basically re-install and re-configure a deficient product.

    Here's a tip that I fortuitously followed and which saved me a lot of effort.

    Before I lost the ability to boot Vista, (BTW, the problem was caused when I tried to install Vista SP2.  My system ran into a endless loop of "Boot-Restore-Repeat"), I had downloaded a free trial version of Acronis True Image Home 2010.  It's a wonderful program, and I'll certainly purchase it outright.  I had just completed an Acronis  System Backup 2 hours before I tried to download and install SP2.

    To restore from the backup, I bought a new internal drive (so that I would not further corrupt the drive that lost it's ability to Boot up Vista) and connected the cables.  I booted from the CDRom that I had created using Acronis before I commenced the backup.  This was a pretty high-risk method of testing the ability of Acronis to restore from the back-up.

    It wll working perfectly.  The Restoration took two hours of processing time while I went for a bike ride.  When I return, my dear ol' system was running perfectly on the new drive.  All of my settings, configurations, programs, and data were virtually undisturbed.

    I recommend that anyone thinking about updating Vista or converting to Windows 7 should first give Acronis a trial evaluation.

    djaugh

  • Oooops! SUCCESS!

    My apologies to Galaxy Metal Gear. Their enclosure works just fine. What doesn't work is one of the USB ports on the E520 backplane. I plugged the enclosure into a USB port on my Dell display and Windows 7 found it instantly, installed a driver for exactly the right Seagate drive, and I am now off to the races after I shoot an e-mail to Galaxy support to make amends. THE GALAXY METAL GEAR BOX ROCKS in Windows 7! And the E520 works beautifully with Windows 7.

  • Well, I purchased and installed Win 7 this past week end.  While I'm still grumbling about the cost of the "Ultimate" update, I'm elated about the new Windows version 7 and it's straight-forward installation.  Many of my gripes about Vista are now resolved. Here's my report of things that worked well ...

    - Backed up the data from the old system using WindowsEasyTransfer

    - Installed Win 7 as new system rather than trying to install over my old data.

    - Turned On Windows Defender, User Account Control, and Installed AVG-Free anti-virus software

    - Restored data from Easy Transfer. 

    - Installed those programs I wanted to have on my system.  This was a good opportunity to clean up my system from programs that I no longer use.

    This succeed beyond my wildest expectations.  My previous File Structure, and configurations for Favorites, MS-Explorer, Adobe Photos,  and Outlook survived.

    Lessons learned ...

    Acronis backup archives cannot be completely trusted.  They will fail to allow a recovery operation if the backed-up file system has corruptionin the hard disk file system that could have been fixed with "chkdsk /b".  Acronis provides no support or instructions for the occurance of this failure condition.  I even suspect that Acronis might have contributed to the corruption. CONCLUSION: Routine Backups should always be preceeded by running "chkdsk /r" to verify that the disk is okay before the backup soiftware (Acronis) creates a backup by making an image that is a virtual hard Drive of the filesystem that is being backed up.

    Windows Backup is not great either.  During a backup operation, an error message popped up saying, "Backup Failed".  There was no further information or explaination.  At least I was notified on the 'create backup' side rather than on the 'restore from backup' side. 

    If possible, obtain a second hard drive for building the new system.  Preserve the original system on a different drive.  In my case, I was able to install both drives in my desktop, so I could choose which drive/OS to Boot from.  This gave me tremendous peace-of-mind, since my original Vista sytem did not need to be overwritten to install the new Win 7 system.

    After testing the new Win 7 system thoroughly, I reformatted the disk that had Vista on it into several partitions.  I'm now using one of those partitions disk for data, and I keep only Win 7 and installed drivers, programs and configurations on the bootable drive. Another partition on that old Vista drive is now used for testing my backup archives to insure that they can successfully be used for restoration. This gives me much more confidence in the backup scheme that I've devised for this arrangement.  I should have done it much earlier in life.  I'm very lucky to have not been substantially burned by data loss in the past. I also got a small-sized pocketdrive (with 500 gig!)  that I now use in conjunction with another USB drive that I had on hand.  I put backup archives on these and rotate these two drives  between my home and away from home.  I also keep on them program images, and encrypted files that contain all of my activation codes, and online account information.

    I extend my thanks to the people in this thread who reported to me that the software update should succees. If anyone has a recommendation for robust backup software, please let me know.

    -djaugh-

     

  • I recently tried that but Win 7 (E520, Win 7 Pro, C2D Q6700, 6GB RAM, nVidia 8300) would not recognize the RAID drive.  The firmware works fine as far as configuring the RAID volume and Win 7 has the drivers required for the drives, but you have to re-install the Intel Matrix Storage Manager to recognize the RAID drive.  The Intel Matrix Storage Manager for this platform will not install on a Win 7 OS - or at least I can't get it to install as it keeps returning error saying wrong os.  I think Dell is purposely limiting the usefullness of the E520 platform as part of planned obsolescence.  A shame becasue all my application software runs like the wind on this upgraded platform.  Just no RAID so not robust enough to use as a peer-to-peer business server ina small business environment.  I've found an Intel Matrix Storage Manager for the G965 chipset on the Intel website and will try that in next few days.

    If you know of any workaround to get the Intel Matrix Storage Manager from Dell to install under Win 7 Pro on an E520 let me know. 

  • You have to install the correct version of INTEL Matrix storage Driver via F6 floppy method. As they go up in version they STOP SUPPORTING Older and older chipsets.  You must also use the 32 bit or 64 bit version based on what kind of windows you have.

    http://www.intel.com/.../CS-009337.htm

    https://downloadcenter.intel.com/download/17131

    8.6.0.1007


    downloadcenter.intel.com/.../17882
    8.9.0.1023

    Intel® Matrix Storage Manager Driver
    PCI\VEN_8086&DEV_2682&CC_0104.DeviceDesc    = "Intel(R) ESB2 SATA RAID "
    PCI\VEN_8086&DEV_27C3&CC_0104.DeviceDesc    = "Intel(R) ICH7R/DH SATA RAID "
    PCI\VEN_8086&DEV_27C6&CC_0104.DeviceDesc    = "Intel(R) ICH7MDH SATA RAID "
    PCI\VEN_8086&DEV_2822&CC_0104.DeviceDesc    = "Intel(R) ICH8R/ICH9R/ICH10R/DO/PCH SATA RAID"
    PCI\VEN_8086&DEV_282A&CC_0104.DeviceDesc    = "Intel(R) ICH8M-E/ICH9M-E/PCHM SATA RAID "

    downloadcenter.intel.com/.../15251
    Version 9.6.0.1014

    Intel® Rapid Storage Technology Driver
    PCI\VEN_8086&DEV_2682&CC_0104   = "Intel(R) ESB2 SATA RAID "
    PCI\VEN_8086&DEV_27C3&CC_0104   = "Intel(R) ICH7R/DH SATA RAID "
    PCI\VEN_8086&DEV_27C6&CC_0104   = "Intel(R) ICH7MDH SATA RAID "
    PCI\VEN_8086&DEV_2822&CC_0104   = "Intel(R) ICH8R/ICH9R/ICH10R/DO/5 Series/3400 Series SATA RAID"
    PCI\VEN_8086&DEV_282A&CC_0104   = "Intel(R) ICH8M-E/ICH9M-E/5 Series SATA RAID "

    downloadcenter.intel.com/.../20104
     Version  10.1.0.1008

    PCI\VEN_8086&DEV_2682&CC_0104.DeviceDesc    = "Intel(R) ESB2 SATA RAID Controller"
    PCI\VEN_8086&DEV_27C3&CC_0104.DeviceDesc    = "Intel(R) ICH7R/DH SATA RAID Controller"
    PCI\VEN_8086&DEV_27C6&CC_0104.DeviceDesc    = "Intel(R) ICH7MDH SATA RAID Controller"
    PCI\VEN_8086&DEV_2822&CC_0104.DeviceDesc    = "Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller"
    PCI\VEN_8086&DEV_282A&CC_0104.DeviceDesc    = "Intel(R) Mobile Express Chipset SATA RAID Controller"

    downloadcenter.intel.com/search
    10.5.0.1027


    downloadcenter.intel.com/.../20768

    Version 10.8.0.1003

    PCI\VEN_8086&DEV_27C3&CC_0104.DeviceDesc    = "Intel(R) ICH7R/DH SATA RAID Controller"
    PCI\VEN_8086&DEV_27C6&CC_0104.DeviceDesc    = "Intel(R) ICH7MDH SATA RAID Controller"
    PCI\VEN_8086&DEV_2822&CC_0104.DeviceDesc    = "Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller"
    PCI\VEN_8086&DEV_282A&CC_0104.DeviceDesc    = "Intel(R) Mobile Express Chipset SATA RAID Controller"

    downloadcenter.intel.com/.../21854

    Version 11.2.0.1006
    PCI\VEN_8086&DEV_27C3&CC_0104.DeviceDesc    = "Intel(R) ICH7R/DH SATA RAID "
    PCI\VEN_8086&DEV_27C6&CC_0104.DeviceDesc    = "Intel(R) ICH7MDH SATA RAID "
    PCI\VEN_8086&DEV_2822&CC_0104.DeviceDesc    = "Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller"
    PCI\VEN_8086&DEV_282A&CC_0104.DeviceDesc    = "Intel(R) Mobile Express Chipset SATA RAID Controller"


    downloadcenter.intel.com/.../21858

    Version 11.6.0.1030
    Windows 7 (32-bit), Windows 7 (64-bit), Windows 8, 32-bit, Windows 8, 64-bit

    PCI\VEN_8086&DEV_2822&CC_0104.DeviceDesc    = "Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID"
    PCI\VEN_8086&DEV_282A&CC_0104.DeviceDesc    = "Intel(R) Mobile Express Chipset SATA RAID "


    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating.

  •  

    that wasn't a service tag, it was an Intel quad core designation, i.e., Q6700.  Surprised you didn't know that!?

  • I had already read all that info from teh Intel website.  The problem is that the instructions for installing are confusing, even contradictory (not surprising for Intel).  After the first couple of sections with all the boiler plate, the instructions tell you to confirm whether you have RAID or non-RAID configured in BIOS.  They say to open device manager and look under SCSI and RAID controllers to determine in your configured for RAID or AHCI.  Then the instructions tell your to use the "F6" method for installing the proper drivers DURING WINDOWS INSTALLATION!  How can you look in Device Manager if Windows isn't ALREADY INSTALLED!?!?  Makes absolutelty no sense to me.  That's why I was looking for someone who has been ther done that.  I already know how to access Intel website and look up the drivers and storage manager application - it's the installation process I don't understand.

  • RedZCar
    The problem is that the instructions for installing are confusing, even contradictory (not surprising for Intel). 

    See if these instructions help:

    http://dellwindowsreinstallationguide.com/a-clean-install-of-windows/downloading-preparing-and-loading-sata-drivers/

    Philip Yip

     

    Windows Reinstallation Guide and Related Wikies See here for other wikies such as Customising and Using Windows 8.1, Dell Wireless Cards and Unofficial Drivers.