System restore error Run Dll as an App problem - Microsoft OS Forum - Software & Operating Systems - Dell Community

System restore error Run Dll as an App problem

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

System restore error Run Dll as an App problem

  • MS Windows XP Home 5.1.2600 Service Pack 2 Build 2600, Inspiron 8200, BIOS A08, 12/10/2002
    Problem: when attempting to use system restore a window appears with "a run DLL as an App has encountered a problem". System restore does not open.
    What I have done: First the hard drive was getting very loud so I ordered a new one from Dell. Made a ghost back up image of the old drive and gave the computer, backup, OS disk, Drivers Disk to the local tech to install.
    When I picked up the computer it had registry errors galore. The ghost image crashed on the eleventh disk so he mad a western digital image and loaded the new dist that way? I have most of it up and running well except system restore.
    This is what I have done so far to try and fix the problem. I can't open the restore window in property to turn it off. I ran SFC /scannow with the system reinstall disk in cd/rw drive the process ran through, rebooted the unit and same error on System restore. Went to Run services.msc and shut down Sys restore and rebooted, problem not solved. Any suggestions short of a fresh install of OS??
  • Charlietoo,
    I would run a Repair Install of Windows.  You can view a step by step walkthrough of a Windows XP SP2 Repair/Install here: 

  • Tony will that take care of the Dll problem?  Thanks!:smileyvery-happy:
  • Charlietoo,
    After considering the fact that your hard drive was apparently cloned using Western Digital's software, I would first try the following:

    When trying to start Windows System Restore, the following error message appears:

    "Run a DLL as an App has encountered a problem and needs to close. We are sorry for the inconvenience."

    This error may occur if the primary hard drive or boot partition has been changed/upgraded/replaced and software from the hard drive vendor (such as MaxBlast from Maxtor or Data Lifeguard from Western Digital) has been used to move the data from the old to the new drive.

    1. Click Start | Control Panel | Administrative Tools | Services.
    2. Right-click System Restore Service and click Properties.
    3. From the Startup Type drop-down, select Disabled.
    4. Click OK.
    5. Close the Services and Administrative Tools windows.
    6. Right-click My Computer, click Properties, and click the System Restore tab. The System Restore tab should now display properly; however, the System Restore service will be disabled.
    7. Enable System Restore and click Apply.

    Note: All previous restore points will be removed.

    Try this first.


  • Tony, you are one smart fella, your second post worked like a charm. I had gone there but just shut it down w/o going into properties which didn't work. Thank you very much for your help!!!!!!
    I have already made a restore point. Thank you, thank you, thank you!
  • Charlietoo,
    You're welcome.  Thanks for posting back.  Helps everyone reading these posts if we know how a specific problem was resolved.

    Message Edited by tgsmith on 04-20-2007 12:08 PM