Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

Dell PowerEdge R710 and RHEL 6.2 (UEFI enabled)

This question has suggested answer(s)

We recently bought Dell PowerEdge R710 server with 6X1TB of storage and 16GB of memory. I had enabled UEFI boot and installed RHEL 6.2 on it. System installation looks like fine, it successfully installed. The problem is once I reboot after complete installation it always end up on GRUB prompt.

Does anyone have similar issue?

I really appreciate your help.



All Replies
  • According to this article GRUB should still load in a UEFI environment.


    The /boot/efi/EFI/redhat/ directory contains grub.efi, a version of GRUB compiled for the EFI firmware architecture as an EFI application. In the simplest case, the EFI boot manager selects grub.efi as the default bootloader and reads it into memory. "

    They have a good write up here.

    That you could use to double check and make sure no steps were missed.

    Let us know.


    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • I already read the couple of times. I did everything as mentioned there, still didn't work.

    I also tried by changing /boot partition type into ext3 as suggested and using 64-bit installation.



  • I highly suggest you open a case with RHEL for that. They need to know that 6.2 is doing that.

  • Is there new version of UEFI available for R710 server? It currently has UEFI version 2.1 on it. I would like to upgrade it to the recent version at least version 2.2 if available. In RHEL documentation it says version 2.2 or later, I think it might be the issue.



  • I am not able to find any documentation showing the UEFI version being updated to 2.2 or 2.3. But if it is available then it would be with the USC update.

    All of the updates including the USC, BIOS, RAID controller, etc. Can be downloaded from our support site.


    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • I couldn't find any option for USC listed on list you sent.

  • Here you go:

  • I checked USC version. It already has a recent version.

  • maybe you can see the blog.

  • After trying to figure this out with several Dell reps, I have an answer. RHEL 6.2 and the PERC 6/i RAID controller have issues booting a GPT partition over a certain size (we're guessing 2 TB, but that's just a guess). The answer from Dell for now is to buy the H700 RAID controller which is certified with RHEL 6.2. Hopefully they (Redhat and/or Dell) will address this problem soon.

  • Have you let it sit on that grub prompt for a while? Sometimes I have noticed after installing 6.2 that it will hang there for longer than expected and will finally kick into loading the OS.

  • Just to follow up: the Perc 6/i + RHEL 6.2 combination is absolutely at fault here. I just got the H700 card setup in my two R610's and it worked immediately - no further changes made besides swapping the 6/i for the H700 and plugging the card into the backplane.