Help: PE R610 - System Services/UEFI Problems After firmware update - PowerEdge General HW Forum - Servers - Dell Community

Help: PE R610 - System Services/UEFI Problems After firmware update


Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

Help: PE R610 - System Services/UEFI Problems After firmware update

This question is not answered

I updated all of the firmware that could be updated via the UEFI based configurator on my R610.

After restarting the F2 - System Services option on boot is already selected for me. It gets to the large Dell logo, with the "Entering System Services...Starting Unified Server Configurator", but hangs there. After about half an hour I reboot (soft reboot with ctrl-alt-del, it responds to this),

Now it will do the same thing at start-up, but when it gets to "Initializing Remote Access Controller" it will eventually give the message:

"iDRAC6 Communication failure.

Unable to launch System Services.

System halted!"

When I restart, where "F2 - System Services" usually is I see "System Services Disabled". It will then give the same
"iDRAC6 Communication failure", but says I can press F1 to continue or F2 to enter system set-up. F2 takes me to the BIOS, F1 boots the server. It warns me about the possibility of server shutdown due to power supply overload.

This server did run Linux - but I have since installed Vista to troubleshoot. I have tried re flashing the Lifecycle controller and the iDRAC6 firmware but it fails for both - my guess is because to boot an OS it has to have System Services Disabled???

Hoping I don't have to RMA the box...


I have also tried the Systems Build and Update Utility. This would only see the Bios, SAS backplane, NICs, etc. as items with upgradable firmware, nothing for iDRAC, UEFI, etc.

All Replies
  • I found a solution. It seems that in order to get the firmware updates to complete. iDRAC6 must be enabled, we don't use it, so I had just disabled it. In order to enable it there seems to be a race condition, where when you enter iDRAc configuration you must quickly toggle it enabled then save, other wise I would receive a "Some settings could not be saved" then the server would reboot.

    So my solution:

    -Shutdown server.

    -Remove power for ~30 sec

    -Power on

    -Use ctrl-e to enter iDRAC6 settings when prompted

    -Toggle idrac enabled, save/exit (time sesntive - must complete quickly)

    -Server auto-reboots and will successfully enter system services.