PowerEdge 1850 won't let me install any OS - Need to update Drivers but can't - PowerEdge HDD/SCSI/RAID Forum - Servers - Dell Community

PowerEdge 1850 won't let me install any OS - Need to update Drivers but can't


Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

PowerEdge 1850 won't let me install any OS - Need to update Drivers but can't

This question is not answered


I have a PowerEdge 1850, SCSI RAID 1 LSI Logic PERC 4e/Si , that recenlty crashed after being in service wihtout problems for some time.

I have been trying to re-install ESXi (which was on there previously) but the install would always hang with references to LinSCSI warnings that would just repeat and repeat in the log.

So, I scrapped that to get it back up and tried to get Windows Server 2008 to install but now get a variety of errors regarding missing drivers.


I take these problems to indicate that I should update the Firmware for the RAID, SCSI, etc but all the firmware available from the website for the LSI Logic PERC 4e/Si needs to have an OS installed or a floppy drive which I don't have either in the server or anywhere else. Any ideas on how I can get all the firmware updated so that I can try to get past this?

Thanks in advance.

All Replies
  • If you want to update the firmware without an OS, the easiest way is to use SBUU/SUU:

    Boot to this utility first and choose Firmware Update (SBUU):

    <ADMIN NOTE: Broken link has been removed from this post by Dell>

    When prompted for the Update Respository, then put in this DVD (SUU - note the installation instructions for the multiple ISO's, and total size is 6.8GB so you need a DL DVD or USB flash drive):Updating is a good idea, but it may not be necessary.  It would be helpful to know the exact error messages encountered.  For example, if you are getting a message about the CD/DVD Driver Missing, that usually means your 2008 media is bad (can also be your DVD drive), but if you need a driver for the PERC 4e/Si controller, then that's a different story (involving two parts).

  • Thanks for the info, I will try the updates and see how it goes.

    In regards to the errors I have received here is what I tried and the results:

    1) Tried to re-install ESXi using the exact same media I did (Direct from VMWare) before when it worked and receive errors regarding MEGARAID Warning LinScsi and then something about a drive or driver but the message is cut off on the screen

    2) Download and try to install ESXi directly from Dell, get same results as in method 1.

    3) Try to install ESXi again to USB instead of HDD with same results

    4) Try to install Windows Server 2008 RTM x64 and receive ERROR: 0x8007054D after COPYING step ( I beleive it is during Extracting step). This error suggests bad media I believe although the media I have I used recently (2 wks ago) and it is direct from MSFT and not a download.

    5) Try to download new Windows media so I downloaded Windows Server 2008 R2 (x64 is only option) and after Copying step and during extraction I get the message that CD/DVD Device Drivers are missing.  This is a bit confusing because it obviously read the DVD to get this far.

    So, after all these issues I am wondering instead if it is having a problem writing to the SCSI disks which led me down the path of wanting to upgrade all the firmware, etc. Just before all of this happend I was able to successfully configure my RAID 1 with the CTRL+M option during boot and used that utility to wipe the disks successfully.

    Let me know if this sheds any more light or if I am barking up the wrong tree.


    Thanks again

  • The CD/DVD drivers message seems to simply be a "catch-all" for when Windows Setup cannot read the disk - no drivers are actually required - it is nearly always a bad disk/image.  Given the number and kind of problems, I might suspect your CD/DVD drive.  I realize you tried from USB with ESXi, but since I'm not really an ESXi/Linux expert, I'm just kinda going with the Windows stuff ... I would try a USB install of 2008 or see if you have a different DVD drive.

    Again, only relating to the Windows errors, I don't think it is a problem with the disk drives.  For 2008R2, you will need the RAID drivers and you will need to configure RAID prior to attempting to install - and I believe it does say it requires a new version of RAID firmware, but I have successfully installed 2008R2 on older firmware before - it may not hurt to update the firmware to be safe.  If it is erroring out at the Copying stage, then it sounds like you're getting past the RAID driver/configuration question anyway.

    Good luck!