OMSA DRAC 5 stops working

Servers

Servers
Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

OMSA DRAC 5 stops working

This question is not answered

As soon as OMSA starts the DRAC stops responding.

This a dell 2950 rev II, with Windows 2008 R2 SP1

Firmware BMC 2.5, Drac 1.65

BIOS is 2.7

I have downgraded from OMSA 7.4, to 7.3, 7.1 and finally 6.5.  Tried racadm racreset racadm racresetcfg, nothing seems to work.  As soon as the OMSA services start, the DRAC stops working.  Rebooting causes DRAC to come alive until OMSA services start again in the OS

Verified Answer
  • This is the service that is causing the issue

    I installed an older version of OMSA and now everything is working correctly.  Apparently the newest versions of OMSA cause this issue, though I don't know exactly why.  This is the version that is currently installed and the drac is working

All Replies
  • Hello

    What stops responding? Are you unable to access the web server of the DRAC, does it stop responding to RACADM commands, or both?

    Uninstall OMSA and see if it works. Please be more specific as to what is not working.

    Thanks

    Daniel Mysinger

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • The web server of the DRAC stops working, and yes removing OMSA cause the DRAC to function again (following a warm or cold reboot of the server).

  • OMSA should not have the ability to do what you are describing. What you are describing is usually an IP address conflict.

    What mode is the iDRAC set to?
    What is the iDRAC IP address?
    What are all of the IP address on the server?

    Daniel Mysinger

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • It shouldn't, but it does.  I have two 2950's with DRAC 5's that do this.  They are both using shared, not dedicated.


    The address of the drac is 172.20.2.206, the server is 172.20.2.11.  When OMSA is uninstalled the DRAC works fine. It's definitely not an IP address conflict, as it is only when the service for OMSA start that the drac stops working.

  • I would suggest that you check any kind of security that you may be running like a firewall on the server, and anything you may be running on the network.

    How are you accessing the DRAC web server? Are you accessing it from the local server or from a different system? Has it ever worked?

    With OMSA installed tell me what happens when you go to this site on the local system:

    https://127.0.0.1:1311

    and this address on a different system:

    https://172.20.2.206

    Most switches will not allow the DRAC web server to be accessed from the local server when running in shared mode so make sure you try from a different system on the LAN and not the server itself.

    Daniel Mysinger

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • There server is a clean build of 2008r2, and the firewall isn't running.  Yes, it works when OMSA is stopped.  It worked under 2003 with OMSA installed.

    At present, with OMSA running you get the OMSA website when going to the loopback address

  • I downgraded the DRAC firmware and the issue seemed to go away. However moments later it stopped working again.

  • This is the service that is causing the issue

    I installed an older version of OMSA and now everything is working correctly.  Apparently the newest versions of OMSA cause this issue, though I don't know exactly why.  This is the version that is currently installed and the drac is working