Windows Server 2012 and WinXP remote desktop problem

Servers

Servers
Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

Windows Server 2012 and WinXP remote desktop problem

This question is not answered

I am having this problem for a month now, and i am stumped with trying to find an answer . I have talked with several network admins in my area and with no luck i have not found a solution. I have a windows server 2012 placed with 5 pcs that are connected on a local network , those 5 pc's connect to the server via remote desktop. List of pc's:

1x Windows 7

4x Windows XP SP3

All have the latests network drivers, all have the latest version of remote desktop installed. All have been scanned for viruses. All have antivirus software.

Problem is the 4 XP machines lose connection on when connected via remote desktop. If one starts losing connection the other 3 start to lose the connection aswell. The windows 7 machine is not affected by this it works fine.

What have I tried:

Scanning for viruses.

Disabling Firewall and antivirus software.

Updating all drivers.

Did many changes to group policy like keepalives etc.

Turning off SMBv2 SMBv3.

Turning off network adapter Offload settings.

Changed some registry settings like keepalive, smb etc.

Updating every pc and server with all windows updates.

Changed the router and switch.

Port forwarded needed ports like 3389.

Updating remote desktop version to 7.0.

I might be forgetting some stuff i will add as i remember anything.

So the thing is this. I use a Windows XP machine from my office I remotely connect to the server via the Internet and I DO NOT experience any connection loss. BUT the XP machines on the local network constantly experience connection loss via remote desktop. I pinged every Machine from the server via CMD command PING. So when they lose connection the Packets get time outs . Packets get dropped between 1-10 packets when a connection is lost. This packet drop does not occur when using the internet or anything else. ONLY when connected to the server via remote desktop. The packets get dropped at random intervals.

Problem is I use an XP machine and I am not experiencing any loss of connection , while the XP machines on the local network experience it , but not the windows 7 machine.

Router is ASUS RT-N53 , and switch is Dlink DES-1008D. Server is a Dell PowerEdge T110 II.

Can someone please tell me what can i do to solve this problem?

All Replies
  • Kingrun2,

    Have you updated to the latest RDP client? I found this kb referring to issues with Xp with 2008, which could easily translate to issues in 2012. Here is the kb w/ update - http://support.microsoft.com/kb/969084

    Also, have you verified you are running it as Administrator?

    Let me know.

    Chris Hawk

    Dell | Social Outreach Services - Enterprise
    Get Support on Twitter @DellCaresPro 
    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • yes all xp clients are running on rdp version 7.0 , and yes all of them are running as administrator

    EDIT: Forgot to add that to my post, edited it now.

  • Did you also enable NLA on the XPsp3 machines?

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa - 'Security Packages' Add 'tspkg' 
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders - 'SecurityProviders' Add 'credssp.dll'
     

    Reboot

    Test

  • Thank you. Just to confirm as I am fairly certain you have. As it allows the connection. Do you, under SYSTEM PROPERTIES on the 2012 system, have it selected to allow older versions to connect? It is a checkbox below the choice to Allow Remote Connections. ote Connections. 

    Chris Hawk

    Dell | Social Outreach Services - Enterprise
    Get Support on Twitter @DellCaresPro 
    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • No need to revert to less secure if you just enable NLA in winxpsp3.

  • This is what is selected

  • Pathping from XP clients to server and in reverse to see which device is responsible for packets loss.

    Off hours, direct connect an XP machine  to the server if possible, removing switches/routers or their settings out of the equation.

    Run TCP Optimizer on the XP machines, save the present config within the util, so you can reverse any changes.

    "Disabling Firewall and antivirus software."  Do not trust either to turn off properly

  • Meiners,


    Do you have the NICS set to auto negotiate or are they set for a specific speed? If set to auto could we set to a fixed speed and then test?

    Chris Hawk

    Dell | Social Outreach Services - Enterprise
    Get Support on Twitter @DellCaresPro 
    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • they are all set to auto negotiate , even the server is set to auto. Off hours doing that is not a possible option an option as I am not an employee of that firm. Does TCP Optimizer , automatically adjust settings, or are there specific settings need to be set? The antivirus and firewall seem to be turned off when i turned off. Checked ports if open when they are not forwarded etc. Seemed turned off.

    Also NICS if needed to know are Broadcom brand , even the server has a broadcom one in it.


    Problem is with the testing too. I usually gather as much stuff as I can, so that I can drive to their office and do as much as I can. Because its a 30min drive to their office. So I need as much options to do something as possible, and also I will do anything I can remotely if possible.

  • TCP optimizer automatically adjusts optimal setting, when you choose "optimal", do backup your original settings via the program; always nice to be able to revert changes. Safe, I used it on many machines/servers. Reboot is needed to apply new settings

    You could try turning off SMB signing, but with that you generally get other network issues; as a general   rule I turn it off during a fresh build. Not a bad idea anyway if there is no issue of internal security (man in the middle attack) , SMB signing slows network speed, can cause strange network issue.

    Aside from virus scan, have you run a rootkit scanner?

     

     

     

     

  • i believe that is disabled, I will double check the registry when i get the chance.

  • Had an issue the last couple days with RDP, really slow logins, which corrected today with new updates both on server and clients. Have you done Windows updates in the last couple days?

     

  • no new updates are showing up. Disabled SMB signing in GPO and Registry. Cannot restart the server atm on work hours. Will restart it after hours , to make the  changes effective.

    This is how it looks like when im pinging the 4 machines from the server, when they lose connection via remote desktop

  • Judging from that I don't think RDP is the issue. I'd say basic (TCP/IP) networking is the issue. If pings don't go through, all other network connectivity is affected.


    Are the server and the 5 desktops (Win7 and 4 x WinXP) all plugged directly into the same switch/hub, or are they going through patch panels, wall jacks or something like that?

    Member since 2003

  • its an office , with several rooms, the 3 winXP and 1 win7  machines are sitting near the switch and router. And there is one in another room that the cable comes from a wall jack . There is also a patch panel i think it resides in the same area where the router and switch are. If I do remember correctly. Though it baffles me that only the XP machines are affected.


    Also noticed, that two pc were not using RDP and were disconnected as shown in task manager. And they still got request timeouts.

    Maybe this is not a remote desktop issue?

    TASK MANAGER

    The 2 disconnected pc's ping screens: