Dell 2162DS KVM firmware update issues

Servers

Servers
Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

Dell 2162DS KVM firmware update issues

This question is answered

Hi

I wonder if somebody could help me, I have recently updated the firmware of our 2162DS KVM switch and since then I cannot access its web interface.

The update was initiated through its web interface by using the "filesystem" option. The firmware did upload successfully, then the switch hung up on rebooting itself. It has a Dell pull-out console attached to it, if I open that one I can see the Dell Logo bouncing like a screensaver, but that all, does not react to its keyboard or touch pad. Tried to power-cycle it, nothing changed.

Item still replies to ping and I can establish a connection to in by using putty-ssh, but I don't know its serial password, Admin and (blank) does not work.

Did anyone see something like that before? Any solutions/workaround?

Thanks in advance,

Peter

Verified Answer
  • Received replacement unit, configured and it works now. Gave the old one another try with the new serial cables...and it turned out that the old/original serial was faulty! The new one does display the KVM's boot menu through serial!

    Tried what the manual suggested, but in the alternate boon menu, the option "Boot Alternate" says "[INCOMPATIBLE]" so nothing really changed...at least I know the Original is not completely dead...

    Couldn't revive it anyway.

All Replies
  • Peter,

    You can try to downgrade your Java version to 1.7u40;  this is a workaround for connection issues only. Also check the release notes to see if there are specific brower issues as well.  The one you are using may be too new..

    Let us know..

     

    Geoff P
    Dell | Social Outreach Services - Enterprise


    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device!
    (iOS, Android, Windows)

  • Geoff,

    I don't think it has anything to do with Java. I did a port scan on it, got no reply from port 80 nor from 443. 22 is open though, that is SSH... Besides, since I have physical contact, I've attached a display and a keyborad, display shows the Dell logo bouncing like a screensaver, keyboard is dead.

    Tried to connect to it by its "SETUP" port with a serial cable today, didn't succeed. Will try that again tomorrow with an USB to Serial adpter, maybe its my laptop's COM port...its an old machine :)

    Peter

  • Found this in the manual:

    To recover from a Flash update failure:
    If after a Flash procedure, the RCS does not boot into the new firmware version, you may use the following steps to revert to the previous firmware version.
    1. Connect a serial cable to the SETUP port on the rear panel of the RCS.
    2. Run a terminal program on the PC connected to the Setup port. The serial port settings should be: 9600 baud, 8 data bits, 1 stop bit, no parity, and no flow control.
    3. Turn on the RCS.
    4. In the terminal program, when the prompt "Hit any key to stop autoboot" appears, press any key. A menu will be displayed.
    5. Enter <1> (Boot Alternate) and press <Enter>. The RCS will automatically reboot to the previous firmware version.
    6. After the RCS reboots, you can attempt the Flash upgrade
  • OK, that didn't work either, it does nothing but only SSL.

    Called support, what was kind of disappointing. Held the line for over 45 minutes then I got disconnected.

    Is this really acceptable anywhere? Is this why we bought 3yrs NBD support for our equipment?!

    So now what? Do I really have to buy another +2000$ equipment, just because I tried to apply an update what was marked as "urgent" plus followed the instructions of the readme file, what came with it?!

    Deeply disappointed!

  • Thanks for your email response. We are here to assist!

    Regards,

    Geoff P
    Dell | Social Outreach Services - Enterprise


    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device!
    (iOS, Android, Windows)

  • Support got in touch a few minutes later I got disconnected. Promised to get a replacement unit on Monday.

    Things look promising. Believe they are moving towards the right direction now.

    Thank you Geoff and Nabil Boukouchi

  • Received replacement unit, configured and it works now. Gave the old one another try with the new serial cables...and it turned out that the old/original serial was faulty! The new one does display the KVM's boot menu through serial!

    Tried what the manual suggested, but in the alternate boon menu, the option "Boot Alternate" says "[INCOMPATIBLE]" so nothing really changed...at least I know the Original is not completely dead...

    Couldn't revive it anyway.