iDRAC7 KVM keyboard and mouse not working in WinPE 5 - Systems Management Forum - Servers - Dell Community

iDRAC7 KVM keyboard and mouse not working in WinPE 5


Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

iDRAC7 KVM keyboard and mouse not working in WinPE 5

This question has suggested answer(s)

Hi. We have a strange problem here. Deploying servers remotely via iDRAC. When we boot via PXE to a WinPE 5 image (WS2012R2), keyboard and mouse are not working. When we boot WinPE4 (WS2012 (non-R2)) or older, it works fine.

The PE image is working fine, I've verified it in a virtual machine where I can use kb+mouse just fine.

What could be the problem? Some Java incompatibility? Or some iDRAC kb+mouse redirection problem regarding the latest WinPE?

I've tried this in Firefox (since I can't access the iDRAC at all from IE11 - it won't let me access HTTPS website with self-signed certificate at all).

We cannot use older version of PE, it has to be 5. The servers in question are M620s.

All Replies
  • I've managed to get IE11 to display iDRAC GUI correctly, but the problem persists, so I assume this won't be ActiveX vs. Java plugin problem, but something different.

  • Same problem here. ONLY when booting from PXE and using WinPE (we have a WDS), the mouse is not working. Sometimes I get it to work by switching the console from Native to JAVA or the other way around, sometimes by re-flashing the iDRAC with the same firmware.

  • dagwinstox, so you have a working keyboard?

  • I've got it working after updating iDRAC FW to 1.51.52 (from 1.51.51), which was released on 29th Jan. Not sure if it was the newer fw or the re-flashing that helped.

  • I spoke too soon, after a reboot, it doesn't work again :(

  • No keyboard, no mouse. Sometimes it works after shutting down the server and booting PXE again, but not always.

    Re-flashing sometimes helps, even with the same firmware version....

  • Map the WinPE ISO image as virtual CD and boot the server with the ISO resolved my issue. Keyboard and mouse working now.

  • That is an option, but we using Windows Deployment Services, so it kind of defeats the purpose... :-(

    Still hoping Dell can resolve this with a firmware update.

  • I am seeing this issue also.

  • If you click multiple times in the virtual console while WinPE is booting the mouse and keyboard will work.

  • nadogmoney

    If you click multiple times in the virtual console while WinPE is booting the mouse and keyboard will work.

    I've tried that of course, but that didn't get it working for me. Also, booting WinPE as Virtual CD is not an option for me, since the boot process is initiated remotely by SCVMM.
    Can anyone from Dell comment on this issue?
  • Clicking multiple time while PE is booting also didn't work for me. The only thing that worked every time is to close the virtual console, "update" the DRAC firmware (even with the same version as the existing firmware), logon again after the firmware upgrade has finished and re-launch the virtual console. I can than pick up where I left, this time with mouse and keyboard working.
  • All,

    We have received this request and are working on an update that will be released soon to address these issues you and others are experiencing. We would suggest as a temporary solution to  back-flash your iDRAC from 1.51 to 1.46 to resolve for now. 

    Geoff P
    Dell | Social Outreach Services - Enterprise

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device!
    (iOS, Android, Windows)

  • Thank you for the information Geoff, at least now we know the problem is not on our end.

  • Hi Geoff, I flashed the firmware on 5 systems to 1.46.45 (build 4), but still the same problem: no keyboard or mouse when booting from the network into WinPE. Flashed them again with 1.51.52 and now I have keyboard and mouse and can continue from where I left off. We are re-installing 50-60 systems, so there is quite an amount of extra work and time lost with this, I hope Dell finds a solution soon.