DRAC6 Static IP issue with Cisco switches

Servers

Servers
Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

DRAC6 Static IP issue with Cisco switches

This question is not answered

When I assign a static IP to dedicated port on drac6 enterprise none of my switches will see a MAC on the switchport.

When I switch DRAC to DHCP it shows and works fine.

I have several dozen servers of various models (r210, r410, r510, r515, r610, r710) and they all have the same problem.

I also have several hundred switches and confirmed this is an issue on every switch I've tested ranging from Cisco 2950, 4500, 3560 and various OS versions from 12.2 - 15.0

They work fine on Juniper switches just not Cisco.  

All Replies
  • Hello mmacnish

    When the IP is static the MAC is sent using gratuitous ARP. To avoid the GARP being missed when a switchport is in a learning mode the iDRAC has been designed to send the GARP every 30 seconds. Since it is working fine on the Junipers we know the GARP is being sent. The issue is with the Cisco switches receiving or updating the MAC table.

    There are security features to disable GARP on the switch. I would suggest that you start by checking to see if GARP is being allowed on the switch:

    http://www.cisco.com/en/US/docs/ios-xml/ios/ipaddr/command/ip_arp_gratuitous_through_ip_dhcp_ping_packets.html

    Thanks

    Daniel Mysinger

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • I followed the advice and it was correct. We also had the same problem with HP ilo.