PowerVault NF600 Driver & Hot Spare

Servers

Servers
Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

PowerVault NF600 Driver & Hot Spare

This question is not answered

Just happened to stop by & look @ my NF600 (PERC 6/i) ast week.  Surprised to find that drive 0:0:2 was showing as failed in the LED display.  OSMA has been configured to send email alerts now so I should get immediate notice next time.

I dropped in a spare drive and the rebuild started automatically.  But I got to thinking, didn't I have a dedicated hot spare configured ? I checked & sure enough drive 1:0:7 is configured as a dedicated hot spare.  So why did it not rebuild to this drive automatically?

The configuration is 0:0:0 & 0:0:1 in VD0/RAID1 (OS volume) & 0:0:2 - 0:0:3 plus 1:0:4 - 1:0:7 in VD1/RAID5 (data volume) with 1:0:7 being the dedicated hot spare.

Also, Firmware/Driver Information... shows "Driver version is out of date."  I checked the Dell support site and the driver I have, 2.24.00.64, is the latest available.  It does display

Storport Driver Version 5.2.3790.3959
Minimum Required Storport Driver Version 5.2.3790.4173

and I've downloaded that version of the Storport driver but I am wary of installing it since it's a hotfix and I'm not having any issues with the system.

Any ideas??? 

All Replies
  • You have two VD's configured ... which VD is the hot-spare dedicated to?  Global hot-spares will rebuild in place of any VD (for which the disk qualifies - big enough, type, etc.), but Dedicated are assigned to specific VD's.

    The storport driver is the storport interface driver for the controller from Microsoft and is only available via hotfix.