WOI for Poweredge 1950

Servers

Servers
Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

WOI for Poweredge 1950

This question is answered

I have a rack with several different generations of Poweredge 1950 and some R610s.  I want to remotely (WOI) start, stop and operate the systems in the rack.  The systems do not have the DRAC boards installed.

I have setup WOL for all systems and can start and stop them all on the LAN just fine.  If I can remotely start a single p1950 system, then I can easily start and stop all systems using that single system.

But I can not get the single p1950 system to start remotely.  I have set Port Forwarding on my DSL modem/router to forward UDP 9 to the system and it sees the magic packet just fine... but it will not power on.

I am unfamiliar with the DRAC boards and the various remote management tools but from the reading I've done... it seems possible to be able to power on and off the machine from the Internet.

Can someone please explain what I would need to be able to remotely power on the system?

Can I do it without a DRAC board installed?

What software is needed to send connect with the system and send the signal to power on?


Thanks!

Verified Answer
  • You can use ipmitool to power on and power off server. For this you does not require DRAC. You need to follow below steps to setup this

    1. Configure IP address and enabled IPMI over lan to iDRAC or BMC.
      1. R610 will have iDRAC by default. For more details refer section "Using the iDRAC6 Configuration Utility" on iDRAC User Guide. You can download iDRAC user guide from here

        ftp://ftp.dell.com/Manuals/all-products/esuprt_electronics/esuprt_software/esuprt_remote_ent_sys_mgmt/integrated-dell-remote-access-cntrllr-6-for-monolithic-srvr-v1.95_User%27s%20Guide_en-us.pdf

      2. On 1950 you need to configure BMC. You can configure IP address and IPMI over lan during boot similar to R610

    2. Install ipmitool on a client machine. You can download ipmitool from here
    3. Run the following command to power on the server

    ipmitool -I lanplus -H <iDRAC / BMC IP Address> -U <iDRAC / BMC Username> -P <iDRAC / BMC Password> power on

    Run following command to get help on this command

    ipmitool -I lanplus -H <iDRAC / BMC IP Address> -U <iDRAC / BMC Username> -P <iDRAC / BMC Password> power

     

    Thanks-

    Shine

All Replies
  • Any ideas?

    I have some DRAC boards on order... not sure if they will help.


    Yesterday, I tried sending the magic packet from a remote computer... it didn't start the desired computer.  Then I used Telnet to connect to the modem/router of the LAN and looked at the ARP listing of IP addresses in the router.  The desired computer was not in there.  So I used ARP to add the desired computer to the list.  I then sent the magic packet again and the desired computer started.

    But today (even though the ARP listing is still there) the remote magic packet will not start the computer.

    Aren't there Dell tools to remotely start and stop servers?  What minimal software is required to cycle power on servers remotely/reliably?

    Thanks.

  • So I try to send the WOL magic packet from my local LAN... the desired computer does not start.  So I start the desired computer manually with the power button.  Then I shutdown the desired computer and then send the WOL magic packet from my local LAN again... the desired computer starts.  Then I shutdown the desired computer again and send the WOL magic packet from my remote system... the desired computer starts.

    It seems that the desired computer is going into some kind of sleep mode overnight and WOL won't wake it.  It will only work after the computer has first been started manually... which is of course, not workable.  I need it to be reliably started remotely.

  • You can use ipmitool to power on and power off server. For this you does not require DRAC. You need to follow below steps to setup this

    1. Configure IP address and enabled IPMI over lan to iDRAC or BMC.
      1. R610 will have iDRAC by default. For more details refer section "Using the iDRAC6 Configuration Utility" on iDRAC User Guide. You can download iDRAC user guide from here

        ftp://ftp.dell.com/Manuals/all-products/esuprt_electronics/esuprt_software/esuprt_remote_ent_sys_mgmt/integrated-dell-remote-access-cntrllr-6-for-monolithic-srvr-v1.95_User%27s%20Guide_en-us.pdf

      2. On 1950 you need to configure BMC. You can configure IP address and IPMI over lan during boot similar to R610

    2. Install ipmitool on a client machine. You can download ipmitool from here
    3. Run the following command to power on the server

    ipmitool -I lanplus -H <iDRAC / BMC IP Address> -U <iDRAC / BMC Username> -P <iDRAC / BMC Password> power on

    Run following command to get help on this command

    ipmitool -I lanplus -H <iDRAC / BMC IP Address> -U <iDRAC / BMC Username> -P <iDRAC / BMC Password> power

     

    Thanks-

    Shine

  • Thank you VERY much for this guidance!  I am now able to power on and off the system as desired.

    Thanks again!

  • OK, so thanks to the help I've received here... I can remotely power ON/OFF my server.

    This is currently working via IPMI using UDP port 623.  But I have multiple servers that I would like to be able to control.  Currently, the port forwarding of the router is set to port forward UDP 623 to serverA.  If I want to control serverB... I must edit the port forwarding in the router of UDP 623 to point it to serverB, etc.

    This can be done remotely, but it is a hassle to have to do this each time I want to control a different machine.  Ideally, I would want to setup multiple port forwards for all the servers and then use the IPMItool to specify which machine I wanted to control by changing the port used.  But I can only make the IPMItool use port 623.  I thought I found that I could use the -p option to specify the port used by ipmitool, but it doesn't seem to work.

    For example, if I port forward UDP port 40000 to a particular server and then tell the ipmitool to use -p 40000... it doesn't connect.

    Is it possible to specify which UDP port is used?


    Thanks!