racadm not detecting local RAC

Servers

Servers
Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

racadm not detecting local RAC

This question is answered

Hello,

We have a Dell PowerEdge 720XD with iDRAC 7 Enterprise. I can use the web interface on it to initialise/format/etc an 8GB SD card fine, however, am limited to uploading image sizes greater than 2GB and from my research I need to do this through the command line.

I have installed the RAC Admin tools from the Open Manage Systems Management Tools and Documentation DVD which provides racadm.

Running racadm on this server returns the following error:

IMPORTANT NOTE!
The RAC is unable to communicate with the BMC. This condition may
occur because of (1) no BMC is present, (2) missing or disfunctional
IPMI-related software components. Many RAC features depend on BMC
connectivity in order to work properly, and you may see failures
as a result.

I can access the RAC fine remotely, however, wanted to do it locally.

Installing the RAC Admin tools on a Dell PowerEdge T320, also with iDRAC 7 Enterprise, does not yield the same problem and works fine.

Any ideas what might be up with my PowerEdge 720XD? I guess next step is checking firmware is up to date? It was up to date when I installed the server about two months ago.

Verified Answer
  • After many failures downloading the updated OM_SMTD_730_A00.iso from the Dell Australia support site I managed to get it from the Dell US support site. Installing the full tools now allows me to query the server locally.

    Previously I was trying with OM SMTD 7.20.

    Thanks for your help.

All Replies
  • You need to install server administrator for racadm to work locally. Please uninstall Rac Tools and install Server Administrator and let me know the result. Rac tools is used for remote  connectivity.

    Thanks-

    Shine

  • Hi, thanks for the reply.

    I had already tried that, I forgot to mention it. Further, installing "just" the RAC Admin tools was sufficient to manage the local RAC on a different server. I will try uninstalling and reinstalling on the problematic server.

  • After many failures downloading the updated OM_SMTD_730_A00.iso from the Dell Australia support site I managed to get it from the Dell US support site. Installing the full tools now allows me to query the server locally.

    Previously I was trying with OM SMTD 7.20.

    Thanks for your help.

  • Hmm I replied a couple of hours ago but I can't find my post now...

    After some troubles downloading the OM_SMTD_730_A00.iso file from the Dell AU support site I was able to grab it from the Dell US support site.

    Installing the full System Administration software allowed me to connect to the local RAC. As you stated the RAC Admin tools were not enough. Curiously they were on a different server though Tongue Tied

    To reiterate OpenManage Systems Management Tools and Documentation 7.2.0 did not work, however version 7.3.0 did.

    Thanks for your help.

  • I just reinstall DEll OMSA from server. Installed OMSA 7.4. reset iDRAC from command line.

    Now able to open iDRAC page with out any error.